+ Post New Thread
Page 4 of 7 FirstFirst 1234567 LastLast
Results 46 to 60 of 105
O/S Deployment Thread, Complete guide to WDS...question in Technical; You could add those lines into a .cmd batch file and then add that file as an application to install ...
  1. #46
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,258
    Thank Post
    218
    Thanked 231 Times in 200 Posts
    Rep Power
    74
    You could add those lines into a .cmd batch file and then add that file as an application to install during the task sequence. If you have it as the last app to install that should hopefully work, I do something similar. There is a freebie add-in somewhere that you can download that lets you re-order the applications so they install in an order of your choosing - a feature that is not built into MDT for some reason :-/

    As for the drivers question, I have almost all my drivers in the one folder, the deploy picks up the correct ones for the machine just fine

  2. #47

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,767
    Thank Post
    873
    Thanked 673 Times in 442 Posts
    Rep Power
    502
    Quote Originally Posted by themightymrp View Post
    You could add those lines into a .cmd batch file and then add that file as an application to install during the task sequence. If you have it as the last app to install that should hopefully work, I do something similar. There is a freebie add-in somewhere that you can download that lets you re-order the applications so they install in an order of your choosing - a feature that is not built into MDT for some reason :-/
    Not sure about most of this as I was always doing to a Domain PC, however, if you are using KMS, then this gets published to DNS and should get found by the client (Don't take this as read as I am not 100% on it!)

    Application ordering can be done from within MDT.. either via the database management side or by using Application Bundles (see here for more info), you can also use dependancies to ensure they get installed in the correct order....

    As for the drivers question, I have almost all my drivers in the one folder, the deploy picks up the correct ones for the machine just fine
    This is fine for the actual deployments, but not for when you are booting into WinPE - you need to inject the relevant drivers (NICs and Mass Storage) directly into the boot image otherwise it will fail before it can connect to the MDT Deployment point..

  3. #48
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,258
    Thank Post
    218
    Thanked 231 Times in 200 Posts
    Rep Power
    74
    Fair point. Once I import my network/storage drivers I update the deploymentshare and replace the litetouch.wim file as a matter of course so yes you're right.

    I don't use the database side of MDT (no reason other than being bothered to set it up) and the bundles/dependancies isn't suitable for me as I like to select various combinations of software depending on the room/laptop etc. So the free download allows an easy way to view the list of apps and use an up & down arrow button to shuffle them around

  4. #49

    Join Date
    May 2012
    Posts
    301
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    The command line worked. The machines activate themselves weather on the domain or not.

    Has anyone used the "Join Domain Prompt" does it work? That would be nice for lab machines. Will give it a try tomorrow.

    I was wondering if anyone knew how to set certain local security rules? I could edit them via command line if it is possible? I want to remove remember last logged on user, and AlT-CTRL-DEL screen to not appear.

    Also, is there a way to launch a bat file as an application? It would be nice to see in the list of application to install a box with [CSS LAB SCRIPTS] [DOMAIN USER SCRIPTS] as choices?

  5. #50

    Join Date
    May 2012
    Posts
    301
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Looks like i can run batch files off a networkshare if i select application without source files / network share option!

  6. #51
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,258
    Thank Post
    218
    Thanked 231 Times in 200 Posts
    Rep Power
    74
    You can, or if you rename them as .cmd instead of .bat they can be added as applications. I have numerous applications which are just batch files which launch various installs from the network.

    Are the machines you are deploying to going to be on a domain or standalone? If they are joining a domain the you can turn off the features you want via Group Policies. If they are standalone you could always try to find the registry keys that govern those settings and then create a .reg file that can be imported from command line?

  7. #52

    Join Date
    May 2012
    Posts
    301
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I guess the machines which I want last user not remembered and disabling of ALT CTRL DEL screen are the labs, so they will be on the domain. Time to knock on the AD guys door!

  8. #53

    Join Date
    May 2012
    Posts
    301
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Went to pxe boot this morning, and now im getting an Windows PE has encounter and environment error? This is a pop up at the splash screen for MS Solution Accelerators

  9. #54

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,767
    Thank Post
    873
    Thanked 673 Times in 442 Posts
    Rep Power
    502
    9/10 the reason for this is a failed deployment - best bet is to clean the disk and try again..
    MDT has a habit of not playing nicely if it doesn't end the wizard correctly - thereby leaving traces on the C: Drive...

  10. #55

    Join Date
    May 2012
    Posts
    301
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    looks like i have to browse out of the directory and then back into the boot directory to load up a newly update Lite x64 .wim boot file.

    Some things ive notice, when i run an install with a silent command it works from the CMD but not when MDT trys to do it...

    iTunes
    Sawtooth SSI Web
    Turning Point 2008
    Turning Point Anywhere
    Adobe Flash (distribution package)

  11. #56

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,767
    Thank Post
    873
    Thanked 673 Times in 442 Posts
    Rep Power
    502
    There was an issue with iTunes and silent installation IIRC..
    Something to do with Quicktime's MSI and it needed to be editted..

  12. #57

    Join Date
    May 2012
    Posts
    301
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    It's weird cause i extracted the .exe and ran /qn on itunes setup and then quicktime.exe /qn and they worked from the command line on my home laptop
    i might do those programs through batch over the network.

  13. #58

    Join Date
    May 2012
    Posts
    301
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    strange just tried it on a 790 desktop, and i got an error "could not locate partition"

  14. #59

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,767
    Thank Post
    873
    Thanked 673 Times in 442 Posts
    Rep Power
    502
    Yeah I remember this issue, but not the exact cause / solution

    Basically you could get Itunes to deploy silently when entered into a command line, but put the same switches into MDT and it failed
    It was something to do with at least one of the MSI files that had to be editted to get round it...

    Never tried it via a batch file so may be worth looking into

    (Thought the issue was on here somewhere but can't find it just now...)

  15. #60

    Join Date
    May 2012
    Posts
    301
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I will try the batch deployment. Do you know if i force restarts on applications, will MDT continue upon reboot? I feel like forcing a reboot between some software might help... but i dont wanna cancel out MDT.

SHARE:
+ Post New Thread
Page 4 of 7 FirstFirst 1234567 LastLast

Similar Threads

  1. [WDS] Clients boot to WDS no matter what option 66 and 67 are set to
    By bart21 in forum O/S Deployment
    Replies: 8
    Last Post: 13th May 2011, 04:18 PM
  2. [WDS] Connecting to WDS Server
    By edsa in forum O/S Deployment
    Replies: 4
    Last Post: 27th January 2011, 11:22 AM
  3. [WDS] Complete guide to
    By ravenadsl in forum O/S Deployment
    Replies: 0
    Last Post: 26th May 2010, 03:15 PM
  4. ISA 2000 to 2004 questions.
    By tosca925 in forum Windows
    Replies: 1
    Last Post: 21st September 2005, 08:50 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •