+ Post New Thread
Results 1 to 6 of 6
O/S Deployment Thread, Unable to move image files via FTP in Technical; Hello, I recently finished installing and configuring a fog server for our Auto Auction. It will service around 80 hosts. ...
  1. #1

    Join Date
    Mar 2012
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Unable to move image files via FTP

    Hello,

    I recently finished installing and configuring a fog server for our Auto Auction. It will service around 80 hosts.

    We have an Iomega Storcenter PX4 300r NAS. The Nas supports NFS and FTP protocols.
    When uploading an image from a host, everything goes fine until the last 1%, and then it errors saying it is unable to move from /mnt/pools/A/A0/fog/dev to /mnt/pools/A/A0/fog.

    If I manually rename and move the files, everything works fine and I can deploy the images.

    From what I gather it is a permissions issue, but when I use filezilla to connect to my nas the directories all show permissions set to 777. The newly written image file in the dev folder has different permissions 644.
    Is there a fog setting or file that I can edit to change the permissions for this file? I know I'm kind of reaching but it's all I can come up with...

    I'm kind of lost as how to proceed to resolve this issue...

    Thanks in advance for any help.

    Adam

  2. #2
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    816
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    40
    I think you would have to look for a umask setting on the NAS box, or look to try and match the owners id number with the id number for the FOG user on the server.

  3. #3

    Join Date
    Mar 2012
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    As far as a umask setting goes, I don't have that option. I am a beginner in Linux could you give me an idea how to find these resource ID's?

  4. #4
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    816
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    40
    On your fog server you can look at /etc/passwd to see the user ID:
    Understanding /etc/passwd File Format
    Hopefully on your NAS box you can set the ownership of the relevant directories with this ID number.

  5. #5

    Join Date
    Mar 2012
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Yeah I cannot execute a chown when I connect to my NAS via FTP. It's an unrecognized command.
    Last edited by arives; 23rd March 2012 at 04:17 PM.

  6. #6
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    816
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    40
    You can't use chown over FTP, you would have to set ownership and permissions through some other method. If it was a server you would do it through the shell, I would have thought your NAS box would have some kind of web interface to let you configure things like this. If your NAS supports iSCSI you could use this instead and it should be easier to configure the permissions as it's seen as local storage by the server. Or getting more complicated, you could virtualise the FOG server and use NFS for the VM storage. To be honest though you could use any old workstation as a storage node if the hard disk is big enough, just queue unicast deployments and everything will still be pretty quick.

SHARE:
+ Post New Thread

Similar Threads

  1. [Fog] Unable to Upload Image of Netbook
    By mwbutler in forum O/S Deployment
    Replies: 10
    Last Post: 21st March 2012, 04:40 PM
  2. [MS Office - XP] The graphics filter was unable to convert this file
    By Arcath in forum Office Software
    Replies: 0
    Last Post: 10th November 2010, 09:25 AM
  3. Replies: 2
    Last Post: 17th October 2009, 03:55 PM
  4. unable to open ms files
    By e_g_r in forum Office Software
    Replies: 7
    Last Post: 25th April 2008, 03:36 PM
  5. Users unable to permanently delete files.
    By secman in forum Windows
    Replies: 13
    Last Post: 5th October 2006, 11:48 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •