+ Post New Thread
Results 1 to 4 of 4
O/S Deployment Thread, Apache error updating fog to .32 in Technical; Hi Guys. Any help much appreciated. Tried to update FOG .29 too .32. (This on Ubuntu 10.04 LTS) ran ./installfog.sh ...
  1. #1

    Join Date
    Oct 2011
    Location
    South Africa
    Posts
    2
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Exclamation Apache error updating fog to .32

    Hi Guys. Any help much appreciated.
    Tried to update FOG .29 too .32. (This on Ubuntu 10.04 LTS)
    ran ./installfog.sh
    and get the following error:


    Configuring services.

    * Setting up fog user...Exists
    * Setting up and starting MySql...OK
    * Backing up user reports...OK
    * Setting up and starting Apache Web Server...Failed!

    Tried restarting Apache - no joy.

    sudo /etc/init.d/apache2 restart

    * Restarting web server apache2
    apache2: Syntax error on line 204 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open shared object file: No such file or directory
    Last edited by Tomcatkzn; 19th October 2011 at 01:05 PM.

  2. #2

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,803
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224
    The error is telling you php v5 isn't installed.

  3. Thanks to Geoff from:

    Tomcatkzn (19th October 2011)

  4. #3


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    try
    Code:
     sudo apt-get install php5

  5. Thanks to CyberNerd from:

    Tomcatkzn (19th October 2011)

  6. #4

    Join Date
    Oct 2011
    Location
    South Africa
    Posts
    2
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks guys. Still new at linux.

    ran
    sudo apt-get install php5

    and got another error about stuff missing. So went to the package manager and selected libapache2-mod-php5
    It said that to install that something else had to be uninstalled which I accepted. The install completed fine.
    I ran the fog install again and it worked perfectly.
    Yeehaa
    Thank guys.

    (Sorry about lack of detail, but power is out so am on my Samsung i9000)
    Last edited by Tomcatkzn; 19th October 2011 at 02:10 PM.

SHARE:
+ Post New Thread

Similar Threads

  1. [Fog] Update FOG installation to latest version
    By TechSupp in forum O/S Deployment
    Replies: 7
    Last Post: 3rd November 2011, 10:02 AM
  2. [Fog] Updating FOG client
    By Stevoid in forum O/S Deployment
    Replies: 3
    Last Post: 12th October 2010, 09:52 AM
  3. Error when trying to update driver
    By ChrisH in forum Promethean Direct Support
    Replies: 11
    Last Post: 16th November 2009, 02:59 PM
  4. "Error 403" & "Moved to here" message
    By tech_guy in forum Windows
    Replies: 4
    Last Post: 24th January 2008, 01:07 PM
  5. Error when trying to deploy XP via BDD
    By Gatt in forum Windows
    Replies: 0
    Last Post: 24th January 2008, 12:04 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •