+ Post New Thread
Results 1 to 8 of 8
O/S Deployment Thread, FOG auto restart/renames. I don't want it to! in Technical; Hi folks - completely new to FOG, having a bit of a falling out at the moment. Long story short ...
  1. #1
    El_Nombre's Avatar
    Join Date
    Sep 2008
    Posts
    288
    Thank Post
    63
    Thanked 25 Times in 19 Posts
    Rep Power
    18

    FOG auto restart/renames. I don't want it to!

    Hi folks - completely new to FOG, having a bit of a falling out at the moment.

    Long story short is we took a disk image of a machine locally, which we HAD intended to have FOG rename for us but for various networking issues on the day it wouldn't after several restarts of the client.

    I've used that image we took locally now on another machine, but THIS machine is now restarting constantly thanks to FOG and renaming itself to the name of the ORIGINAL machine whenever it's restarted.

    I have access to the FOG console and had meant to get to grips with it one of these days, but was hoping it wouldn't be on unpleasant terms!

    What do I need to change on the FOG server to stop this mischief?

    Many thanks for reading!

  2. #2

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,070
    Thank Post
    210
    Thanked 430 Times in 310 Posts
    Rep Power
    144
    Not sure why the machine should be re-naming its self as the name of the origenal machine. Anyhow, it's quite easy to disable that service, you can do it on a global or individual client level.

    Log into the fog console, and click the 'hosts' tab and search for the correct host that you want to stop re-naming its self.
    Click the Edit icon at the end of the line
    Select service settings from the left hand menu
    Un-tick the box that says 'hostname changer enabled' this will stop the FOG client re-naming the machine.
    Save the settings.

    The client will need a re-boot to pick up the new settings from the FOG server.

    If you want to disable the renaming service globally, you can do that from the Services menu, select hostname changer from the left hand menu, remove the tick from the box and save the settings.

    Mike.

  3. Thanks to maniac from:

    El_Nombre (3rd March 2011)

  4. #3
    El_Nombre's Avatar
    Join Date
    Sep 2008
    Posts
    288
    Thank Post
    63
    Thanked 25 Times in 19 Posts
    Rep Power
    18
    Ah that sounds like it! I'll run off and see if that does the trick.

    Yeah I found the option to globally disable it but I'm loth to. FOG's kinda useful that way when it's working alright (from my limited experience with the thing.)

    Thanks so much for the help!

    EDIT - urgh. No it's still doing it. Chopping the Hostname changer. (EDIT2 - Which HAS now sorted it) I'd love to be able to use the FOG server but with the way things are here it's going to have to wait until I've got a spare afternoon to read up on. 'orrible thing.

    Cheers again for helping me out though.
    Last edited by El_Nombre; 3rd March 2011 at 02:25 PM.

  5. #4

    Join Date
    Sep 2011
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I image computers and let my students deploy them out into the classrooms. As such I want the names to stay set (all the same) because they autologon 1 time as a local admin for the AD joining. I also DO NOT want Fog to rename them at all. No problem until I recently upgraded and now it renames them to the NIC address, which breaks the autologon of the image. Worked fine until the recent upgrade.

    I tried turning off renaming globally but that did nothing, still renames them to the NIC.

    Thoughts? Really don't want to go backwards!

    Brian

  6. #5

    Join Date
    Oct 2005
    Posts
    853
    Thank Post
    51
    Thanked 116 Times in 106 Posts
    Rep Power
    75
    Perhaps just don't include the Fog client in the system build? or when installing the client don't select the "hostname changer" module.

  7. #6

    Join Date
    Nov 2010
    Posts
    467
    Thank Post
    61
    Thanked 72 Times in 59 Posts
    Rep Power
    34
    Quote Originally Posted by bapool View Post
    I image computers and let my students deploy them out into the classrooms. As such I want the names to stay set (all the same) because they autologon 1 time as a local admin for the AD joining. I also DO NOT want Fog to rename them at all. No problem until I recently upgraded and now it renames them to the NIC address, which breaks the autologon of the image. Worked fine until the recent upgrade.

    I tried turning off renaming globally but that did nothing, still renames them to the NIC.

    Thoughts? Really don't want to go backwards!

    Brian
    Fog uses the mac address to link names to hosts. Set the host name on the host management page and you'll be fine.

    Fog can tell you the mac of a machine from the pxe boot menu if it helps.

  8. #7

    Join Date
    Nov 2010
    Posts
    467
    Thank Post
    61
    Thanked 72 Times in 59 Posts
    Rep Power
    34
    Quote Originally Posted by El_Nombre View Post
    Hi folks - completely new to FOG, having a bit of a falling out at the moment.

    Long story short is we took a disk image of a machine locally, which we HAD intended to have FOG rename for us but for various networking issues on the day it wouldn't after several restarts of the client.

    I've used that image we took locally now on another machine, but THIS machine is now restarting constantly thanks to FOG and renaming itself to the name of the ORIGINAL machine whenever it's restarted.

    I have access to the FOG console and had meant to get to grips with it one of these days, but was hoping it wouldn't be on unpleasant terms!

    What do I need to change on the FOG server to stop this mischief?

    Many thanks for reading!
    Is the client machines name correct against its mac address on the host management page?

  9. #8
    ssx4life's Avatar
    Join Date
    Sep 2009
    Posts
    106
    Thank Post
    0
    Thanked 12 Times in 12 Posts
    Rep Power
    13
    correctly.

    All computers are tied to the mac address. If you reimage a host and have a different name for the machine the hostnamechanger.dll in the fog client will compare that against the database and update it for you.

    Check the mac address of the computer against your current computers and update it to what you want.

SHARE:
+ Post New Thread

Similar Threads

  1. Home folders renames to My Documents
    By bewlay51 in forum Windows Server 2008
    Replies: 41
    Last Post: 19th September 2013, 08:46 AM
  2. [Fog] Fog Documentation: How to delete a group of computers in FOG
    By ssx4life in forum O/S Deployment
    Replies: 1
    Last Post: 9th November 2009, 01:59 PM
  3. Vista Renames Server 2003 home folders
    By MACLURE-E in forum Windows Vista
    Replies: 14
    Last Post: 27th January 2009, 08:31 PM
  4. Drive mapping renames not working on new machines
    By mullet_man in forum Scripts
    Replies: 6
    Last Post: 9th August 2007, 11:48 AM
  5. Turn off auto restart
    By richard in forum Windows
    Replies: 2
    Last Post: 25th June 2007, 07:49 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •