Hello all,

On Friday(Apr 2010) I tried rolling out an XP Pro image to 30 Toshiba NB300-108 Notebooks using Windows 7 boot.wim (WinPe3) and Server 2003 without any success, they kept getting stuck at Expanding Files (1%). I could apply the 5GB image in 8 minutes using a bootable USB stick with WinP3 and an external hard drive.

The cause of the problem is the network driver included in Windows 7 for the RealTek RTL8102/3E PCI Express adapter.

Here is the solution that fixed the problem for me; the solution comes first with the other failed attempts to solve it afterwards.

What you will need:
For Toshiba NB300-108 Notebooks the Windows 7 Network driver for the RTL8102E/RTL8103E Pci-Express NIC:

Realtek

WAIK 6.1 for Windows 7 as you will need DISM to manage the Windows7 boot.wim.


N.B. When working with Wim files it is always a good idea between working with different Wim files to run:
DISM /Cleanup-Wim

N.B.2 It also a good idea to check how many images are in the wim file by using:
DISM /Get-WimInfo /wimfile:file.wim

The Windows 7 boot.wim has two images, a WinPE3 at index:1 and Windows 7 at index:2. If you add the driver to the WinPE section it will import fine in to WDS but will not show up in the boot selection menu, hence checking how many images there are ;)

So we will mount the 2nd image:

DISM /mount-wim /wimfile:"D:\32bit Deploy - Windows 7 based.wim" /index:2 /mountdir:D:\Mount

Add the driver, DISM should automatically find the inf file. If you need to add more drivers from the same folder tree you can now do a recursive find, just add /recurse

DISM /Add-Driver /Image:D:\Mount /Driver:D:\Drivers\RealTek\RTL8102E

We can now commit the changes:

DISM /Commit-Wim /MountDir:D:\Mount /commit

Now name the wim file an updated version number and /or description and replace/re-import it in to WDS.

I hope this helps everyone else who gets these notebooks.

Other things I tried on the Friday to get it to work. Some further background, the School's site had a Dell PowerEdge 1800 with Intel Pro 1000MT network card and NetGear FS726T switches.

Updating the Server's driver had no effect.

Plugging a client directly in to a gigabit port on the switch with the Server in the other gigabit port had no effect.

Some others have stated that swapping in a different network card has fixed it; it didn't in this case. Put in an Intel 100 PCI NIC, no effect. Can't find reference, sorry.

Some people have had very very slow deployments, e.g. 72hours or more using Server 2003/R2 they suggested this article on disabling Scalable networking. Can't find original reference, sorry. An update to turn off default SNP features is available for Windows Server 2003-based and Small Business Server 2003-based computers
These settings were already set to 0 (disabled) in the registry.