+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 30
O/S Deployment Thread, netdom driving me insane in Technical; Hello all, Have a bit of a issue with netdom and Fog. I've entered all of the details in the ...
  1. #1
    stevehp's Avatar
    Join Date
    Jul 2008
    Location
    Ohio
    Posts
    102
    Thank Post
    13
    Thanked 19 Times in 16 Posts
    Rep Power
    16

    netdom driving me insane

    Hello all,

    Have a bit of a issue with netdom and Fog. I've entered all of the details in the settings for Active Directory in Fog as well as encrypting the password with fogcrypt(multiple times). The issue is that the hostname will change, but it will not join the domain. The log file for Fog says "netdom output: Dns name contains an invalid character." So I'm a bit stumped. Which dns name is netdom referring to? If it's the computer name I've already tried a simple name of "test" and it failed. The regular host name was fourteen characters with characters that aren't invalid at all, so I'm at a loss as to what the issue could be. After futzing with this for over an hour and a half I'm just going to leave off the auto domain join stuff and do it manually as it's already been too much of a time waster.

    If anyone has any suggestions I'd be more than glad to hear them.

    Cheers

  2. #2

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,037
    Thank Post
    209
    Thanked 425 Times in 306 Posts
    Rep Power
    144
    Check you're using the FQDN when specifying the domain for FOG to join clients to, e.g 'school.local' and not just 'school'.

    Also make sure you haven't accidently typed a space at the end of the domain name in FOG, this caused an issue for me when I first set it up.

    Mike.

  3. Thanks to maniac from:

    stevehp (3rd February 2010)

  4. #3
    stevehp's Avatar
    Join Date
    Jul 2008
    Location
    Ohio
    Posts
    102
    Thank Post
    13
    Thanked 19 Times in 16 Posts
    Rep Power
    16
    Quote Originally Posted by maniac View Post
    Check you're using the FQDN when specifying the domain for FOG to join clients to, e.g 'school.local' and not just 'school'.

    Also make sure you haven't accidently typed a space at the end of the domain name in FOG, this caused an issue for me when I first set it up.

    Mike.
    I finally cracked it. The documentation led me to believe that the Active Directory settings in FOG needed to be LDAP formatted. I come to figure out it's not. I either misread the wiki or it needs to be combed over for more errors and or mistakes.

    Thanks for the suggestions Mike I appreciate it.
    Last edited by stevehp; 3rd February 2010 at 09:12 PM.

  5. Thanks to stevehp from:

    maniac (3rd February 2010)

  6. #4

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,037
    Thank Post
    209
    Thanked 425 Times in 306 Posts
    Rep Power
    144
    Quote Originally Posted by stevehp View Post
    I finally cracked it. The documentation led me to believe that the settings in Active Directory section in the Fog Settings needed to be ldap formatted. I come to figure out it's not. I either misread the wiki or it needs to be combed over for more errors and or mistakes.

    Thanks for the suggestions Mike I appreciate it.
    No worries, there's a little thanks button at the bottom of my post, feel free to press it

    Mike.

  7. Thanks to maniac from:

    pwagner9999 (17th December 2010)

  8. #5

    Join Date
    Oct 2008
    Posts
    67
    Thank Post
    1
    Thanked 9 Times in 6 Posts
    Rep Power
    13
    Quote Originally Posted by stevehp View Post
    I finally cracked it. The documentation led me to believe that the Active Directory settings in FOG needed to be LDAP formatted. I come to figure out it's not. I either misread the wiki or it needs to be combed over for more errors and or mistakes.

    Thanks for the suggestions Mike I appreciate it.
    Just starting with FOG. Set up the AD bit OU=nnn,DC=nnn,DC=nnn etc. Is this not right? And, if it ain't, what should it be??

    Cheers, Andy E.

  9. #6
    katie.lawe's Avatar
    Join Date
    Mar 2006
    Location
    Beverley
    Posts
    26
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    We are just starting with Fog and are having similar issues with the machines not joining the domain. Does anyone have any examples of what they put into their AD settings?

    We have tried encrypted and un-encrypted passwords and am just not getting anywhere. It would save so much time if we could get this working.

    Thanks
    Kate

  10. #7
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    816
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    39
    On the 'Fog Settings' page I've entered

    FOG_AD_DEFAULT_DOMAINNAME: school.internal
    FOG_AD_DEFAULT_OU: -I leave this blank-
    FOG_AD_DEFAULT_USER: school\FogADUserAccount
    FOG_AD_DEFAULT_PASSWORD: -here you paste in the output from the fog password encryptor-

    Now when registering the client either check the box in the user interface next to 'Join Domain after image task', the other boxes will populate with the default values, or the same thing will happen if you register the computer through the PXE boot menu, just answer 'y' at the appropriate point.

    I thought the active directory join was broken on my system but in actual fact I had just forgotten to check the box in the user interface. For debugging check the output of the log file in C:\fog.log.
    Last edited by morganw; 5th August 2010 at 07:23 PM.

  11. #8
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    816
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    39
    ...and, you have to delegated the management of computer objects to the fog AD account so that computers can join, you could always test with the domain administrator account and password just to see if that is the problem.

  12. #9
    oxide54's Avatar
    Join Date
    Mar 2009
    Posts
    798
    Thank Post
    51
    Thanked 55 Times in 54 Posts
    Rep Power
    22
    Quote Originally Posted by morganw View Post
    ...and, you have to delegated the management of computer objects to the fog AD account so that computers can join, you could always test with the domain administrator account and password just to see if that is the problem.
    yes definitely check that, we don't use FOG (yet!) but we found with ghost/sysprep that the delegated account didn't always work. we also found this worked better with the FQDN of the domain instead of the netbios name.

  13. #10

    dhicks's Avatar
    Join Date
    Aug 2005
    Location
    Knightsbridge
    Posts
    5,618
    Thank Post
    1,230
    Thanked 776 Times in 673 Posts
    Rep Power
    235
    Quote Originally Posted by morganw View Post
    FOG_AD_DEFAULT_DOMAINNAME: school.internal
    FOG_AD_DEFAULT_OU: -I leave this blank-
    FOG_AD_DEFAULT_USER: school\FogADUserAccount
    FOG_AD_DEFAULT_PASSWORD: -here you paste in the output from the fog password encryptor-
    Just to add: don't forget to turn off PHP's magic quotes feature, as described here:

    SourceForge.net: FOG - A Free Cloning Solution: Topic: fog 0.29 join domain error wrong password

    If you don't, the DOMAIN\username string gets converted to DOMAIN\\username when you save it, causing much confusion and general flumoxisation (you can tell what I've been doing for several hours now...).

    --
    David Hicks

  14. #11

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,037
    Thank Post
    209
    Thanked 425 Times in 306 Posts
    Rep Power
    144
    My username for Active Directory operations in FOG doesn't have the domain before it, it's never needed it - works quite happily with just the username in the box.

  15. Thanks to maniac from:

    dhicks (30th November 2010)

  16. #12
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    816
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    39
    Quote Originally Posted by dhicks View Post
    Just to add: don't forget to turn off PHP's magic quotes feature, as described here:

    SourceForge.net: FOG - A Free Cloning Solution: Topic: fog 0.29 join domain error wrong password

    If you don't, the DOMAIN\username string gets converted to DOMAIN\\username when you save it, causing much confusion and general flumoxisation (you can tell what I've been doing for several hours now...).

    --
    David Hicks
    ...and interesting there is bug if you populate the AD settings through a FOG group which will remove the backslash, so DOMAIN\username becomes DOMAINusername.

  17. Thanks to morganw from:

    dhicks (30th November 2010)

  18. #13

    Join Date
    May 2007
    Location
    London
    Posts
    217
    Thank Post
    6
    Thanked 13 Times in 11 Posts
    Rep Power
    17
    Seconded on that bug!

  19. #14
    obijon's Avatar
    Join Date
    Nov 2010
    Location
    SC
    Posts
    13
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Workaround for that bug is to use DOMAIN\\user in group settings (double-backslash).

  20. #15
    oxide54's Avatar
    Join Date
    Mar 2009
    Posts
    798
    Thank Post
    51
    Thanked 55 Times in 54 Posts
    Rep Power
    22
    Quote Originally Posted by obijon View Post
    Workaround for that bug is to use DOMAIN\\user in group settings (double-backslash).
    its the first thing i would of tried, its pretty standard for c based programming languages and a lot of script languages.

    \n = newline
    \\ = \
    \" = "

    etc etc

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Windows 7 Netdom
    By mwnci in forum O/S Deployment
    Replies: 3
    Last Post: 6th November 2009, 01:08 PM
  2. c# web service driving me insane
    By localzuk in forum Coding
    Replies: 10
    Last Post: 18th September 2009, 08:18 AM
  3. [Video] Insane Gamer
    By mattx in forum Jokes/Interweb Things
    Replies: 0
    Last Post: 18th July 2009, 11:50 AM
  4. Bulldog Broadband driving me insane!!
    By Number6 in forum Internet Related/Filtering/Firewall
    Replies: 30
    Last Post: 5th May 2009, 02:00 PM
  5. shortcuts : this is driving me insane...
    By kennysarmy in forum Windows
    Replies: 9
    Last Post: 28th January 2009, 08:12 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •