+ Post New Thread
Results 1 to 2 of 2
O/S Deployment Thread, Automatic Restart after sysprep has run in Technical; Afternoon, I'm playing with our sysprep stuff this afternoon and have re-learnt my notes etc, etc. I've just imaged a ...
  1. #1

    garethedmondson's Avatar
    Join Date
    Oct 2008
    Location
    Gowerton, Swansea
    Posts
    2,309
    Thank Post
    973
    Thanked 326 Times in 194 Posts
    Blog Entries
    11
    Rep Power
    170

    Automatic Restart after sysprep has run

    Afternoon,

    I'm playing with our sysprep stuff this afternoon and have re-learnt my notes etc, etc. I've just imaged a machine (very basic XPSP3 with nothing on) and it has joined to the network with the correct name and so forth.

    However when it starts up for the first time it has a black screen behind the logon box. It seems to need a restart to bring back the blue.

    I wonder if anyone has achieved this? I know I can run a script/batch after sysprep has finished. So far I have a .vbs script which joins it to some AD security groups and I have a shutdown program ready to go.

    What I don't is where to put these or where to reference them.

    If anyone could help, that would be amazing.

    Many thanks

    Gareth

  2. #2

    garethedmondson's Avatar
    Join Date
    Oct 2008
    Location
    Gowerton, Swansea
    Posts
    2,309
    Thank Post
    973
    Thanked 326 Times in 194 Posts
    Blog Entries
    11
    Rep Power
    170
    Hokay - so useing setupmgr to edit my sysprep.inf file I have added in a command to run when sysprep finishes. The command is:

    C:\shutdown.exe -r -t 0

    Using the .wim editor I have put the shutdown.exe file in the root. A quick check reveals that it is there.

    I've updated the image in WDS. Everything seems to be working, but the machine does not reboot after it finishes imaging. It just stays at the logon screen with the black background - waiting for a manual reboot before it picks up it's GPOs etc.

    :-(

    GJE



SHARE:
+ Post New Thread

Similar Threads

  1. Script to Restart Service
    By enjay in forum Windows Server 2000/2003
    Replies: 7
    Last Post: 23rd September 2009, 08:27 PM
  2. Run Fat Boy Run
    By WOW_freak in forum General Chat
    Replies: 2
    Last Post: 12th August 2009, 11:42 AM
  3. Server Restart
    By Gibson335 in forum Hardware
    Replies: 8
    Last Post: 23rd January 2009, 10:40 AM
  4. Restart Issue
    By JAW$ in forum Windows
    Replies: 1
    Last Post: 1st July 2008, 01:21 PM
  5. Turn off auto restart
    By richard in forum Windows
    Replies: 2
    Last Post: 25th June 2007, 08:49 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •