+ Post New Thread
Results 1 to 7 of 7
O/S Deployment Thread, PXEboot problem in Technical; Hi, i'm new in Linux and FOG, so i'm sorry if my question is a bit odd I'm installing FOG ...
  1. #1

    Join Date
    Jan 2010
    Location
    Indonesia
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    PXEboot problem

    Hi, i'm new in Linux and FOG, so i'm sorry if my question is a bit odd

    I'm installing FOG in Fedora 10 and i have installed the client service in a Windows XP computer.
    When i'm trying to boot from the client, the client always unable to locate the configuration file.
    The DHCP server seems to work fine and i didn't see any errors occurred in the server.

    Here is the message I got in the client computer :
    Code:
    PXELinux 3.82 2009-06-09
    . . . [other informations]
    !PXE Entry point found (we hope) at 9D3B:0109 via plan A
    UNDI code segment at 9D3B len 16C2
    UNDI data segment at 933B len A000
    Getting cached packet 01 02 03
    . . . [other informations]
    TFTP prefix:
    Trying to load: pxelinux.cfg/ec5db4c0-74fe-d511-b9e7-3d9235afe5a1
    Trying to load: pxelinux.cfg/01-00-17-31-b6-5e-a8
    Trying to load: pxelinux.cfg/0A64491E
    Trying to load: pxelinux.cfg/0A64491
    Trying to load: pxelinux.cfg/0A6449
    Trying to load: pxelinux.cfg/0A644
    Trying to load: pxelinux.cfg/0A64
    Trying to load: pxelinux.cfg/0A6
    Trying to load: pxelinux.cfg/0A
    Trying to load: pxelinux.cfg/0
    Trying to load: pxelinux.cfg/default
    
    Unable to locate configuration file
    Boot failed: press a key to retry or wait for reset
    It seems that the client didn't know where to find the file. Should I configure something in the FOG server or in the Fedora or in the client?

    Oh, one more question, should I install the tftp server separately or FOG has did it for me during the installation? Because i found the tftpboot folder but i cannot start the tftp server using the service command.

    Thanks in advance..

  2. #2
    Arcath's Avatar
    Join Date
    Feb 2009
    Location
    Lancashire
    Posts
    935
    Thank Post
    99
    Thanked 107 Times in 95 Posts
    Rep Power
    72
    does /tftpboot/pxelinux.cfg/default exist on your FOG machine?

  3. #3

    Join Date
    May 2009
    Location
    England
    Posts
    264
    Thank Post
    58
    Thanked 36 Times in 35 Posts
    Rep Power
    19
    The pxelinux is the link in scope 67, yes? If so it has to be the exact right link or fog plays up like mad.

  4. #4

    Join Date
    Jan 2010
    Location
    Indonesia
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    @arcath
    yes, the tftpboot/pxelinux.cfg/default is exist in my FOG machine

    @potato-peeler
    what do you mean by scope 67? i don't really understand, sorry..is it about the DHCP server or something?

  5. #5

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    10,691
    Thank Post
    824
    Thanked 2,570 Times in 2,187 Posts
    Blog Entries
    9
    Rep Power
    731
    The Scope 67 reffered to is just the settings for option 67 under the DHCP server configuration BOOTP / DHCP options

    I think to do this you need to go into the dhcp server config and add

    Code:
           allow booting;
           allow bootp;
    and
    Code:
    next-server TFTP_server_address;
                   filename "/tftpboot/pxelinux.0";
    or whatever it should be under your setup

    But I am rubbish at *nix so I could well be wrong.

  6. #6

    Join Date
    Jan 2010
    Location
    Indonesia
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    @synack
    thanks a lot for your help..
    i got another error then..*sigh*

    PXE-T01 : File note found

    i'll try to fix that..

  7. #7

    Join Date
    Jan 2010
    Location
    Indonesia
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    i found the problem...
    in my dhcpd.conf, i wrote : filename:"tftpboot/pxelinux.0"
    i changed it into filename:"pxelinux.0"

    and it worked

    @all, thanks a lot for the help..really appreciate that..

SHARE:
+ Post New Thread

Similar Threads

  1. Exchange 2003 problem/profile problem?
    By Japtastic in forum Windows Server 2000/2003
    Replies: 4
    Last Post: 30th September 2009, 05:41 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •