+ Post New Thread
Results 1 to 10 of 10
O/S Deployment Thread, Fog won't add computers to the domain in Technical; Hi all, long time reader first time poster here. I love what you have going for IT education workers! I've ...
  1. #1

    Join Date
    Nov 2009
    Location
    Perth
    Posts
    11
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Fog won't add computers to the domain

    Hi all, long time reader first time poster here. I love what you have going for IT education workers!

    I've been looking at rolling out FOG over Ghost for quite a while and finally have some spare time to do so.

    I've setup a spare machine with Ubuntu 8.10 and installed FOG, added the Active directory information and made sure the password was encrypted using FOGCrypt. Also doublechecked there were no spaces before or after the encrypted password. Made my Sysprep image with the FOG client installed.

    I can remotely boot and upload the image to the FOG server, but after I reboot the client machine and sit at the logon screen waiting for it to add to the domain, it does nothing!

    I've logged onto the machine and copied the fog.txt file

    Code:
     25/11/2009 9:45 AM FOG::UserTracker Record processed by server!
     25/11/2009 9:45 AM FOG::DirCleaner Failed to connect to fog server!
     25/11/2009 9:45 AM FOG::DirCleaner The operation has timed out
     25/11/2009 9:45 AM FOG::DirCleaner    at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
       at System.Net.WebClient.DownloadString(Uri address)
       at System.Net.WebClient.DownloadString(String address)
       at FOG.DirCleaner.doWork()
     25/11/2009 9:45 AM FOG::DirCleaner Sleeping for 1 minute.
     25/11/2009 9:45 AM FOG::GreenFog Failed to connect to fog server!
     25/11/2009 9:45 AM FOG::GreenFog The operation has timed out
     25/11/2009 9:45 AM FOG::GreenFog    at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
       at System.Net.WebClient.DownloadString(Uri address)
       at System.Net.WebClient.DownloadString(String address)
       at FOG.GreenFog.doWork()
     25/11/2009 9:45 AM FOG::GreenFog Sleeping for 1 minute.
     25/11/2009 9:45 AM FOG::ClientUpdater Failed to connect to fog server!
     25/11/2009 9:45 AM FOG::ClientUpdater The operation has timed out
     25/11/2009 9:45 AM FOG::ClientUpdater    at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
       at System.Net.WebClient.DownloadString(Uri address)
       at System.Net.WebClient.DownloadString(String address)
       at FOG.SnapinClient.startUpdate()
     25/11/2009 9:45 AM FOG::ClientUpdater Sleeping for 1 minute.
     25/11/2009 9:46 AM FOG::HostRegister Failed to connect to fog server!
     25/11/2009 9:46 AM FOG::HostRegister The operation has timed out
     25/11/2009 9:46 AM FOG::HostRegister    at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
       at System.Net.WebClient.DownloadString(Uri address)
       at System.Net.WebClient.DownloadString(String address)
       at FOG.HostRegister.registerHost()
     25/11/2009 9:46 AM FOG::HostRegister Object reference not set to an instance of an object.
     25/11/2009 9:46 AM FOG::HostRegister    at FOG.HostRegister.registerHost()
     25/11/2009 9:46 AM FOG::SnapinClient The operation has timed out
     25/11/2009 9:46 AM FOG::SnapinClient    at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
       at System.Net.WebClient.DownloadString(Uri address)
       at System.Net.WebClient.DownloadString(String address)
       at FOG.SnapinClient.startWatching()
     25/11/2009 9:46 AM FOG::GUIWatcher Message found, attempting to notify GUI!
     25/11/2009 9:46 AM FOG::GUIWatcher Dispatch OK!
     25/11/2009 9:46 AM FOG::GreenFog Attempting to connect to fog server...
     25/11/2009 9:46 AM FOG::UserTracker Unable to replay journal, no server connection found.
     25/11/2009 9:46 AM FOG::ClientUpdater Attempting to connect to fog server...
     25/11/2009 9:47 AM FOG::DirCleaner Module is active...
     25/11/2009 9:47 AM FOG::DirCleaner Determining which directories should be cleaned...
     25/11/2009 9:48 AM FOG::GreenFog Module is active...
     25/11/2009 9:48 AM FOG::ClientUpdater Failed to connect to fog server!
     25/11/2009 9:48 AM FOG::ClientUpdater The operation has timed out
     25/11/2009 9:48 AM FOG::ClientUpdater    at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
       at System.Net.WebClient.DownloadString(Uri address)
       at System.Net.WebClient.DownloadString(String address)
       at FOG.SnapinClient.startUpdate()
     25/11/2009 9:48 AM FOG::ClientUpdater Sleeping for 1 minute.
    Also FOG pops up on the client in the top righthand corner and says "FOG Host registration error: Object reference not set to an instance of an object"

    Can anyone offer any advice?

  2. #2
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20
    Hi,
    When I sysprep a machine, I try and include the domain information in the sysprep setting (sysprep.inf). So when I take an image, it already has domain info 'inside' the image. FOG doesn't need to know about the domain stuff, just manages deployment.

    I know it doesn't answer your question, but it is an alternative. Read quite a bit about Fog issues with adding to the domain, although lots are successful with it too.

  3. #3

    Join Date
    Nov 2009
    Location
    Perth
    Posts
    11
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I like the idea of FOG because it will rename the PC to what I want (eg RM50-01, room 50, PC 1) and can see groups so it dumps them into corresponding OUs.

  4. #4

    sparkeh's Avatar
    Join Date
    May 2007
    Posts
    7,015
    Thank Post
    1,362
    Thanked 1,769 Times in 1,191 Posts
    Blog Entries
    22
    Rep Power
    530
    I think that this might be your problem:
    Quote Originally Posted by Stevoid View Post
    25/11/2009 9:45 AM FOG:irCleaner Failed to connect to fog server!
    25/11/2009 9:45 AM FOG::GreenFog Failed to connect to fog server!
    25/11/2009 9:45 AM FOG::ClientUpdater Failed to connect to fog server!
    25/11/2009 9:48 AM FOG::ClientUpdater Failed to connect to fog server!
    The FOG client cannot connect to the server. Nothing is going to happen.

    First of all can you log into your newly imaged machine and see if you can contact the FOG server?
    Are your network settings correct after imaging? eg IP+DNS etc.

  5. #5

    Join Date
    Nov 2009
    Location
    Perth
    Posts
    11
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I can ping it, and the IP/DNS settings are fine. I can even log onto the fog server in IE on the client machine.

  6. #6

    Join Date
    Jul 2009
    Posts
    589
    Thank Post
    51
    Thanked 110 Times in 95 Posts
    Rep Power
    68
    I had the problem of fog not joining machines to the domain and i had to recompile the fog hostname change bit to get it to work. the section you need is called 'Securing Active Directory Integration'.

  7. #7

    sparkeh's Avatar
    Join Date
    May 2007
    Posts
    7,015
    Thank Post
    1,362
    Thanked 1,769 Times in 1,191 Posts
    Blog Entries
    22
    Rep Power
    530
    Check c:\program files\fog\etc\config.ini to make sure that the client has the right IP for the server.

  8. #8

    Join Date
    Mar 2010
    Location
    New Orleans
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I'm having the same issue all of the sudden. Anyone actually come up with a solution for this?

  9. #9

    Join Date
    Nov 2009
    Location
    Perth
    Posts
    11
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Unfortunately I couldn't find a fix for this I just had to live with the fact I would have to go round and manually add the PCs to the domain. It will still do the name change at least.

  10. #10

    Join Date
    Mar 2010
    Location
    New Orleans
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Stevoid View Post
    Unfortunately I couldn't find a fix for this I just had to live with the fact I would have to go round and manually add the PCs to the domain. It will still do the name change at least.
    Well, I'm hoping someone does. It took me about an hour and a half to rename and add 30 computers today. I've got to find another solution as I have about 100 more to go. (And unfortunately only about 1/10 will successfully name change now). All new additions with new 0.29 Fog service on image.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 1
    Last Post: 17th January 2011, 02:36 PM
  2. [Fog] Fog Documentation: How to delete a group of computers in FOG
    By ssx4life in forum O/S Deployment
    Replies: 1
    Last Post: 9th November 2009, 01:59 PM
  3. Users being able to add 10 computers to a domain
    By Ben-BSH in forum Windows Server 2000/2003
    Replies: 22
    Last Post: 5th November 2009, 10:53 AM
  4. Script to add computers to AD like RIS
    By box_l in forum Scripts
    Replies: 2
    Last Post: 4th June 2008, 08:34 PM
  5. Essential add-on for AD Users & Computers
    By ajbritton in forum Downloads
    Replies: 9
    Last Post: 10th August 2006, 02:08 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •