+ Post New Thread
Results 1 to 4 of 4
O/S Deployment Thread, [Fog] DHCP/PXE problem in Technical; Hi 'geekers! I've posted this same prob to the FOG forums but last time I posted there I got no ...
  1. #1

    Join Date
    Oct 2008
    Posts
    94
    Thank Post
    8
    Thanked 16 Times in 10 Posts
    Rep Power
    26

    [Fog] DHCP/PXE problem

    Hi 'geekers!

    I've posted this same prob to the FOG forums but last time I posted there I got no response and I'm in a bit of a hurry to get Fog running properly again so I can't chance not having a reply by tomorrow so I wanted to post it here as I know there a a lot of FOG fans and users on these forums.

    Before I ask my question- is there not an irc channel for FOG? I've not been able to find one which seems odd as FOG deserves to be massively popular from what I've seen so far. Also, I'm pretty sure STP is turned off but I'll need to double check that.

    I did have FOG 0.27 working very nicely on our Ubuntu 9.04 Server install until I did an dist-upgrade of Ubuntu last week and now I can only access the FOG PXE menu on a select few machines whereas before it was working on all machines on our LAN. After trying a few different things I decided to totally re-install Ubuntu server and FOG but the problem persists.

    We have one room full of computers that were all imaged using FOG but now none of them get issued a DHCP address so you can't access the FOG PXE menu but you can access the FOG menu on some other machines of different parts of our network still. The settings on our DHCP server have not changed from when we successfully imaged that full room and the fog server has the same static IP as when it was working.

    I've tried turning DHCP on and off on our switches but it hasn't made any difference to the once-working machines so I'm presuming Ubuntu have broke something in a recent update??

    Thanks for your help!

    Dan

  2. #2

    tmcd35's Avatar
    Join Date
    Jul 2005
    Location
    Norfolk
    Posts
    5,575
    Thank Post
    834
    Thanked 873 Times in 726 Posts
    Blog Entries
    9
    Rep Power
    324
    Heres a gut instinct answer for you...

    It's nothing to do with FOG or DHCP. Why? Because other machines elsewhere on your network are getting DHCP addresses and connecting to FOG fine.

    It's nothing to do with the actual machines. Why? All the machines in that room are effected in the same way. Unless you've gone round changing something in the bios on all the machines it's very unlikely that the exact same fault would occur on the 30 machines that just so happen to be in the same room at the same time. Too much of a coincident.

    This points to a network problem between the switch the room is connected to and the switch the DHCP and/or FOG server is connected to.

    Best way to prove if I'm right or wrong is to take one of the machines out of that room and plug it in somewhere else, where you know FOG is working. If that machine suddenly works then you know it's definetly a network issue in that room.

    Check all switch configs and test network cables. Can you ping the switch the room is connected to from the DHCP or FOG server?

    EDIT: on the outside chance that it is a problem with the model pc you're using in that suite, reset the bios to factory defaults on one of them and try again. I've seen that fix random machines not picking up DHCP during PXE-Boot before. Though never worked out why?
    Last edited by tmcd35; 17th August 2009 at 03:29 PM.

  3. #3

    Join Date
    Jul 2009
    Location
    Shropshire
    Posts
    49
    Thank Post
    2
    Thanked 4 Times in 3 Posts
    Rep Power
    11
    I've just installed FOG today, dual booted the server with ubuntu cos i have loads of ghost images i will have to convert to FOG.

    The above post sounds about right, I imagine your experiencing the same problems if you were to boot windows on one of them? I know with ghost PC-DOS and winPE sometimes (like today) new machines will come in and winPE won't load drives for the NICs so you spend an hour taking them out of there packaging, pluging them into the network then booting winPE from PXE only for it to not find session and ping commands give error cos of the wrong NIC drivers, or they dont fal back to the universal packet drivers. Could be a similar issue in the FOG / linux setup?? are they different NICs to the other things that pick up an IP from DHCP ?

  4. #4

    Join Date
    Oct 2008
    Posts
    94
    Thank Post
    8
    Thanked 16 Times in 10 Posts
    Rep Power
    26

    etherboot saves the day

    We managed to get a laptop to boot to the FOG PXE menu in the problematic room as the laptop we used allowed much longer for DHCP to come up than the desktops (which all have RTL8168c/8111c NICs built onto their mobos) which only give you a max of 5s before it gives up. I read on another thread that you can supposedly extend the time-out by pushing PAUSE then unpausing with space or enter but that didn't work for me, nor did juggling the boot order.

    The solution for me was to boot off the latest git etherboot image for r8169:r8169 which I downloaded from:

    ROM-o-matic.net

    Funny thing with that is that etherboot finds / boots the FOG PXE menu instantly, soon as its booted. Wassatalaboot??

SHARE:
+ Post New Thread

Similar Threads

  1. [Fog] FOG problem
    By Jed in forum O/S Deployment
    Replies: 32
    Last Post: 21st September 2011, 01:13 PM
  2. [Fog] FOG, DHCP and image speed
    By TechSupp in forum O/S Deployment
    Replies: 16
    Last Post: 29th June 2009, 02:15 PM
  3. PXE Cannot Find DHCP
    By topher83 in forum Windows
    Replies: 4
    Last Post: 11th April 2008, 07:10 PM
  4. PXE Cannot Find DHCP
    By topher83 in forum Wireless Networks
    Replies: 0
    Last Post: 9th April 2008, 11:48 AM
  5. PXE > DHCP > TFTP - A Question
    By Pear in forum Thin Client and Virtual Machines
    Replies: 2
    Last Post: 4th October 2006, 03:57 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •