+ Post New Thread
Results 1 to 10 of 10
O/S Deployment Thread, Disable the boot menu in Technical; Hi all, Iv been doing work experience in a school using the old ghost that dosent support multicasting so last ...
  1. #1

    Join Date
    Dec 2008
    Location
    Rochdale, Greater Manchester
    Posts
    12
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    13

    Disable the boot menu

    Hi all,

    Iv been doing work experience in a school using the old ghost that dosent support multicasting so last week I setup Fog. All works perfectly and for free it is very impressive. The school are going to carry on using it but there is one small issue that other people must of come across.

    When a machine is setup to boot from lan as first device it will go to Fog menu. I know you can put the timeout to a second but the network manager dosent want the studemts to be able to mess about. We know there is a password etc but he wants a way to go straight past the menu.

    Before I set up Fog I had a play around with the vmware image. When using that the machines didnt show the fog menu they went to xp. But when i created a task everything still worked

    any suggestions?

    Dont no if this was luck - was making an image and half way through iploading accidently turned the server off, at the power. When it booted back up the image just carried on uploading from where it were

  2. #2

    tmcd35's Avatar
    Join Date
    Jul 2005
    Location
    Norfolk
    Posts
    6,069
    Thank Post
    902
    Thanked 1,013 Times in 825 Posts
    Blog Entries
    9
    Rep Power
    350
    Set your hard drives to 1st boot priority in the bios boot order and set a bios password. So long as PXE/network/Lan booting is enabled in the bios you should be able to push F12 at the bios boot screen when you first turn the computer on to get it network booting. If you don't push F12 then the computer will boot straight from hdd as normal.

    unfortuantly there is nothing (i know of) that you can do to stop the students pressing F12 at the same point. Unless you only enable network boot in the bios when you actually need it.

    For added security (I don't use FOG so don't rightly know) if FOG allows you to set an admin password to log into it then set that as well.

  3. #3
    teky's Avatar
    Join Date
    Apr 2008
    Location
    South west
    Posts
    84
    Thank Post
    9
    Thanked 9 Times in 9 Posts
    Rep Power
    15
    Hi, We use FOG here and on the boot menu have set passwords on all the options apart from boot to hard disk, so the only option that they can choose that will work is hard disk. The only way they could bypass this is if they were able to gain access to the fog configuration somehow, which is impossible here.

  4. #4

    Join Date
    Dec 2008
    Location
    Rochdale, Greater Manchester
    Posts
    12
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    13
    Thanks for the replys but its not what we are looking for.

    We already have the password set and we want it to boot from lan so everything can be done remotly - in theory.

    The netman just dosent want the students to be able to see the menu even though they cant do anything.

  5. #5

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,087
    Thank Post
    210
    Thanked 432 Times in 312 Posts
    Rep Power
    145
    Have you tried setting the menu timeout to Zero?

    Mike.

  6. #6
    teky's Avatar
    Join Date
    Apr 2008
    Location
    South west
    Posts
    84
    Thank Post
    9
    Thanked 9 Times in 9 Posts
    Rep Power
    15
    If your adventurious then you could play with the graphics and change it all to black so if you can't set the time to 0 then have a least a 1 secound delay with nothing showing, will look into it more tomorrow though

  7. #7

    Join Date
    Dec 2008
    Location
    Rochdale, Greater Manchester
    Posts
    12
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    13
    The time limit has to be 1 or above.

    I was going to change the background, add the school logo is that something that is allowed with open source or not?

  8. #8


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,033 Times in 813 Posts
    Rep Power
    341
    Quote Originally Posted by edwardjrobertson View Post
    When a machine is setup to boot from lan as first device it will go to Fog menu. I know you can put the timeout to a second but the network manager dosent want the studemts to be able to mess about. We know there is a password etc but he wants a way to go straight past the menu.
    If you don't want to change the config in the bios (it is hassle reconfiguring all the bioses when you need t re-image)
    you could make a new default file that boots to hdd only.
    backup the old one

    Code:
    cp /tftpboot/pxelinux.cfg/default /tftpboot/pxelinux.cfg/default.bak
    then create a new file that has no menu, instead it would just say:

    Code:
    DEFAULT localboot 0
    or try and just edit the file and replace "DEFAULT vesamenu.c32" with DEFAULT localboot 0 and keep the rest of the file intact

    EDIT:
    I think you might want to say
    Code:
    DEFAULT fog.local
    instead. have a play with it.

    /edit
    I think that might work.

    clearly you will have to undo your changes when you next want to use the pxe bootmenu.

    I was going to change the background, add the school logo is that something that is allowed with open source or not?
    yes you can.
    Last edited by CyberNerd; 17th August 2009 at 08:47 PM.

  9. #9

    Join Date
    Dec 2008
    Location
    Rochdale, Greater Manchester
    Posts
    12
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    13
    Thanks "CyberNerd" will have a look at it tomorow.

    There is actually no need to use the boot menu - we will do everything from the web page.

    Will post back the results

  10. #10

    Join Date
    Dec 2008
    Location
    Rochdale, Greater Manchester
    Posts
    12
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    13
    Problem sorted

    Changed the default menu to fog.local

    Thanks again



SHARE:
+ Post New Thread

Similar Threads

  1. [Fog] How to Add boot images to the PXE Menu
    By ChrisH in forum O/S Deployment
    Replies: 6
    Last Post: 25th September 2009, 09:24 PM
  2. [Fog] RM NBook200 wont load pxe boot menu
    By Optics in forum O/S Deployment
    Replies: 2
    Last Post: 23rd July 2009, 02:51 PM
  3. refit boot manager menu
    By Uraken in forum Mac
    Replies: 6
    Last Post: 14th May 2009, 04:10 PM
  4. disable Menu Bar in ie7 GPO
    By goodhead in forum Windows
    Replies: 3
    Last Post: 1st April 2009, 04:07 PM
  5. Replies: 10
    Last Post: 7th November 2007, 01:32 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •