+ Post New Thread
Results 1 to 3 of 3
O/S Deployment Thread, RM NBook200 wont load pxe boot menu in Technical; Hi all, Iím hoping you can help me out. We have recently taken delivery of 40 RM NBook 200ís (Compal ...
  1. #1
    Optics's Avatar
    Join Date
    Apr 2006
    Posts
    50
    Thank Post
    9
    Thanked 7 Times in 6 Posts
    Rep Power
    18

    RM NBook200 wont load pxe boot menu

    Hi all, Iím hoping you can help me out.

    We have recently taken delivery of 40 RM NBook 200ís (Compal SW91) which I was hoping to image with XP in the same way we have started to image all our other laptops (using FOG, all RM rebadged Compalís of various ages) but I keep getting a blank screen instead of the boot menu.

    The display just before it blank screens, shows that the PXE has found the server and is trying to load the kernel.

    PXE entry point found (we hope) at 9AD6:0108
    Getting cached packet 01
    Getting cached packet 02
    Getting cached packet 03
    My IP Address seems to be AC10152D IPFromDHCPHere
    ip=IPHERE:FOGSvrIPG IP:SUBNET
    TFTP Prefix:
    Trying to load: pxelinux.cfg/a37a8fc1-99ed-11dd-8015-001eecd14548
    Trying to load: pxelinux.cfg/01-00-1e-ec-d1-46-48
    Trying to load: pxelinux.cfg/AC10152D
    Trying to load: pxelinux.cfg/ AC10152
    Trying to load: pxelinux.cfg/ AC1015
    Trying to load: pxelinux.cfg/ AC101
    Trying to load: pxelinux.cfg/ AC10
    Trying to load: pxelinux.cfg/ AC1
    Trying to load: pxelinux.cfg/ AC
    Trying to load: pxelinux.cfg/ A
    Trying to load: pxelinux.cfg/ default

    Iíve tried every kernel available through the FOG update menu, but as Iím pretty much a linux newbie I havenít even considered making my own kernel as I wouldnít know where to start.

    The text only menu just hangs after I type the fog command.

    I canít change any BIOS settings other than the boot order, I thought at first that RM had customised the BIOS options, but the Compal website appears to supply the same BIOS. I have a feeling the problem may have to do with ACPI or similar settings, as when I tried to load Ubuntu Live CD, I get the following error.:

    2648441 ACPI: Invalid PBLK length [5]
    2686601 ACPI: Invalid PBLK length [5]

    On the F6 Boot parameters menu, setting ACPI=off causes numerous errors and halts loading, but if set to noapic and nolapic as well as ACPI=off it errors mentioning a PNPBIOS error but then it allows Ubuntu live CD to load as normal and appears to work fine.

    Iím totally stuck, any suggestions guys and gals?

    Graham

  2. #2

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,802
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224
    ACPI errors and boot failures like this are due to the BIOS not implementing the various related standards correctly. I suggest you check with the manufacturer to see if there is a BIOS update that will fix it.

    Failing that you can try disabling ACPI. In the fog entry for the host (create one if you've not managed to register the machine automatically) go to the kernel parameters section. Add 'acpi=off irqpoll' and then try and do an image upload, initiated from the web interface (the quick image option does not honour any custom machine settings in fog).

  3. Thanks to Geoff from:

    Optics (4th July 2009)

  4. #3
    Optics's Avatar
    Join Date
    Apr 2006
    Posts
    50
    Thank Post
    9
    Thanked 7 Times in 6 Posts
    Rep Power
    18
    I forgot to update this, oops.

    The actual problem was with the kernel not being able to deal with the USB2.0 controller on the SiS M672/968 chipset.

    I updated the kernel used to 2.6.30.1 and it works well again now. The latest version of FOG (0.27) also has this updated kernel.

    Thanks again for your help Geoff.

    Graham

SHARE:
+ Post New Thread

Similar Threads

  1. Another PXE Boot Question
    By Reaper in forum Wireless Networks
    Replies: 7
    Last Post: 31st October 2008, 02:27 PM
  2. Track Mania - Wont load?
    By dave.81 in forum Gaming
    Replies: 8
    Last Post: 16th July 2008, 12:44 PM
  3. iMac G3 wont boot
    By sidewinder in forum Mac
    Replies: 9
    Last Post: 21st November 2006, 08:58 AM
  4. iBook G4 wont boot
    By sidewinder in forum Mac
    Replies: 11
    Last Post: 16th November 2006, 09:50 AM
  5. PXE Boot
    By richard in forum Wireless Networks
    Replies: 12
    Last Post: 20th May 2006, 04:37 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •