+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 19
O/S Deployment Thread, FOG active directory in Technical; Trying to get FOG to auto add to the domain. It doesnt seem to be working. the fog log on ...
  1. #1
    browolf's Avatar
    Join Date
    Jun 2005
    Location
    Mars
    Posts
    1,533
    Thank Post
    108
    Thanked 89 Times in 75 Posts
    Blog Entries
    47
    Rep Power
    41

    FOG active directory

    Trying to get FOG to auto add to the domain.

    It doesnt seem to be working. the fog log on the workstation only reports trying to add to domain. doesn't say why it didn't.

    any way to find out?

  2. #2
    clarky2k3's Avatar
    Join Date
    Nov 2007
    Location
    Northumberland
    Posts
    321
    Thank Post
    35
    Thanked 49 Times in 40 Posts
    Rep Power
    25
    When you created your image did you leave it off the domain and did you have Windows XP Support Tools installed?

    Have you use the FOGCrypt utility to create a encrypted password that FOG uses to join the domain?

  3. #3

    sparkeh's Avatar
    Join Date
    May 2007
    Posts
    7,137
    Thank Post
    1,417
    Thanked 1,824 Times in 1,230 Posts
    Blog Entries
    22
    Rep Power
    553
    Yeah I had a bit of tweaking to do to get this working.

    So I am guessing that you have the client installed and added AD info to the console but did you follow the instructions about Securing Active Directory Integration?. AD integration would not work for me until I had recompiled HostNameChange.sln and replaced it on the host machine and used Fogcrypt.
    Last edited by sparkeh; 26th June 2009 at 01:02 PM.

  4. #4
    browolf's Avatar
    Join Date
    Jun 2005
    Location
    Mars
    Posts
    1,533
    Thank Post
    108
    Thanked 89 Times in 75 Posts
    Blog Entries
    47
    Rep Power
    41
    everything is like it ought to be but haven't tried the recompiling. guess i'd better try that. thanks.

  5. #5
    browolf's Avatar
    Join Date
    Jun 2005
    Location
    Mars
    Posts
    1,533
    Thank Post
    108
    Thanked 89 Times in 75 Posts
    Blog Entries
    47
    Rep Power
    41
    I tried that.
    the hostname changer says
    "padding is invalid and can not be removed."

    wtf does that mean!? lol

  6. #6
    Jed
    Jed is offline
    Jed's Avatar
    Join Date
    Aug 2008
    Location
    Peacehaven
    Posts
    33
    Thank Post
    7
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Question:

    Should I be using LDAP format in the default AD settings to represent the domain and the OU?

  7. #7

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    Boston, MA
    Posts
    7,597
    Thank Post
    109
    Thanked 770 Times in 598 Posts
    Rep Power
    183
    You ran the tool to encrypt the password?

    The account you're using has the delegated rights to add machines to the domain too yeah?

    Sorry to rub it in, but mine worked straight away after following the instructions.

  8. #8

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,850
    Thank Post
    110
    Thanked 598 Times in 514 Posts
    Blog Entries
    1
    Rep Power
    227
    does it work if you leave the destination OU setting blank (ie so it adds it to Computers).

  9. Thanks to Geoff from:

    Jed (29th July 2009)

  10. #9
    Jed
    Jed is offline
    Jed's Avatar
    Join Date
    Aug 2008
    Location
    Peacehaven
    Posts
    33
    Thank Post
    7
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Ran the Fogcrypt tool.

    Changed the hostnamechanger.dll and added it to the client.

    installed XP power tools on the client.

    Using my admin account to test as I am sure this has the rights to join to the domain.

    I can only assume it is my setup on the server. Hense my question about the setup of the default AD settings.

    Can someone give me a template of theirs, so I can compare?

    Cheers,

    Jed

  11. #10
    R0M
    R0M is offline
    R0M's Avatar
    Join Date
    Mar 2009
    Location
    Perth
    Posts
    68
    Thank Post
    7
    Thanked 8 Times in 8 Posts
    Rep Power
    13
    Also try checking that the host is not already added in AD, I imaged one for example called "ITRoom2-001" but hadn't removed that name from AD before re-imaging and it gave me funny errors.

  12. Thanks to R0M from:

    Jed (29th July 2009)

  13. #11
    Jed
    Jed is offline
    Jed's Avatar
    Join Date
    Aug 2008
    Location
    Peacehaven
    Posts
    33
    Thank Post
    7
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Already tried that, I've got the hostname changer working, just the AD causing a problem. Still thinking that I've got the config wrong for the defualt AD settings.

  14. #12

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,850
    Thank Post
    110
    Thanked 598 Times in 514 Posts
    Blog Entries
    1
    Rep Power
    227
    what happens if you run the netdom command manually with the settings you've used for fog?

  15. #13
    Jed
    Jed is offline
    Jed's Avatar
    Join Date
    Aug 2008
    Location
    Peacehaven
    Posts
    33
    Thank Post
    7
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I tried running that a minute ago, it came back with a syntax error. I copied it straight from the fogwiki. I am just going to run another deploy and check the fog.log to see if the client is trying to join the domain at all.

    Still think I may have the default active directory settings wrong.

  16. #14
    Jed
    Jed is offline
    Jed's Avatar
    Join Date
    Aug 2008
    Location
    Peacehaven
    Posts
    33
    Thank Post
    7
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    It worked!!!!

    It was my default AD settings after all.

    Cheers for the help guys,

    Legendary as always!

  17. #15

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,850
    Thank Post
    110
    Thanked 598 Times in 514 Posts
    Blog Entries
    1
    Rep Power
    227
    BTW the fog wiki is wrong where it says just to use the OU name. You must use the fully qualified LDAP path to the OU instead. For example:

    Code:
    OU=Classrooms,OU=Desktops,OU=All Computers,DC=carrhill,DC=lancs,DC=sch,DC=uk

  18. Thanks to Geoff from:

    Jed (29th July 2009)



SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. FreeNAS / Active Directory
    By dwimorberg in forum How do you do....it?
    Replies: 17
    Last Post: 8th May 2009, 03:51 PM
  2. Replies: 0
    Last Post: 6th April 2009, 11:26 PM
  3. active directory
    By MrPstv in forum Windows Server 2000/2003
    Replies: 5
    Last Post: 26th March 2009, 08:26 PM
  4. Active Directory
    By Neville in forum Windows
    Replies: 6
    Last Post: 25th June 2008, 04:24 PM
  5. Replies: 7
    Last Post: 31st January 2008, 01:17 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •