+ Post New Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 33
O/S Deployment Thread, FOG problem in Technical; Hi Guys, I can't get fog to install on ubuntu 9.04 desktop! It gets as far as installing packages but ...
  1. #1
    Jed
    Jed is offline
    Jed's Avatar
    Join Date
    Aug 2008
    Location
    Peacehaven
    Posts
    33
    Thank Post
    7
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    FOG problem

    Hi Guys,

    I can't get fog to install on ubuntu 9.04 desktop!

    It gets as far as installing packages but as soon as it checks the installations it stops at the first one and says

    Checking installation ..... apache2 failed!

    Then it just stops!

    I thought it maybe a connection to the internet but that seems to be working fine.

    Any ideas?
    Last edited by Jed; 26th June 2009 at 09:06 AM.

  2. #2
    clarky2k3's Avatar
    Join Date
    Nov 2007
    Location
    Northumberland
    Posts
    318
    Thank Post
    35
    Thanked 47 Times in 39 Posts
    Rep Power
    24
    You will need to enter the command sudo ./installfog.sh
    It will ask you to enter a password, just enter the same password of the user you are currently using again.

  3. #3
    Jed
    Jed is offline
    Jed's Avatar
    Join Date
    Aug 2008
    Location
    Peacehaven
    Posts
    33
    Thank Post
    7
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have already done that.

    I can start the installation fine, but it is towards the end of the installation the problem crops up.

  4. #4
    Batman's Avatar
    Join Date
    Mar 2009
    Location
    Northampton
    Posts
    940
    Thank Post
    115
    Thanked 118 Times in 74 Posts
    Rep Power
    40
    When I've installed FOG I always install apache, php and mysql before I run the script. I'm not sure if the script actually installs those things.

    When you say it fails to install apache is that through synaptic/apt or through the script?

  5. Thanks to Batman from:

    Jed (26th June 2009)

  6. #5
    clarky2k3's Avatar
    Join Date
    Nov 2007
    Location
    Northumberland
    Posts
    318
    Thank Post
    35
    Thanked 47 Times in 39 Posts
    Rep Power
    24
    Check that apache2 is installed. If not sudo apt-get install apache2
    If it is check that it running /etc/init.d/ apache2 start.
    I must admit i havent tried it on ubuntu desktop 9.04, just 8.10 server and desktop.

  7. Thanks to clarky2k3 from:

    Jed (26th June 2009)

  8. #6
    Jed
    Jed is offline
    Jed's Avatar
    Join Date
    Aug 2008
    Location
    Peacehaven
    Posts
    33
    Thank Post
    7
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have just tried sudo apt-get install apache2

    Got an error saying E: couldn't find package apache2

    I am assuming that fog installs all of these for you....am i wrong there?

    If so what can I do to install apache2?

  9. #7
    denon101's Avatar
    Join Date
    Jul 2008
    Location
    Stuck in the server room......
    Posts
    397
    Thank Post
    54
    Thanked 37 Times in 35 Posts
    Rep Power
    21
    Are you behind a proxy??

    I found that when I installed fog on 8.10 I have to manually enter proxy details including a username and password. I then ran apt-get install apache2, mysql and installed all the packages first. Then ran the fog installer. This was the only way to get fog installed.

    Hope that helps

  10. Thanks to denon101 from:

    Jed (26th June 2009)

  11. #8
    Jed
    Jed is offline
    Jed's Avatar
    Join Date
    Aug 2008
    Location
    Peacehaven
    Posts
    33
    Thank Post
    7
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I am behind a proxy I have entered my username/password in the following format:

    Username
    Password

    should I be using:

    domainname\username
    password

    ?

  12. #9
    Jed
    Jed is offline
    Jed's Avatar
    Join Date
    Aug 2008
    Location
    Peacehaven
    Posts
    33
    Thank Post
    7
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Got it!

    Thanks guys,

    I was using our unfiltered proxy but this wasn't working properly, I've changed to our proxy and my username password and it is working!

    Hoorah!

    Cheers guys, legendary as ever!

  13. #10
    denon101's Avatar
    Join Date
    Jul 2008
    Location
    Stuck in the server room......
    Posts
    397
    Thank Post
    54
    Thanked 37 Times in 35 Posts
    Rep Power
    21
    Excellent!!

  14. #11

    Join Date
    Nov 2006
    Posts
    998
    Thank Post
    132
    Thanked 58 Times in 51 Posts
    Rep Power
    24
    I couldn't get FOG to install whatsoever behind our firewall, so I just took the machine home to do it.

    One thing that's puzzled me however is the dhcp3-server daemon won't autostart...

  15. #12
    Jed
    Jed is offline
    Jed's Avatar
    Join Date
    Aug 2008
    Location
    Peacehaven
    Posts
    33
    Thank Post
    7
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Just a note to this thread.

    In order to install fog I had to switch a few times between our proxy address and unfiltered address.

    Hope this saves some time for someone!

  16. #13
    TechSupp's Avatar
    Join Date
    Mar 2007
    Location
    South Yorkshire
    Posts
    1,916
    Thank Post
    315
    Thanked 122 Times in 103 Posts
    Rep Power
    42
    Quote Originally Posted by fafster View Post
    I couldn't get FOG to install whatsoever behind our firewall, so I just took the machine home to do it.

    One thing that's puzzled me however is the dhcp3-server daemon won't autostart...

    I found that as well, couldn't understand why they would not log on to the FOG server then realised the DHCP on the FOG server was not started automatically! Anyone know how to set it to start automatically?

  17. #14

    Join Date
    Jul 2009
    Location
    Az
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    almost got it working... help

    so far I had to install all the packages manually and fog finally got past failing but I got this,

    Configuring services.

    * Setting up fog user...Exists
    * Setting up and starting MySql...Failed!
    I left the password blank so this would not happen, or so I thought.

    what is the next trick to get fog UP?

    thanks

  18. #15

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,592
    Thank Post
    109
    Thanked 770 Times in 598 Posts
    Rep Power
    182
    @badbot: A blank MySQL password can be troublesome as scripts/apps do not corretly pass 'nothing' for the password field.

SHARE:
+ Post New Thread
Page 1 of 3 123 LastLast

Similar Threads

  1. [Fog] FOG Help!
    By Dafty in forum O/S Deployment
    Replies: 2
    Last Post: 10th August 2011, 10:51 AM
  2. [Fog] Help required with FOG
    By TechSupp in forum O/S Deployment
    Replies: 4
    Last Post: 14th June 2009, 10:48 PM
  3. [Fog] FOG
    By CheeseDog in forum O/S Deployment
    Replies: 5
    Last Post: 3rd March 2009, 09:54 AM
  4. Using Netboot with FOG
    By monkeyx in forum O/S Deployment
    Replies: 11
    Last Post: 11th September 2008, 01:23 AM
  5. Fog!
    By localzuk in forum Other Stuff
    Replies: 1
    Last Post: 23rd January 2007, 11:25 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •