+ Post New Thread
Results 1 to 10 of 10
O/S Deployment Thread, SOLVED - WDS - PXE Missing Menu in Technical; We've just set up a WDS Server as we're considering using this rather than Ghost (which we use at the ...
  1. #1
    bmdixon's Avatar
    Join Date
    Apr 2008
    Location
    Birmingham
    Posts
    253
    Thank Post
    41
    Thanked 57 Times in 38 Posts
    Rep Power
    22

    SOLVED - WDS - PXE Missing Menu

    We've just set up a WDS Server as we're considering using this rather than Ghost (which we use at the moment).

    I've installed WDS (following the guide here.

    When i try and get a client to boot via PXE to capture an image it's saying "PXE-E74: Bad or missing PXE menu and/or prompt information".

    I've spent hours now trying to find a solution for this but not getting anywhere, so thought i'd call on the mighty edugeekers for advice!

    Please save me from my frustration!!!!!
    Last edited by bmdixon; 30th January 2009 at 01:52 PM.

  2. #2

    tmcd35's Avatar
    Join Date
    Jul 2005
    Location
    Norfolk
    Posts
    5,575
    Thank Post
    834
    Thanked 873 Times in 726 Posts
    Blog Entries
    9
    Rep Power
    324
    I went through this during the half of this month! Pleased to say I now have it working So I'll be glad to help why it's all still fresh in my mind!

    Did you upgrade from a RIS Installation? Are you running in native, mixed or legacy mode?

    Have you checked DHCP? Option 66 needs to be set to your WDS servers Ip and option 67 should be 'boot\x86\wdsnbp.cpm'

    Have you checked the 'Remote Install' tab in the computers account in AD. Should be set to Respond to clients.

    Check the 'Boot' tab in the WDS server properties. I've set both the x86 and x64 default boot program to 'Boot\x86\pxeboot.com'.

  3. Thanks to tmcd35 from:

    mrforgetful (6th July 2010)

  4. #3
    bmdixon's Avatar
    Join Date
    Apr 2008
    Location
    Birmingham
    Posts
    253
    Thank Post
    41
    Thanked 57 Times in 38 Posts
    Rep Power
    22
    Quote Originally Posted by tmcd35 View Post
    I went through this during the half of this month! Pleased to say I now have it working So I'll be glad to help why it's all still fresh in my mind!
    Thanks for you help
    Did you upgrade from a RIS Installation? Are you running in native, mixed or legacy mode?[/QUOTE]
    No, a fresh install. Not upgraded from RIS. Running in Native mode.
    Quote Originally Posted by tmcd35 View Post
    Have you checked DHCP? Option 66 needs to be set to your WDS servers Ip and option 67 should be 'boot\x86\wdsnbp.cpm'
    Have set those now, still not working....
    Quote Originally Posted by tmcd35 View Post
    Have you checked the 'Remote Install' tab in the computers account in AD. Should be set to Respond to clients.
    Where is this?.... not sure what you mean...

    Quote Originally Posted by tmcd35 View Post
    Check the 'Boot' tab in the WDS server properties. I've set both the x86 and x64 default boot program to 'Boot\x86\pxeboot.com'.
    Yeah, both set to that already.

  5. #4

    tmcd35's Avatar
    Join Date
    Jul 2005
    Location
    Norfolk
    Posts
    5,575
    Thank Post
    834
    Thanked 873 Times in 726 Posts
    Blog Entries
    9
    Rep Power
    324
    Both! Installed it in native mode first then turned the air blue when I reliased I needed mixed mode and had to uninstall both WDS and SP2 to get RIS installed first! aaahhh!

    'Active Directory Users and Computers' - your main AD database. Find the WDS server account in their and right-click, choose properties and go to the 'Remote Install' Tab.

    Also, are you running Vista on any desktop? Have you downloaded the 'Windows Automated Installation Kit' and extracted the correct .WIM files. You need two .wim files from the WAIK and the boot.wim from vista/server 2008.

    Also have you set at least one image group in the WDS Install Images folder?

  6. #5
    bmdixon's Avatar
    Join Date
    Apr 2008
    Location
    Birmingham
    Posts
    253
    Thank Post
    41
    Thanked 57 Times in 38 Posts
    Rep Power
    22
    Quote Originally Posted by tmcd35 View Post
    Both! Installed it in native mode first then turned the air blue when I reliased I needed mixed mode and had to uninstall both WDS and SP2 to get RIS installed first! aaahhh!

    'Active Directory Users and Computers' - your main AD database. Find the WDS server account in their and right-click, choose properties and go to the 'Remote Install' Tab.
    OK, gotcha. That is already set to "Respond to client computers..."
    Noticed that if i go into the advanced settings and click on images or tools tabs that i get an error: "Unable to contact the remote install server. The server may not be accessible at this time. The directory service has been updated with the new settings."
    Guessing this is not a good sign..... WDS service is started on the wds server though...
    Quote Originally Posted by tmcd35 View Post
    Also, are you running Vista on any desktop? Have you downloaded the 'Windows Automated Installation Kit' and extracted the correct .WIM files. You need two .wim files from the WAIK and the boot.wim from vista/server 2008.

    Also have you set at least one image group in the WDS Install Images folder?
    Not running any vista machines but have extracted the 2 .wim and the boot.wim files from vista business cd.

  7. #6

    tmcd35's Avatar
    Join Date
    Jul 2005
    Location
    Norfolk
    Posts
    5,575
    Thank Post
    834
    Thanked 873 Times in 726 Posts
    Blog Entries
    9
    Rep Power
    324
    When you installed the WDS server did you let it get DHCP authorisation. If not, it is begining to sound as if the server is not authorised.

    Either that or you might want to double check folder permissions for the WDS directory. Make sure the security is not getting in the way.

  8. #7
    bmdixon's Avatar
    Join Date
    Apr 2008
    Location
    Birmingham
    Posts
    253
    Thank Post
    41
    Thanked 57 Times in 38 Posts
    Rep Power
    22
    Just tried to reinstall it, but getting the same error.
    It has dhcp authorisation selected in the server properties in WDS, not sure what the permissions should be but even with full access to "Everyone" it doesn't work.

    Thanks for your help so far tmcd35

  9. #8
    bmdixon's Avatar
    Join Date
    Apr 2008
    Location
    Birmingham
    Posts
    253
    Thank Post
    41
    Thanked 57 Times in 38 Posts
    Rep Power
    22

    FIXED IT! :D

    Ok, it works (at least i now get the pxe menu)
    We had option 43 enabled on our dhcp server, as soon as i took that off (and 60, 66,67) it worked.

  10. #9

    tmcd35's Avatar
    Join Date
    Jul 2005
    Location
    Norfolk
    Posts
    5,575
    Thank Post
    834
    Thanked 873 Times in 726 Posts
    Blog Entries
    9
    Rep Power
    324
    Ahh, sorry forgot about Option 43! My DHCP server is on a different machine so I never set it in the first place, and then forgot all about it. I do remember reading somewhere about the need to enable that if DHCP and WDS/RIS are on the sam server.

    Still glad you got it working in the end.

  11. #10
    mrforgetful's Avatar
    Join Date
    May 2006
    Posts
    1,637
    Thank Post
    7
    Thanked 15 Times in 15 Posts
    Rep Power
    22
    Quote Originally Posted by tmcd35 View Post
    I went through this during the half of this month! Pleased to say I now have it working So I'll be glad to help why it's all still fresh in my mind!

    Did you upgrade from a RIS Installation? Are you running in native, mixed or legacy mode?

    Have you checked DHCP? Option 66 needs to be set to your WDS servers Ip and option 67 should be 'boot\x86\wdsnbp.cpm'

    Have you checked the 'Remote Install' tab in the computers account in AD. Should be set to Respond to clients.

    Check the 'Boot' tab in the WDS server properties. I've set both the x86 and x64 default boot program to 'Boot\x86\pxeboot.com'.
    Thankyou Thankyou Thankyou!

    I've been trying to get this working on and off for a month or two.

    Yours is the first post I've come across that got me the correct menu appearing to choose between WDS and RIS.

    You're the first to mention using the two different boot programs in different places and that is what fixed it.

    Again, thankyou )

SHARE:
+ Post New Thread

Similar Threads

  1. (MDT), WDS and PXE TFTP not happening
    By PiqueABoo in forum Windows Server 2008
    Replies: 5
    Last Post: 14th November 2009, 03:17 PM
  2. WDS Legacy Mode vs WDS
    By markwilliamson2001 in forum Windows
    Replies: 0
    Last Post: 15th July 2008, 12:50 PM
  3. WDS and PXE booting
    By powdarrmonkey in forum Wireless Networks
    Replies: 3
    Last Post: 19th June 2008, 09:44 PM
  4. Create menu & sub-menu with Edugeek Joomla
    By FN-GM in forum EduGeek Joomla 1.0 Package
    Replies: 24
    Last Post: 8th December 2007, 11:48 PM
  5. Replies: 8
    Last Post: 8th June 2007, 09:32 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •