+ Post New Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 34
O/S Deployment Thread, MDT Help!! in Technical; Hello, Anyone have any tips for speeding up MDT ? Currently it all works fine, however the only things I ...
  1. #1

    Join Date
    Feb 2014
    Location
    Cumbria
    Posts
    105
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Angry MDT Help!!

    Hello,
    Anyone have any tips for speeding up MDT?

    Currently it all works fine, however the only things I want to speed up are mainly the initial setup.
    So, instead of me having to select the task sequence, it automatically picks it.
    I don't want to have to type in the domain, it should automatically do it for me?

    Just so I can skip these tedious steps!


    All I want to have to do is type in the credentials for connecting to network shares (if this is compulsory)
    Then enter the name for the machine
    and then select the software to install!

    Any ideas on how to make it THIS easy?

    Thanks!

  2. #2

    Join Date
    Mar 2007
    Posts
    1,791
    Thank Post
    82
    Thanked 296 Times in 227 Posts
    Rep Power
    87

  3. #3
    AlexB's Avatar
    Join Date
    Jul 2006
    Location
    Warwickshire
    Posts
    373
    Thank Post
    37
    Thanked 39 Times in 35 Posts
    Rep Power
    23
    You can make it zero touch if you are so inclined...

    This assumes on one task sequence that you want to pick, all applications in one application pack and computers already have the correct name (reimage), otherwise if you want to pick the name just change commented sections below

    bootstrap.ini
    Code:
    [Settings]
    Priority=Default
    
    [Default]
    DeployRoot=<leave at your current setting>
    
    SkipBDDWelcome=YES
    
    KeyboardLocalePE=0809:00000809
    
    UserID=<domain admin, your domain joiner with enough perms to access files for deploy>
    UserPassword=<above's password>
    UserDomain=<your domain name>
    rules.ini
    Code:
    [Settings]
    Priority=Default
    Properties=MyCustomProperty
    
    [Default]
    
    ;This is for using exitsing name
    
    UserExit=UserExit.vbs
    OSDComputername=#GetOfflineComputername()#
    SkipComputerName=YES
    
    ;This is for picking name at image time
    
    ;SkipComputerName=NO
    ;ComputerName=<we set this to the format of naming to help remind imager, e.g. <room>-<number>>
    
    ;End of naming
    
    SkipBDDWelcome=YES
    OSInstall=YES
    
    OrgName="<whatever organisation name you use>"
    FullName="<whatever full name you use, e.g. Authorised User>"
    
    SkipTimeZone=YES
    TimeZone=085
    TimeZoneName=GMT Standard Time
    
    SkipLocaleSelection=YES
    GeoID=0XF2
    UserLocale=en-gb
    KeyboardLocale=0809:00000809
    
    SkipUserData=YES
    UserDataLocation=NONE
    
    ;Task sequence ID
    SkipTaskSequence=YES
    TaskSequenceID=W7_SP1_WAR
    
    SkipAppsOnUpgrade=YES
    SkipProductKey=YES
    SkipBitLocker=YES
    
    
    ;I know you can set elsewhere, but we picked here...
    SkipAdminPassword=YES
    AdminPassword=<local admin password>
    
    DeploymentType=NEWCOMPUTER
    DoNotCreateExtraPartition=YES
    
    SkipApplications=YES
    ;UID of the application pack containing all your apps
    Applications001={1182ad04-4c82-46fc-94b7-10d00cb47d7b}
    
    ;Really oddly I found that if I didn't put account details in hear then it didn't work if hidden, but worked fine if not hidden and just clicked through... odd world
    SkipDomainMembership=YES
    JoinDomain=<domain FQDN>
    DomainAdminDomain=<domain FQDN>
    DomainAdmin=<domain joiner account>
    DomainAdminPassword=<above's password>
    ;OU during and after image, but if machine already exists it seems to leave alone in what OU it is already in.
    StagingOU=OU=xxx,OU=xxx,DC=internal
    MachineObjectOU=OU=xxx,OU=xxx,DC=internal
    
    SkipCapture=YES
    DoCapture=NO
    
    SkipSummary=YES
    SkipFinalSummary=YES
    
    FinishAction=RESTART
    We put windows update before and after application install and set a reboot at end in the task sequence.

    UserExit.vbs goes in <deploymentshare>\Scripts and is only needed for picking up existing computer name.

    This assumes you are UK based with UK keyboards, change as required

    Change SkipXXXXXX=Yes to SkipXXXXX=No for those sections you want to pick, it will just default to whatever is set above

    It should go without saying, but...
    Backup both rules.ini and bootstrap.ini before you start
    Attached Files Attached Files
    Last edited by AlexB; 4th April 2014 at 11:14 AM.

  4. Thanks to AlexB from:

    GRitchie (4th April 2014)

  5. #4

    Join Date
    Feb 2014
    Location
    Cumbria
    Posts
    105
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Ah - excellent.
    I will give this a shot later on today!

    Thank you very much for this!!

  6. #5

    Join Date
    Feb 2014
    Location
    Cumbria
    Posts
    105
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks!
    So if I want to manually enter the computer name, I can leave this script and that section to SKIP=NO?

  7. #6

    Join Date
    Feb 2014
    Location
    Cumbria
    Posts
    105
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Sounds like a really stupid question, but where do I locate the rules.ini and bootstrap.ini files?

  8. #7
    AlexB's Avatar
    Join Date
    Jul 2006
    Location
    Warwickshire
    Posts
    373
    Thank Post
    37
    Thanked 39 Times in 35 Posts
    Rep Power
    23
    Within the Deployment Workbench, right click the "MDT Deployment Share <path>" on the left tree and click properties. rules.ini is the Rules tab, bootstrap.ini is a button at the bottom of this tab. Note that changing the bootstrap.ini causes the wim/iso to be regenerated after you Update Deployment Share, so replace your current wim (probably in WDS) with the newly generated one.

    For naming with choosing use the below. I'd still copy the vbs file and keep the commented section... you never know what you'll do in the future
    Code:
    ;This is for using exitsing name
    
    ;UserExit=UserExit.vbs
    ;OSDComputername=#GetOfflineComputername()#
    ;SkipComputerName=YES
    
    ;This is for picking name at image time
    
    SkipComputerName=NO
    ComputerName=<we set this to the format of naming to help remind imager, e.g. <room>-<number>>
    
    ;End of naming
    Last edited by AlexB; 4th April 2014 at 11:12 AM.

  9. #8
    AlexB's Avatar
    Join Date
    Jul 2006
    Location
    Warwickshire
    Posts
    373
    Thank Post
    37
    Thanked 39 Times in 35 Posts
    Rep Power
    23
    Oh, forgot to say. I started down this line for exacting the same reason... far too many windows to click through where most of them only want the default settings anyway!

  10. #9

    Join Date
    Feb 2014
    Location
    Cumbria
    Posts
    105
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Yeah - exactly!


    Just configured now, testing it in 30 seconds, I'll tell you the outcome.

  11. #10

    Join Date
    Feb 2014
    Location
    Cumbria
    Posts
    105
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hmm, this seems to have enabled ALL settings for me to click through?

  12. #11
    AlexB's Avatar
    Join Date
    Jul 2006
    Location
    Warwickshire
    Posts
    373
    Thank Post
    37
    Thanked 39 Times in 35 Posts
    Rep Power
    23
    Did you update the deployment share and use the new wim/iso?

  13. #12

    Join Date
    Feb 2014
    Location
    Cumbria
    Posts
    105
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I think the issue was I didn't change the name of the task sequence - retrying now!

  14. #13

    Join Date
    Feb 2014
    Location
    Cumbria
    Posts
    105
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Scratch that - still no luck!

    If you'd prefer to email it might be easier back and forth? :-)

  15. #14

    Join Date
    Feb 2014
    Location
    Cumbria
    Posts
    105
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    This is okay isn't it?

    Code:
    [Settings]
    Priority=Default
    Properties=MyCustomProperty
    
    
    [Default]
    
    
    ;This is for using exitsing name
    
    
    UserExit=UserExit.vbs
    OSDComputername=#GetOfflineComputername()#
    SkipComputerName=NO
    
    
    ;This is for picking name at image time
    
    
    ;SkipComputerName=NO
    ;ComputerName=<we set this to the format of naming to help remind imager, e.g. <room>-<number>>
    
    
    ;End of naming
    
    
    SkipBDDWelcome=YES
    OSInstall=YES
    
    
    OrgName="Dowdales School"
    FullName="Dowdales School"
    
    
    SkipTimeZone=YES
    TimeZone=085
    TimeZoneName=GMT Standard Time
    
    
    SkipLocaleSelection=YES
    GeoID=0XF2
    UserLocale=en-gb
    KeyboardLocale=0809:00000809
    
    
    SkipUserData=YES
    UserDataLocation=NONE
    
    
    ;Task sequence ID
    SkipTaskSequence=YES
    TaskSequenceID=WINDOWS7
    
    
    SkipAppsOnUpgrade=YES
    SkipProductKey=YES
    SkipBitLocker=YES
    
    
    
    
    SkipAdminPassword=YES
    AdminPassword=******
    
    
    DeploymentType=NEWCOMPUTER
    DoNotCreateExtraPartition=YES
    
    
    SkipApplications=NO
    ;UID of the application pack containing all your apps
    Applications001={1182ad04-4c82-46fc-94b7-10d00cb47d7b}
    
    
    ;Really oddly I found that if I didn't put account details in hear then it didn't work if hidden, but worked fine if not hidden and just clicked through... odd world
    SkipDomainMembership=YES
    JoinDomain=STAFF.INTERNAL
    DomainAdminDomain=STAFF.INTERNAL
    DomainAdmin=Administrator
    DomainAdminPassword=**********
    
    
    SkipCapture=YES
    DoCapture=NO
    
    
    SkipSummary=YES
    SkipFinalSummary=YES
    
    
    FinishAction=RESTART

  16. #15
    AlexB's Avatar
    Join Date
    Jul 2006
    Location
    Warwickshire
    Posts
    373
    Thank Post
    37
    Thanked 39 Times in 35 Posts
    Rep Power
    23
    I don't mind, but it might be useful for those that come after use with similar problems to see the whole thread.

    Regardless of whether you post here or private message, if you could post a copy for your rules.ini and bootstrap.ini .... looks like you beat me to saying that, looking now...

SHARE:
+ Post New Thread
Page 1 of 3 123 LastLast

Similar Threads

  1. Replies: 2
    Last Post: 26th March 2014, 11:27 AM
  2. Replies: 2
    Last Post: 31st October 2013, 10:30 AM
  3. Replies: 13
    Last Post: 17th September 2013, 01:41 AM
  4. Replies: 0
    Last Post: 22nd January 2013, 03:43 PM
  5. [SCCM 2007] Using MDT Roles with SCCM 2007 R3 - Help!!
    By craigg in forum O/S Deployment
    Replies: 2
    Last Post: 26th September 2011, 08:50 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •