+ Post New Thread
Results 1 to 9 of 9
O/S Deployment Thread, SCCM 2012 PXE boot client gets bad BCD file in Technical; ...
  1. #1

    Join Date
    Aug 2007
    Location
    Liphook
    Posts
    52
    Thank Post
    3
    Thanked 2 Times in 2 Posts
    Rep Power
    15

    SCCM 2012 PXE boot client gets bad BCD file

    Hi,

    I have SCCM 2012 installed and have jumped right into OS deployment I am hitting a wall with the client giving the error:
    The Windows Boot Configuration Data (BDC) file from the PXE server does not contain a valid operating system entry.
    Error code: 0xc0000098


    I have setup a distro point and configured PXE and have also distributed the 32 and 64 bit boot files.

    I think the problem is with my DHCP server which was set for our current win2008 WDS server. I have set the Boot server host name to the new SCCM server. I'm at a loss as to what I should set the Boot file name to be!

    I have followed this guide for installing as the book a brought is already out of date (grr)
    Install Guide – ConfigMgr 2012 SP1 Beta + Server 2012 + SQL 2012 CU 3

    And this for the OSD part
    SCCM 2012 SP1 - OSD With WDS / PXE / MDT 2012 UDI - YouTube

    Any help appreciated. I really don't want to build myself a LAB SCCM server it all takes so long!!

  2. #2
    Sam_Brown's Avatar
    Join Date
    Sep 2009
    Location
    Northampton
    Posts
    568
    Thank Post
    95
    Thanked 38 Times in 36 Posts
    Rep Power
    18
    Option 066 needs to be set to the IP of the SCCM Server
    Option 067 needs to be set to "smsboot\x64\wdsnbp.com"

    Also go to Administration > Site Configuration > Servesr and Site System Roles and go into the Distribution Point properties. Make sure the PXE options have been set up and enabled.

  3. #3
    TheScarfedOne's Avatar
    Join Date
    Apr 2007
    Location
    Plymouth, Devon
    Posts
    1,297
    Thank Post
    616
    Thanked 162 Times in 147 Posts
    Blog Entries
    78
    Rep Power
    83
    Quote Originally Posted by Sam_Brown View Post
    Option 066 needs to be set to the IP of the SCCM Server
    Option 067 needs to be set to "smsboot\x64\wdsnbp.com"

    Also go to Administration > Site Configuration > Servesr and Site System Roles and go into the Distribution Point properties. Make sure the PXE options have been set up and enabled.
    Beat me to it. You may occasionally see this too when the server is congested... Just fyi

  4. #4
    Sam_Brown's Avatar
    Join Date
    Sep 2009
    Location
    Northampton
    Posts
    568
    Thank Post
    95
    Thanked 38 Times in 36 Posts
    Rep Power
    18
    Quick question... even though the path has "x64" will it still work with 32 bit clients? Or do I need to change the option depending on whether the client I'm deploying to is 64 or 32 bit?
    Last edited by Sam_Brown; 24th June 2013 at 08:14 PM.

  5. #5
    TheScarfedOne's Avatar
    Join Date
    Apr 2007
    Location
    Plymouth, Devon
    Posts
    1,297
    Thank Post
    616
    Thanked 162 Times in 147 Posts
    Blog Entries
    78
    Rep Power
    83
    You need to have an x86 and x64 boot image set up and distributed... Even if you don't plan to use it

  6. #6
    Sam_Brown's Avatar
    Join Date
    Sep 2009
    Location
    Northampton
    Posts
    568
    Thank Post
    95
    Thanked 38 Times in 36 Posts
    Rep Power
    18
    I was just curious about the actual PXE boot... will a 32 bit machine be able to pxe boot using the "smsboot\x64\wdsnbp.com" file or will I need to edit the dhcp option to "smsboot\x86\wdsnbp.com" whenever I plan on building a 32 bit machine?

  7. #7
    TheScarfedOne's Avatar
    Join Date
    Apr 2007
    Location
    Plymouth, Devon
    Posts
    1,297
    Thank Post
    616
    Thanked 162 Times in 147 Posts
    Blog Entries
    78
    Rep Power
    83
    Ah, no...I need to check the path used. I don't think you list the x86 x64 bit in the path...

  8. #8

    Join Date
    Aug 2013
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Sam_Brown View Post
    Option 066 needs to be set to the IP of the SCCM Server
    Option 067 needs to be set to "smsboot\x64\wdsnbp.com"

    Also go to Administration > Site Configuration > Servesr and Site System Roles and go into the Distribution Point properties. Make sure the PXE options have been set up and enabled.
    Just wanted to see if anyone had an update for this. Does everyone use this path or can I change the path to smsboot\x86\wdsnbp.com ?

  9. #9

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,689
    Thank Post
    516
    Thanked 2,455 Times in 1,899 Posts
    Blog Entries
    24
    Rep Power
    833
    Quote Originally Posted by Redhawk View Post
    Just wanted to see if anyone had an update for this. Does everyone use this path or can I change the path to smsboot\x86\wdsnbp.com ?
    The images will work as follows:

    32Bit Image 64Bit Image 32Bit Installer Package 64Bit Installer Package
    x86 Boot Image Yes Yes Yes No
    x64 Boot Image No Yes No Yes

    So, you need to use the right boot image for the right systems.

SHARE:
+ Post New Thread

Similar Threads

  1. SCCM 2012 PXE boot no longer working
    By jaminben in forum Enterprise Software
    Replies: 10
    Last Post: 9th April 2013, 02:23 PM
  2. SCCM 2012 - PXE Boot woes
    By stebo730 in forum O/S Deployment
    Replies: 4
    Last Post: 8th February 2013, 11:09 AM
  3. [SCCM 2012] PXE OS Deployment Woes...
    By cmorgan in forum Enterprise Software
    Replies: 14
    Last Post: 10th August 2012, 03:36 PM
  4. Netbooks PXE boot never gets IP
    By Blue_Cookeh in forum Wired Networks
    Replies: 2
    Last Post: 18th July 2012, 02:58 PM
  5. SCCM 2012 pxe problems
    By AliG in forum Enterprise Software
    Replies: 3
    Last Post: 18th May 2012, 09:41 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •