+ Post New Thread
Results 1 to 12 of 12
O/S Deployment Thread, Injecting a NIC driver into WinPE boot image. in Technical; I need to image a group of PC's that must have an unsupported network card. (The weirdest thing being i ...
  1. #1
    fairm010's Avatar
    Join Date
    Jun 2010
    Location
    C:/Windows/System32/
    Posts
    1,440
    Thank Post
    61
    Thanked 206 Times in 178 Posts
    Rep Power
    56

    Injecting a NIC driver into WinPE boot image.

    I need to image a group of PC's that must have an unsupported network card. (The weirdest thing being i managed to succesfully use the boot image to "Capture" but the "Install" doesnt like the NIC.)

    I have read the easiest way is to inject the driver into the offline boot image using DISM but i cant find any decent guides anywhere.

    Can anyone help?

    (On another note, we have just received "The Call"!)

  2. #2

    Join Date
    Jan 2008
    Location
    South West
    Posts
    1,842
    Thank Post
    219
    Thanked 271 Times in 219 Posts
    Rep Power
    69
    This is a copy of someones guide from the web that I stuck into a word doc. Sorry I cant credit the author I did it along time ago. I have used these instructions and they worked for me. I believe there is an better way todo this if you have a later version of server (2008+)

    Add Drivers to WinPE.docx

    EDIT: Durrr it was in the first line of the doc. http://www.commodore.ca/windows/inje...vers_winpe.htm
    Last edited by chazzy2501; 26th February 2013 at 03:14 PM.

  3. #3

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    10,044
    Thank Post
    3,579
    Thanked 1,119 Times in 1,024 Posts
    Rep Power
    377
    Last edited by mac_shinobi; 26th February 2013 at 03:21 PM.

  4. #4
    fairm010's Avatar
    Join Date
    Jun 2010
    Location
    C:/Windows/System32/
    Posts
    1,440
    Thank Post
    61
    Thanked 206 Times in 178 Posts
    Rep Power
    56
    Thanks guys. We are due to upgrade to 2012 in Easter but they want the PC's imaged this week! I'll give this a go!

    Thanks again

    Matt

  5. #5
    fairm010's Avatar
    Join Date
    Jun 2010
    Location
    C:/Windows/System32/
    Posts
    1,440
    Thank Post
    61
    Thanked 206 Times in 178 Posts
    Rep Power
    56
    Stupid question but in a n00b with WDS. I understand all that injection driver business, seems straightforward enough however: Do i inject into the Windows 7 image im installing or the Boot image that you initaially boot into?

  6. #6


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    7,050
    Thank Post
    232
    Thanked 922 Times in 791 Posts
    Rep Power
    308
    yes in a nutshell you export a boot.wim from wds mount it run dism to add drivers unmount it and reload into wds if you have server08r2 though it can do it via the wds console

  7. #7
    fairm010's Avatar
    Join Date
    Jun 2010
    Location
    C:/Windows/System32/
    Posts
    1,440
    Thank Post
    61
    Thanked 206 Times in 178 Posts
    Rep Power
    56
    Sorry i should have said in that previous post that it is currently Server 08 Standard.

  8. #8

    Join Date
    Jan 2008
    Location
    South West
    Posts
    1,842
    Thank Post
    219
    Thanked 271 Times in 219 Posts
    Rep Power
    69
    Yes, you are injecting it into the windows PE not the windows 7 image.

  9. #9

    DaveP's Avatar
    Join Date
    Oct 2006
    Location
    Can't talk now: The mother-ship is calling!
    Posts
    9,353
    Thank Post
    353
    Thanked 1,346 Times in 925 Posts
    Blog Entries
    4
    Rep Power
    1202
    This thread:

    Link 1: Building Dell Optiplex 790 [Windows 7: 64 Bit]

    and this reply in that thread:

    Link 2: Building Dell Optiplex 790 [Windows 7: 64 Bit]

    both seem to be somewhat relevant to this thread.

  10. #10

    Join Date
    May 2013
    Location
    Santa Clara,CA
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    When I try to use my WDS console in 2008, there is nothing there to work with and no way to import it???

  11. #11

    DaveP's Avatar
    Join Date
    Oct 2006
    Location
    Can't talk now: The mother-ship is calling!
    Posts
    9,353
    Thank Post
    353
    Thanked 1,346 Times in 925 Posts
    Blog Entries
    4
    Rep Power
    1202
    Quote Originally Posted by TerrenceRocks View Post
    When I try to use my WDS console in 2008, there is nothing there to work with and no way to import it???
    Can you post a screenshot of what you see in your WDS console? Could be helpful when discussing the issue[s] you are having.

  12. #12


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    7,050
    Thank Post
    232
    Thanked 922 Times in 791 Posts
    Rep Power
    308
    Quote Originally Posted by TerrenceRocks View Post
    When I try to use my WDS console in 2008, there is nothing there to work with and no way to import it???
    if its 2008 (vista server) rather than 2008r2 (7 server) the options arnt there you need to use dism and do it yourself iirc



SHARE:
+ Post New Thread

Similar Threads

  1. Injecting Drivers into Boot Image Issue
    By disco_samurai in forum O/S Deployment
    Replies: 12
    Last Post: 8th December 2011, 10:51 AM
  2. Adding new NIC Drivers to PXE Boot
    By acrobson in forum How do you do....it?
    Replies: 0
    Last Post: 1st February 2011, 06:39 PM
  3. [WDS] Inject drivers into WIM file
    By dezt in forum O/S Deployment
    Replies: 6
    Last Post: 23rd June 2010, 11:28 AM
  4. Replies: 4
    Last Post: 30th December 2009, 10:57 AM
  5. [Ghost] USB Ghost BOOT with common NIC drivers
    By Cowardlyduck in forum O/S Deployment
    Replies: 16
    Last Post: 15th October 2009, 12:22 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •