+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21
*nix Thread, Ubuntu server, web downloads fail in Technical; aptitude and the command line use different settings, try this on the command line first: Code: export http_proxy="http://username:Password@my.proxy.server:port" and then ...
  1. #16
    hit
    hit is online now
    hit's Avatar
    Join Date
    Mar 2008
    Location
    London
    Posts
    324
    Thank Post
    47
    Thanked 50 Times in 48 Posts
    Rep Power
    50
    aptitude and the command line use different settings, try this on the command line first:

    Code:
    export http_proxy="http://username:Password@my.proxy.server:port"
    and then do a wget

  2. #17
    hit
    hit is online now
    hit's Avatar
    Join Date
    Mar 2008
    Location
    London
    Posts
    324
    Thank Post
    47
    Thanked 50 Times in 48 Posts
    Rep Power
    50
    Oh, I forgot, if the above works, put it into the end of /etc/profile and it will be set everytime you logon.

  3. #18

    Join Date
    Jun 2011
    Posts
    51
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by hit View Post
    aptitude and the command line use different settings, try this on the command line first:

    Code:
    export http_proxy="http://username:Password@my.proxy.server:port"
    and then do a wget
    That worked!!! Where does it exported proxy setting to?

    Thanks a lot!

  4. #19
    hit
    hit is online now
    hit's Avatar
    Join Date
    Mar 2008
    Location
    London
    Posts
    324
    Thank Post
    47
    Thanked 50 Times in 48 Posts
    Rep Power
    50
    Quote Originally Posted by happierlarry View Post
    That worked!!! Where does it exported proxy setting to?

    Thanks a lot!
    No problem, it just sets an environment variable, same as SET in windows. you should also add it to /etc/profile so it sets it at logon for you.

  5. #20

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,541
    Thank Post
    513
    Thanked 2,408 Times in 1,864 Posts
    Blog Entries
    24
    Rep Power
    822
    Quote Originally Posted by happierlarry View Post
    That worked!!! Where does it exported proxy setting to?

    Thanks a lot!
    It creates a session variable basically - so when you log out it'll disappear and you'll need to run it again next login.

    You can edit your /etc/profile to contain that line though, so it gets put in by default.

    How to configure Proxy Settings for the Linux Console and APT | The WireFrame

  6. #21

    Join Date
    Jun 2011
    Posts
    51
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Done it.

    Thanks again!

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. [Ubuntu] shibboleth and Ubuntu server
    By atamakosi in forum *nix
    Replies: 1
    Last Post: 23rd May 2012, 11:16 PM
  2. [Ubuntu] Setting Network Proxy in Ubuntu Server
    By nawbus in forum *nix
    Replies: 9
    Last Post: 13th May 2010, 12:28 PM
  3. Ubuntu Server Error
    By Jackd in forum *nix
    Replies: 5
    Last Post: 2nd October 2007, 08:25 PM
  4. Ubuntu Server FQ Domain name not set
    By mark in forum *nix
    Replies: 6
    Last Post: 26th July 2007, 11:35 AM
  5. Exchange Server 2003 - HDD Fail - Please Help
    By ninjabeaver in forum Windows
    Replies: 6
    Last Post: 20th March 2007, 05:06 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •