+ Post New Thread
Results 1 to 3 of 3
*nix Thread, apt is broken.. in Technical; Code: root@ubuntu:/home/rex/public_html# apt-get install php5-gd E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the ...
  1. #1

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,527
    Thank Post
    1,339
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200

    apt is broken..

    Code:
    root@ubuntu:/home/rex/public_html# apt-get install php5-gd
    E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
    Code:
    root@ubuntu:/home/rex/public_html# sudo dpkg --configure -a
    dpkg: parse error, in file '/var/lib/dpkg/updates/0000' near line 0:
     newline in field name `#!/bin/sh'
    last reboot f2sk fixed a loadf of file system errors and Im guessing something in the dpkg folder has become corrupt..

    Im in the process of migrating everything to a new server but I need to get php5-gd installed and would like to try get apt fixed..

    Is it a lost cause?

  2. #2


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339

  3. Thanks to CyberNerd from:

    RabbieBurns (16th March 2012)

  4. #3

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,527
    Thank Post
    1,339
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    why is it that i struggle for a solution all week, and within minutes of posting it on here i find the answer!?

    Code:
    root@ubuntu:/home/rex/public_html# cd /var/lib/dpkg/updates/
    root@ubuntu:/var/lib/dpkg/updates# rm *
    root@ubuntu:/var/lib/dpkg/updates# sudo dpkg --configure -a
    dpkg: parse error, in file '/var/lib/dpkg/available' near line 0:
     newline in field name `#!/bin/sh'
    root@ubuntu:/var/lib/dpkg/updates# dpkg --clear-avail
    root@ubuntu:/var/lib/dpkg/updates# sudo dpkg --configure -a
    now it works

    Code:
    root@ubuntu:/var/lib/dpkg/updates# apt-get install php5-gd
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
      libt1-5
    The following NEW packages will be installed:
      libt1-5 php5-gd
    0 upgraded, 2 newly installed, 0 to remove and 15 not upgraded.
    Need to get 212kB of archives.
    After this operation, 598kB of additional disk space will be used.
    Do you want to continue [Y/n]?
    Thanks for you suggestion cybernerd but to copy all the files off the CD would probably take me longer than to build a new install ;p

SHARE:
+ Post New Thread

Similar Threads

  1. WOL is broken in Windows 7
    By GoldenWonder in forum Windows 7
    Replies: 16
    Last Post: 28th September 2010, 10:42 AM
  2. My DNS is broken :(
    By Simcfc73 in forum Windows
    Replies: 2
    Last Post: 17th December 2009, 09:46 AM
  3. teh Java is broken everywheres! :(
    By Oops_my_bad in forum Windows
    Replies: 2
    Last Post: 15th September 2008, 09:58 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •