+ Post New Thread
Results 1 to 10 of 10
*nix Thread, Ubuntu 10.04 407 Proxy in Technical; Hello i hope i'm not posting in the wrong section. Pretty much at work i have a Linux box which ...
  1. #1
    LJay's Avatar
    Join Date
    Feb 2012
    Location
    United Kingdom
    Posts
    12
    Thank Post
    3
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Ubuntu 10.04 407 Proxy

    Hello i hope i'm not posting in the wrong section. Pretty much at work i have a Linux box which is running ubuntu 10.04. I can browse the internet by typing the proxy settings into firefox > network, but using the command apt-get update or wget google.co.uk etc gives me this error which is posted below.

    Code:
    root@lewis-desktop:/home/lewis# apt-get update
    Ign http://gb.archive.ubuntu.com lucid Release.gpg
    Ign http://security.ubuntu.com lucid-security Release.gpg
    Ign http://dl.google.com stable Release.gpg                             
    Ign http://gb.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_GB   
    Ign http://dl.google.com/linux/chrome/deb/ stable/main Translation-en_GB
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_GB
    Ign http://gb.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_GB
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_GB
    Ign http://dl.google.com stable Release                                  
    Ign http://dl.google.com stable/main Packages                                  
    Ign http://gb.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_GB      
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_GB
    Ign http://gb.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_GB
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_GB
    Ign http://dl.google.com stable/main Packages  
    Ign http://security.ubuntu.com lucid-security Release                    
    Ign http://gb.archive.ubuntu.com lucid-updates Release.gpg               
    Err http://dl.google.com stable/main Packages                            
      407  Proxy Authentication Required
    Ign http://security.ubuntu.com lucid-security/main Packages                    
    Ign http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_GB  
    Ign http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_GB
    Ign http://security.ubuntu.com lucid-security/restricted Packages
    Ign http://security.ubuntu.com lucid-security/main Sources
    Ign http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_GB
    Ign http://security.ubuntu.com lucid-security/restricted Sources
    Ign http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_GB
    Ign http://gb.archive.ubuntu.com lucid Release
    Ign http://security.ubuntu.com lucid-security/universe Packages
    Ign http://security.ubuntu.com lucid-security/universe Sources
    Ign http://gb.archive.ubuntu.com lucid-updates Release
    Ign http://security.ubuntu.com lucid-security/multiverse Packages
    Ign http://gb.archive.ubuntu.com lucid/main Packages
    Ign http://gb.archive.ubuntu.com lucid/restricted Packages
    Ign http://security.ubuntu.com lucid-security/multiverse Sources
    Ign http://gb.archive.ubuntu.com lucid/main Sources
    Ign http://security.ubuntu.com lucid-security/main Packages
    Ign http://gb.archive.ubuntu.com lucid/restricted Sources
    Ign http://security.ubuntu.com lucid-security/restricted Packages
    Ign http://security.ubuntu.com lucid-security/main Sources
    Ign http://gb.archive.ubuntu.com lucid/universe Packages
    Ign http://gb.archive.ubuntu.com lucid/universe Sources
    Ign http://security.ubuntu.com lucid-security/restricted Sources
    Ign http://security.ubuntu.com lucid-security/universe Packages
    Ign http://gb.archive.ubuntu.com lucid/multiverse Packages
    Ign http://security.ubuntu.com lucid-security/universe Sources
    Ign http://gb.archive.ubuntu.com lucid/multiverse Sources
    Ign http://gb.archive.ubuntu.com lucid-updates/main Packages             
    Ign http://security.ubuntu.com lucid-security/multiverse Packages        
    Ign http://security.ubuntu.com lucid-security/multiverse Sources
    Ign http://gb.archive.ubuntu.com lucid-updates/restricted Packages
    Ign http://gb.archive.ubuntu.com lucid-updates/main Sources
    Err http://security.ubuntu.com lucid-security/main Packages
      407  Proxy Authentication Required
    Ign http://gb.archive.ubuntu.com lucid-updates/restricted Sources
    Err http://security.ubuntu.com lucid-security/restricted Packages
      407  Proxy Authentication Required
    Ign http://gb.archive.ubuntu.com lucid-updates/universe Packages         
    Err http://security.ubuntu.com lucid-security/main Sources               
      407  Proxy Authentication Required
    Err http://security.ubuntu.com lucid-security/restricted Sources
      407  Proxy Authentication Required
    Ign http://gb.archive.ubuntu.com lucid-updates/universe Sources
    Err http://security.ubuntu.com lucid-security/universe Packages
      407  Proxy Authentication Required
    Ign http://gb.archive.ubuntu.com lucid-updates/multiverse Packages
    Ign http://gb.archive.ubuntu.com lucid-updates/multiverse Sources
    Err http://security.ubuntu.com lucid-security/universe Sources
      407  Proxy Authentication Required
    Ign http://gb.archive.ubuntu.com lucid/main Packages
    Err http://security.ubuntu.com lucid-security/multiverse Packages
      407  Proxy Authentication Required
    Ign http://gb.archive.ubuntu.com lucid/restricted Packages
    Err http://security.ubuntu.com lucid-security/multiverse Sources
      407  Proxy Authentication Required
    Ign http://gb.archive.ubuntu.com lucid/main Sources
    Ign http://gb.archive.ubuntu.com lucid/restricted Sources
    Ign http://gb.archive.ubuntu.com lucid/universe Packages
    Ign http://gb.archive.ubuntu.com lucid/universe Sources
    Ign http://gb.archive.ubuntu.com lucid/multiverse Packages
    Ign http://gb.archive.ubuntu.com lucid/multiverse Sources
    Ign http://gb.archive.ubuntu.com lucid-updates/main Packages
    Ign http://gb.archive.ubuntu.com lucid-updates/restricted Packages
    Ign http://gb.archive.ubuntu.com lucid-updates/main Sources
    Ign http://gb.archive.ubuntu.com lucid-updates/restricted Sources
    Ign http://gb.archive.ubuntu.com lucid-updates/universe Packages
    Ign http://gb.archive.ubuntu.com lucid-updates/universe Sources
    Ign http://gb.archive.ubuntu.com lucid-updates/multiverse Packages
    Ign http://gb.archive.ubuntu.com lucid-updates/multiverse Sources
    Err http://gb.archive.ubuntu.com lucid/main Packages
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid/restricted Packages
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid/main Sources
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid/restricted Sources
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid/universe Packages
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid/universe Sources
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid/multiverse Packages
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid/multiverse Sources
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid-updates/main Packages
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid-updates/restricted Packages
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid-updates/main Sources
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid-updates/restricted Sources
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid-updates/universe Packages
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid-updates/universe Sources
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid-updates/multiverse Packages
      407  Proxy Authentication Required
    Err http://gb.archive.ubuntu.com lucid-updates/multiverse Sources
      407  Proxy Authentication Required
    W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/main/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/lucid-security/main/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/lucid-security/restricted/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/lucid-security/main/source/Sources.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/lucid-security/restricted/source/Sources.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/lucid-security/universe/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/lucid-security/universe/source/Sources.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/lucid-security/multiverse/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/lucid-security/multiverse/source/Sources.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid/main/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid/restricted/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid/main/source/Sources.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid/restricted/source/Sources.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid/universe/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid/universe/source/Sources.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid/multiverse/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid/multiverse/source/Sources.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid-updates/main/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid-updates/restricted/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid-updates/main/source/Sources.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid-updates/restricted/source/Sources.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid-updates/universe/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid-updates/universe/source/Sources.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid-updates/multiverse/binary-i386/Packages.gz  407  Proxy Authentication Required
    
    W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/lucid-updates/multiverse/source/Sources.gz  407  Proxy Authentication Required
    
    E: Some index files failed to download, they have been ignored, or old ones used instead.
    I have tried adding userassword@proxyort into apt.conf but still didn't help.

    I would really like this to work but it wont due to needing my user and password to authenticate with the proxy.

    Thanks

  2. #2


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,033 Times in 813 Posts
    Rep Power
    341
    Sounds similar to this problem:


    Debian server through proxy

  3. #3
    januttall's Avatar
    Join Date
    Sep 2010
    Posts
    227
    Thank Post
    17
    Thanked 28 Times in 28 Posts
    Blog Entries
    1
    Rep Power
    14
    set the proxy for apt-get do the following go to /etc/apt/apt.conf (edit with what ever you like i prefer nano)
    change the file to read [Acquire::http::Proxy "http://YOUR-PROXY:8080";] (without the square brackets)
    restart the machine.
    FYI if you have more thn one working interface it will get stuck choseing a gateway so only set the gateway one one interface or set all but the interface on DHCP to not have a Default gateway.
    Last edited by januttall; 27th February 2012 at 11:25 AM. Reason: made it make scence:P

  4. #4
    LJay's Avatar
    Join Date
    Feb 2012
    Location
    United Kingdom
    Posts
    12
    Thank Post
    3
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Hi thanks for the reply, but my apt.conf already has my proxy , its the authentication which i need to enable like http://usernameassword@proxyort but that doesnt seem to work either

  5. #5
    LJay's Avatar
    Join Date
    Feb 2012
    Location
    United Kingdom
    Posts
    12
    Thank Post
    3
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I think i will just give up and not use my work linux for much and just use the one i have at home

  6. #6


    tom_newton's Avatar
    Join Date
    Sep 2006
    Location
    Leeds
    Posts
    4,507
    Thank Post
    871
    Thanked 862 Times in 681 Posts
    Rep Power
    199
    I am guessing your proxy is using ntlm auth rather than proxy-auth, or that the sites you are going to are blocked. If you are your proxy administrator, how about setting those sites as "allow" and "do not auth for", if thats possible.

  7. #7
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    339
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0
    export http_proxy=http://usernameassword@proxyserver.netort/
    export ftp_proxy=http://usernameassword@proxyserver.netport/

    Wondered if this works for you

  8. #8

    Join Date
    Jul 2012
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    i have exactly same problem, looking for a solution

    i'm using ubuntu 10.04 and these are what i tried so far.

    i added my proxy adress, port, user and password by using gui (System->Preferences->Network Proxy->Manual)

    i tried to export http_proxy, https_proxy on terminal by using correct proxy definition.

    Also i had firefox, google chrome and opera.
    interestingly, just firefox can accces internet if i configure to use manual settings in firefox.

    All the way, the result always 407.

    Any help would be appreciated

  9. #9

    Join Date
    Jul 2012
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    ok. solved.

    install ntlmaps, configure it and use 127.0.0.1:5865 as proxy. that's all

  10. #10

    jinnantonnixx's Avatar
    Join Date
    Mar 2011
    Location
    In the Calamatorium.
    Posts
    2,086
    Thank Post
    123
    Thanked 534 Times in 357 Posts
    Blog Entries
    2
    Rep Power
    336
    Quote Originally Posted by januttall View Post
    set the proxy for apt-get do the following go to /etc/apt/apt.conf (edit with what ever you like i prefer nano)
    change the file to read [Acquire::http::Proxy "http://YOUR-PROXY:8080";] (without the square brackets)
    .
    This is the best approach.

    A common error is to omit a domain if your proxy expects one.

    If your proxy expects a domain, you should include it like this:

    Acquire::http::Proxy "http://your_domain\\your_user@your_proxy:8080";

    You should have two backslashes as the backslash is an 'escape' character.
    Last edited by jinnantonnixx; 18th July 2012 at 09:49 PM.



SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 5
    Last Post: 20th October 2010, 12:30 PM
  2. [Fog] Fog on ubuntu 10.04 issues installing cannot check apache.
    By microtest in forum O/S Deployment
    Replies: 2
    Last Post: 3rd August 2010, 10:20 AM
  3. [Ubuntu] Ubuntu 10.04 LTS is here!
    By mikeglover in forum *nix
    Replies: 29
    Last Post: 18th May 2010, 07:49 PM
  4. [Ubuntu] Ubuntu 10.04 Hit By Major Bug On Release Day [?]
    By DaveP in forum *nix
    Replies: 1
    Last Post: 29th April 2010, 10:00 PM
  5. [Ubuntu] Dansguardian 2.10.0.3 and Ubuntu 9.04
    By voodoochile in forum *nix
    Replies: 11
    Last Post: 5th June 2009, 02:51 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •