Has anyone got amavis-new running with Sophos? i can get it working with Clam-AV no problems but having installed sophos (version 7.5) on the linux box (buntu 11.10) i cant work out how to config the 15-av_scanners file
it feels like im missing something to it inbetween... the examples in the file produce errors such as


Jan 26 18:19:14 Edge2MTA amavis[2590]: (02590-01) (!)Sophie: Can't connect to UNIX socket /var/run/sophie: No such file or directory, retrying (2)
Jan 26 18:19:20 Edge2MTA amavis[2590]: (02590-01) (!)Sophie av-scanner FAILED: run_av error: Too many retries to talk to /var/run/sophie (Can't connect to UNIX socket /var/run/sophie: No such file or directory) at (eval 105) line 375.\n

or

Jan 26 18:54:12 Edge2MTA amavis[1692]: (01692-01) (!)Sophos-SSSP: Can't connect to UNIX socket /var/run/savdi/sssp.sock: No such file or directory, retrying (2)
Jan 26 18:54:18 Edge2MTA amavis[1692]: (01692-01) (!)Sophos-SSSP av-scanner FAILED: run_av error: Too many retries to talk to /var/run/savdi/sssp.sock (Can't connect to UNIX socket /var/run/savdi/sssp.sock: No such file or directory) at (eval 105) line 375.\n
Jan 26 18:54:18 Edge2MTA amavis[1692]: (01692-01) (!!)WARN: all primary virus scanners failed, considering backups

config is like
['Sophos-SSSP',
\&ask_daemon, ["{}", 'sssp:/var/run/savdi/sssp.sock'],
# or: ["{}", 'sssp:[127.0.0.1]:4010'],
qr/^DONE OK\b/m, qr/^VIRUS\b/m, qr/^VIRUS\s*(\S*)/m ],

or

['Sophie',
\&ask_daemon, ["{}/\n", '/var/run/sophie'],
qr/(?x)^ 0+ ( : | [\000\r\n]* $)/m, qr/(?x)^ 1 ( : | [\000\r\n]* $)/m,
qr/(?x)^ [-+]? \d+ : (.*?) [\000\r\n]* $/m ],

Thanks Gordon.