+ Post New Thread
Results 1 to 9 of 9
*nix Thread, Karoshi iso problem in Technical; hi all i have recently setup a workstation to run karoshi server 7.03 i have added the distribution module so ...
  1. #1

    Join Date
    Oct 2011
    Location
    england
    Posts
    4
    Thank Post
    11
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Karoshi iso problem

    hi all

    i have recently setup a workstation to run karoshi server 7.03
    i have added the distribution module so i can cast images to workstations...and here is the problem..i have placed the iso in /home/distributions/linux_distro and when trying to upload through the Karoshi management /client/linux client/upload iso..then i hit a problem..i browse to the iso click open then submit..i get the error that "The connection was reset".. the computer is not connected to the internet although i have no problem accessing the WEB management page...i hope that this is enough information for you...please help

  2. #2

    Dos_Box's Avatar
    Join Date
    Jun 2005
    Location
    Preston, Lancashire
    Posts
    9,057
    Thank Post
    625
    Thanked 2,215 Times in 1,016 Posts
    Blog Entries
    23
    Rep Power
    635
    Moving to *nix forum.

  3. #3

    Dos_Box's Avatar
    Join Date
    Jun 2005
    Location
    Preston, Lancashire
    Posts
    9,057
    Thank Post
    625
    Thanked 2,215 Times in 1,016 Posts
    Blog Entries
    23
    Rep Power
    635
    I would suggest you PM linuxgirlie as Karoshi is her baby and she would be able to give you the best advice possible.

  4. Thanks to Dos_Box from:

    tosh61 (26th October 2011)

  5. #4

    Join Date
    Oct 2011
    Location
    england
    Posts
    4
    Thank Post
    11
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    thanks for the advice....

  6. #5
    danielknox's Avatar
    Join Date
    Jun 2009
    Location
    Dover
    Posts
    13
    Thank Post
    0
    Thanked 6 Times in 6 Posts
    Rep Power
    12
    Hi tosh61, couple of questions so I can try replicating the problem

    What ISO are you trying to upload? Is it the karoshi client ISO itself? Are you also accessing the uploader in the web management from the server or a remote machine on the same network. Also does the error appear immediately or after a while.

    I seem to recall a problem with a "the connection reset" message being displayed if a large iso is trying to be uploaded (above 700MB) but this takes a while to appear. If this is the case then I will contact one of the developers and work out how we resolved this bug when we were developing the module.

    Quote Originally Posted by tosh61 View Post
    hi all

    i have recently setup a workstation to run karoshi server 7.03
    i have added the distribution module so i can cast images to workstations...and here is the problem..i have placed the iso in /home/distributions/linux_distro and when trying to upload through the Karoshi management /client/linux client/upload iso..then i hit a problem..i browse to the iso click open then submit..i get the error that "The connection was reset".. the computer is not connected to the internet although i have no problem accessing the WEB management page...i hope that this is enough information for you...please help

  7. #6

    Join Date
    Oct 2011
    Location
    england
    Posts
    4
    Thank Post
    11
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Daniel

    yes you are correct...the image is the karoshi client ..which is 2Gb..the error message takes approx 2 mins to popup...i have now added the client in var/www/html also...just to ensure that i have the correct permissions to upload..i am using the web management as i have yet to setup any other computers to connect..this is a trial network that we want to appraise and for possible use in schools


    many thanks

    at present i have only the server built ..as i wanted to try and cast the image rather than build with the dvd...

  8. #7
    danielknox's Avatar
    Join Date
    Jun 2009
    Location
    Dover
    Posts
    13
    Thank Post
    0
    Thanked 6 Times in 6 Posts
    Rep Power
    12
    Thanks tosh. This error does sound pretty familiar so we are planning to test it tomorrow with the linux client distro. If it is the problem we are thinking (http maxing out how much data we can send nicely) then we will create a patch to fix this problem. Probably something using ftp.

  9. #8
    danielknox's Avatar
    Join Date
    Jun 2009
    Location
    Dover
    Posts
    13
    Thank Post
    0
    Thanked 6 Times in 6 Posts
    Rep Power
    12
    Just got give an update on this.

    We are creating in the next day a new way of handling isos for this part of the system, as http seems to be a bit temperamental. What we are doing is creating an area within the itadmin samba share. Files can be place here via samba, scp etc. and then from the web management you will be able to see all the available isos from a dropdown menu within the distribution module. Selecting an ISO will prepare it for deployment.

    The nice thing about doing it this way will allow us later on to extend functionality to multiple cd images. So you will be able to deploy systems with different software setups (windows & linux) to different computers rather than being restricted to using one image only. Our eta for the new share and dropdown method is about 1 to 2 days to get it coded and tested.

  10. #9
    danielknox's Avatar
    Join Date
    Jun 2009
    Location
    Dover
    Posts
    13
    Thank Post
    0
    Thanked 6 Times in 6 Posts
    Rep Power
    12
    The module has now been updated, providing a location in itadminshare to upload isos to. They are then accessible from the web management for the distribution module.

SHARE:
+ Post New Thread

Similar Threads

  1. [Karoshi] Karoshi Linux 7 - Released!
    By linuxgirlie in forum *nix
    Replies: 8
    Last Post: 20th October 2010, 04:15 PM
  2. iso problems
    By richard in forum Learning Network Manager
    Replies: 28
    Last Post: 11th January 2010, 11:39 AM
  3. Intermitent problems with logging on
    By alexknight in forum Wireless Networks
    Replies: 27
    Last Post: 22nd August 2005, 04:01 AM
  4. Karoshi
    By linuxgirlie in forum *nix
    Replies: 4
    Last Post: 6th July 2005, 10:16 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •