+ Post New Thread
Results 1 to 2 of 2
*nix Thread, Mounting ISCSI at boot in Technical; The server (RHEL6.1) has iscsi initiator started on boot. chkconfig iscsi on The iscsi disks are used for backup, the ...
  1. #1


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339

    Mounting ISCSI at boot

    The server (RHEL6.1) has iscsi initiator started on boot.
    chkconfig iscsi on
    The iscsi disks are used for backup, the other disks are FC SAN.


    on reboot I see:

    fsck.ext4 Unable to resolve 'UUID=d24feb8b-9352-42d2-9efa-db5d52f5bc8e'
    fsck.ext4 Unable to resolve 'UUID=f1299fae-f2b5-44cc-8f56-067fb7f9216f'
    fsck.ext4 Unable to resolve 'UUID=c9279c61-43a4-463d-bf1b-3d51878645e6'


    Then I'm dropped into a recovery shell.

    In recovery /etc/init.d/iscsi says:
    iscsi is stopped.

    Which is no surprise because the network is stopped.



    my fstab:
    the last 3 entries in the fstab are iscsi drives (for backup)
    /dev/mapper/vg_student-lv_root / ext4 defaults 1 1
    UUID=fa6228af-9e2b-4b8e-901c-b5c003c07572 /boot ext4 defaults 1 2
    /dev/mapper/vg_student-lv_swap swap swap defaults 0 0
    /dev/VolGroup01/CURRIC /home/CURRIC ext4 defaults,usrquota,grpquota,acl,user_xattr 1 2
    /dev/VolGroup02/T_Drive /shared ext4 defaults,usrquota,grpquota,acl,user_xattr 1 2
    tmpfs /dev/shm tmpfs defaults 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    sysfs /sys sysfs defaults 0 0
    proc /proc proc defaults 0 0
    #172.16.0.81:NFS_Backup /backup nfs timeo=14,intr
    UUID=d24feb8b-9352-42d2-9efa-db5d52f5bc8e /backup ext4 defaults 1 2
    UUID=f1299fae-f2b5-44cc-8f56-067fb7f9216f /backup-SHARED ext4 defaults 1 2
    UUID=c9279c61-43a4-463d-bf1b-3d51878645e6 /backup-SIMS ext4 defaults 1 2
    I can comment out the iscsi and boot normally, then uncomment and mount -a works.

    How do I fix this? Do I need to get the network/iscsi turned on faster

  2. #2


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    fixed.
    fstab needed the _netdev option:

    UUID=d24feb8b-9352-42d2-9efa-db5d52f5bc8e /backup ext4 defaults,_netdev 1 2

    a schoolboy error

SHARE:
+ Post New Thread

Similar Threads

  1. [Debian] NFS drive not being mounted at boot
    By computer_expert in forum *nix
    Replies: 3
    Last Post: 15th June 2011, 03:04 PM
  2. [MDT] Logging in at PXE Boot
    By Chuckster in forum O/S Deployment
    Replies: 2
    Last Post: 10th February 2011, 10:28 PM
  3. Virtualbox VM install causes checkdisk to run at boot
    By computer_expert in forum Windows
    Replies: 0
    Last Post: 17th August 2010, 05:37 PM
  4. Method to check what's happening at boot?
    By reggiep in forum Windows
    Replies: 3
    Last Post: 22nd January 2010, 03:07 PM
  5. Parental Consent to use the internet at school
    By mark in forum School ICT Policies
    Replies: 20
    Last Post: 24th June 2005, 11:18 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •