+ Post New Thread
Results 1 to 13 of 13
*nix Thread, Linux Mint 11 "Device not ready" in Technical; Hey guys, I recently bought a Lenovo ThinkPad Edge E520 which came with Windows 7 Home, I soon got sick ...
  1. #1

    Join Date
    Jul 2010
    Location
    Melbourne, Australia
    Posts
    32
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Linux Mint 11 "Device not ready"

    Hey guys,

    I recently bought a Lenovo ThinkPad Edge E520 which came with Windows 7 Home, I soon got sick of that and wanted to try my luck with Linux. I have previously played around with Ubuntu, Debian and attempted Arch Linux but always got sick of it after a week and reformatted.

    I downloaded the Linux Mint 11 64bit DVD .iso and installed it without a problem, but I can't connect to my wireless network. From what I can tell, my wireless NIC is being picked up and has the correct drivers installed and "sudo rfkill list" shows that it is not blocked. I have tried almost every solution I could find online with no luck and I have also tried multiple clean installs, the only thing I haven't done is update the kernel because I am absolutely clueless on that...

    Can someone help me out here? I am more than happy to supply you with full details of whatever you need as long as you can list the command for me.

    The offending NIC is "Broadcom Corporation Device 0537" and I have tried the STA drivers and the b43 fwcutter firmware.

    Thanks

  2. #2

    nephilim's Avatar
    Join Date
    Nov 2008
    Location
    Dunstable
    Posts
    12,026
    Thank Post
    1,631
    Thanked 1,920 Times in 1,419 Posts
    Blog Entries
    2
    Rep Power
    434
    Broadcom NICs and Atheros NICs are not 100% reliable on Linux (though they are 95% reliable) - This is my own experience btw.
    Intel NICs are better supported.

    Now the question is, when the device is hard wired in, are you able to go onto the package manager and look for wifi adaptor programs? They may be able to help.

  3. #3

    nephilim's Avatar
    Join Date
    Nov 2008
    Location
    Dunstable
    Posts
    12,026
    Thank Post
    1,631
    Thanked 1,920 Times in 1,419 Posts
    Blog Entries
    2
    Rep Power
    434
    Also have you run the update manager? That might be able to get all of the relevant updates you need to get it going.

  4. #4

    Join Date
    Jul 2010
    Location
    Melbourne, Australia
    Posts
    32
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I will look for some WiFi programs now and yes I have ran multiple updates and have activated the Broadcom STA drivers that the "Additional drivers" program told me to do.

  5. #5

    Join Date
    Jul 2010
    Location
    Melbourne, Australia
    Posts
    32
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Nope, no WiFi programs.

  6. #6

    Join Date
    Jul 2009
    Posts
    564
    Thank Post
    46
    Thanked 106 Times in 91 Posts
    Rep Power
    68
    my dell laptop (with a broadcom wireless card) requires the wireless to enabled in windows before it will start working under Linux (Debian/Ubuntu/Linux Mint Debian Edition are the distros I've tried). Have you tried disabling and enabling the Wifi in Windows then rebooting into Linux Mint?

  7. #7

    Join Date
    Jul 2010
    Location
    Melbourne, Australia
    Posts
    32
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Not dual booting, so I don't think it matters? But that sounds awfully strange...
    If I tap the hardware FN wireless key it goes from "Wireless disabled" and flashes to "disconnected" or something or other for a second and seems like it's working and THEN to "Device not ready"

    I really appreciate the help guys, as a I.T trainee I feel like I should have experience in more than one OS.

  8. #8

    Join Date
    Jul 2009
    Posts
    564
    Thank Post
    46
    Thanked 106 Times in 91 Posts
    Rep Power
    68
    Quote Originally Posted by Bocaj1994 View Post
    But that sounds awfully strange...
    It does. When trying to get the wireless card working on my laptop for the first time, I seem to remember a post that basically said the firmware (or something like that) is loaded onto the wireless card before being enabled and allowing the OS to use it.

    If you run 'sudo lshw' from the terminal, does it give you a model number for the wireless card (eg. Broadcom Corporation BCM4312 802.11b/g) ?

  9. #9

    Join Date
    Jul 2010
    Location
    Melbourne, Australia
    Posts
    32
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    This? A quote doesn't count as 10char?!

    *-network
    description: Wireless interface
    product: Broadcom Corporation
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:09:00.0
    logical name: eth1
    version: 01
    serial: ac:81:12:3e:1d:ca
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=wl0 driverversion=5.100.82.38 latency=0 multicast=yes wireless=IEEE 802.11abgn
    resources: irq:19 memory:e1d00000-e1d03fff

  10. #10

    Join Date
    Jul 2009
    Posts
    564
    Thank Post
    46
    Thanked 106 Times in 91 Posts
    Rep Power
    68
    If you go into restricted drivers, have you disabled the b43 driver and left the broadcom one enabled?

    You may need to reboot the machine for the changes to take effect. also when you enable the STA driver, you need to be connected to the internet as some additional files will be downloaded.

    (apologies for the slow reply, my net connection has been unreliable over the weekend)

  11. #11

    jinnantonnixx's Avatar
    Join Date
    Mar 2011
    Location
    In the Calamatorium.
    Posts
    1,983
    Thank Post
    113
    Thanked 504 Times in 339 Posts
    Blog Entries
    2
    Rep Power
    286
    The wireless hardware switch is set to 'working' I trust? (We've all done this!)

    Of all the things I find with Linux, wireless is something that just never gives me problems. My main machine is a HP laptop with Atheros, the other is a Pavillion with Broadcom; both work faultlessly with Ubuntu.

    Not much comfort to you, of course, but I'd try a live CD (say, Ubuntu Natty) and just see if that sees the wireless.

  12. #12

    Join Date
    Jul 2010
    Location
    Melbourne, Australia
    Posts
    32
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for the help guys and yes I tried both of them multiple times, I actually swapped to Ubuntu to see if the problem was there aswell and the answer was sadly yes.
    I posted on acouple of other forums aswell but for Ubuntu.

    Apparently if the acer-wireless is detected and soft blocked even if you DON'T have an acer module then the wireless is blocked on all modules.

    Solution here and my thread.


    After fixing it in Ubuntu I promptly switched back to Linux Mint 11 *I like it better* applied the fix and bam, it worked perfect.

  13. #13

    Join Date
    Jul 2009
    Posts
    564
    Thank Post
    46
    Thanked 106 Times in 91 Posts
    Rep Power
    68
    glad to hear you eventually got it working

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 11
    Last Post: 1st June 2011, 11:05 AM
  2. Spiceworks won't scan. "No devices ready for network health check yet"?
    By Number6 in forum Network and Classroom Management
    Replies: 0
    Last Post: 24th November 2010, 08:42 AM
  3. "CC3 ready" machines - backup partition?
    By Nozza in forum Network and Classroom Management
    Replies: 3
    Last Post: 3rd July 2009, 03:30 PM
  4. "USB Device not recognized" on Windows XP
    By mrcrazy04 in forum Hardware
    Replies: 6
    Last Post: 24th February 2008, 10:06 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •