Site Maintenance this evening The site will be offline for hosting changes. Time TBC

+ Post New Thread
Results 1 to 12 of 12
*nix Thread, 407 proxy authentication in Technical; Hi, im hoping someone can help, ive been placed in charge of the web filtering, but am getting the accounts ...
  1. #1

    Join Date
    Feb 2011
    Posts
    7
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    407 proxy authentication

    Hi, im hoping someone can help, ive been placed in charge of the web filtering, but am getting the accounts department trying to access an application which requires internet. They keep getting a logon failure.

    The software, winbacs, have sent me logs of the problem:

    HTTP: 407 Proxy Authentication Required
    X-Squid-Error: ERR_CACHE_ACCESS_DENIED 0
    X-Cache: MISS from ClientSiteProxy
    X-Cache-Lookup: NONE from ClientSiteProxy:3128
    Connection: close
    Content-Length: 1364
    Content-Type: text/html
    Date: Wed, 02 Feb 2011 15:00:14 GMT
    Expires: Wed, 02 Feb 2011 15:00:14 GMT
    Proxy-Authenticate: NTLM
    Server: squid/2.7.STABLE4
    Via: 1.0 ClientSiteProxy:3128 (squid/2.7.STABLE4)
    ERROR: Cache Access Denied
    ------------

    I am using messagelabs as the web filtering tool and using clientsiteproxy. I think I need to mage some changes to the squid file but am unsure of how to go about this, any help will be appreciated.

  2. #2

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,808
    Thank Post
    272
    Thanked 1,135 Times in 1,031 Posts
    Rep Power
    349
    Not used Messagelabs or anything but to bypass ntlm for some sites you will need to add a line like this

    acl bypassNTLM dstdomain "/etc/squid/bypassauth.squid"

    above acl AuthorizedUsers proxy_auth REQUIRED

    then create the file bypassauth.squid inside the folder /etc/squid/ above and add the domains the program needs access to

    restart squid

  3. Thanks to glennda from:

    rashidhussain (3rd February 2011)

  4. #3

    Join Date
    Feb 2011
    Posts
    7
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi, thanks
    Ive got to the part where Ive created a file called bypassauth.squid, but unsure how to add a domain in here.

    The rest of the log shows:

    <H1>ERROR</H1>
    <H2>Cache Access Denied</H2><HR noshade size="1px"><P>
    While trying to retrieve the URL:
    <A HREF="paymentservices.bacs.co.uk:443">paymentservi ces.bacs.co.uk:443</A><P>
    The following error was encountered:<UL><LI><STRONG>Cache Access Denied.</STRONG></UL>

    So I am thinking the domain is paymentservices.bacs.co.uk:443. Can you let me know the format I need to type this into the new blank bypassauth.squid I have created.

  5. #4

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,808
    Thank Post
    272
    Thanked 1,135 Times in 1,031 Posts
    Rep Power
    349
    Just type in bacs.co.uk and it should then do anything for the whole domain - or just put in paymentservices.bacs.co.uk

    It might need the subdomain aswell as the domain

    Or put in *.bacs.co.uk
    Last edited by glennda; 3rd February 2011 at 09:44 AM.

  6. Thanks to glennda from:

    rashidhussain (3rd February 2011)

  7. #5

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,808
    Thank Post
    272
    Thanked 1,135 Times in 1,031 Posts
    Rep Power
    349
    Did that work?

  8. #6

    Join Date
    Feb 2011
    Posts
    7
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    hi again, im having difficulties since restarting the squidNT service. It would not restart giving me an error service not restarting 107. I then tried to uninstall the program and reinstall, but now getting error 1920 when trying to reinstall the program
    Last edited by rashidhussain; 3rd February 2011 at 01:35 PM.

  9. #7

    Join Date
    Feb 2011
    Posts
    7
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Ok I have managed to restart squid successfully now, so will get back to you once I have tested this. Many thanks for you assistance.

  10. #8

    Join Date
    Feb 2011
    Posts
    7
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    hi, ive just tried the solution, but they are still getting logon failure on the application

  11. #9

    Join Date
    Feb 2011
    Posts
    7
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    hi, is there any other suggestions for resolving this issue, thanks.

  12. #10

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,808
    Thank Post
    272
    Thanked 1,135 Times in 1,031 Posts
    Rep Power
    349
    Sorry for not getting back to you - As far as i know that should have worked. Can you proxy see that site unrestricted? ie there is no upstream filter in place

  13. #11

    Join Date
    Feb 2011
    Posts
    7
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Sorry I am not sure how to go about checking this. I recieved a document from the software company in which they asked me to put the same proxy I had from the internet explorer into their own software and to leave the username and password as blank if the user does not get prompted for this when opening the internet. I tried this, but no luck.

  14. #12

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,808
    Thank Post
    272
    Thanked 1,135 Times in 1,031 Posts
    Rep Power
    349
    I mean can you plug something in on the other side of the proxy and see if you can get to the webaddress.

SHARE:
+ Post New Thread

Similar Threads

  1. TMG 2010 Proxy Authentication
    By localzuk in forum Internet Related/Filtering/Firewall
    Replies: 1
    Last Post: 4th November 2010, 10:37 AM
  2. Replies: 5
    Last Post: 20th October 2010, 11:30 AM
  3. Proxy Authentication Script - HELP!!!!!
    By chrisa in forum Scripts
    Replies: 9
    Last Post: 7th March 2008, 04:34 PM
  4. Replies: 6
    Last Post: 27th February 2007, 08:00 PM
  5. Office 2003 Proxy Authentication Problem
    By Stefletch in forum Office Software
    Replies: 8
    Last Post: 10th February 2007, 10:00 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •