+ Post New Thread
Results 1 to 12 of 12
*nix Thread, Linux Moodle Server Fail in Technical; Hi all, Bare with me as i have limited Linux knowledge We have an Ubuntu 9.0.3 CLI Server installation running ...
  1. #1
    TomTomGo's Avatar
    Join Date
    Jan 2010
    Location
    Preston, Lancashire
    Posts
    32
    Thank Post
    20
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Thumbs down Linux Moodle Server Fail

    Hi all,

    Bare with me as i have limited Linux knowledge

    We have an Ubuntu 9.0.3 CLI Server installation running our school Moodle. As of Monday the server stops hosting the VLE roughly 10 minutes after boot up and we are unable to ping/putty onto the server after this time.
    I can still login to the CLI via our KVM and ping out to other servers.
    I've ran a Memtest and hard disk tests with no failures.
    There is 25gb of storage space free.

    What commands do i need to run to ascertain if the webserver/apache is running? Could this be a firewall issue?

    Your help is appreciated.

  2. #2
    carvjo's Avatar
    Join Date
    Mar 2010
    Location
    Oxford
    Posts
    195
    Thank Post
    12
    Thanked 39 Times in 34 Posts
    Rep Power
    21
    sudo /etc/init.d/apache2 stop
    sudo /etc/init.d/apache2 start
    sudo /etc/init.d/apache2 restart

  3. Thanks to carvjo from:

    TomTomGo (1st December 2010)

  4. #3
    carvjo's Avatar
    Join Date
    Mar 2010
    Location
    Oxford
    Posts
    195
    Thank Post
    12
    Thanked 39 Times in 34 Posts
    Rep Power
    21
    I've installed webmin on the ubuntu server that hosts our moodle - managing the server via a web browser is great..

  5. #4
    TomTomGo's Avatar
    Join Date
    Jan 2010
    Location
    Preston, Lancashire
    Posts
    32
    Thank Post
    20
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by carvjo View Post
    sudo /etc/init.d/apache2 stop
    sudo /etc/init.d/apache2 start
    sudo /etc/init.d/apache2 restart
    Thanks for the prompt reply. Ok apache2 was already running, ive restarted it anyway, but our VLE is still down. What other checks can i do through the CLI?

  6. #5

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,859
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    182
    Run this after startup and watch what happens when it stops responding:

    Code:
    sudo tail -f /var/log/syslog
    Hit Ctrl-C to exit it.

  7. #6
    TomTomGo's Avatar
    Join Date
    Jan 2010
    Location
    Preston, Lancashire
    Posts
    32
    Thank Post
    20
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by powdarrmonkey View Post
    Run this after startup and watch what happens when it stops responding:

    Code:
    sudo tail -f /var/log/syslog
    Hit Ctrl-C to exit it.
    Right it stops responding on the following, which i've typed out(!):

    Date/Time servername /USR/SBIN/CRON[3584]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)
    Last edited by TomTomGo; 1st December 2010 at 11:32 AM. Reason: typo

  8. #7

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,859
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    182
    Reboot and stop cron, to rule that out:

    Code:
    sudo invoke-rc.d cron stop
    and do the same to see if it still stops responding - if so, it was a red herring.

    carvjo: Calling init scripts directly is deprecated, this is the way to do them safely.

  9. Thanks to powdarrmonkey from:

    j17sparky (1st December 2010)

  10. #8
    TomTomGo's Avatar
    Join Date
    Jan 2010
    Location
    Preston, Lancashire
    Posts
    32
    Thank Post
    20
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for your help.

    This time i get:

    Date/Time servername console-kit-daemon[3329]: WARNING: cannot initialize libpolkit, some functionality will not be available

  11. #9

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,859
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    182
    Mmm, it was a red herring then - you really need someone to take a proper look, you can play this game all day...

  12. Thanks to powdarrmonkey from:

    TomTomGo (1st December 2010)

  13. #10
    TomTomGo's Avatar
    Join Date
    Jan 2010
    Location
    Preston, Lancashire
    Posts
    32
    Thank Post
    20
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by powdarrmonkey View Post
    Mmm, it was a red herring then - you really need someone to take a proper look, you can play this game all day...
    Thanks for trying. Anyone aware of a Linux support specialist?

  14. #11
    carvjo's Avatar
    Join Date
    Mar 2010
    Location
    Oxford
    Posts
    195
    Thank Post
    12
    Thanked 39 Times in 34 Posts
    Rep Power
    21
    you could always try to install the policykit

    sudo apt-get install policykit

    but I'm with powdarrmonkey on this - find a local Linux guru to take a looksee..

  15. #12
    carvjo's Avatar
    Join Date
    Mar 2010
    Location
    Oxford
    Posts
    195
    Thank Post
    12
    Thanked 39 Times in 34 Posts
    Rep Power
    21
    place an ad on 'people per hour'

SHARE:
+ Post New Thread

Similar Threads

  1. Pointing to our Linux Moodle Server
    By papakura in forum Windows
    Replies: 7
    Last Post: 10th July 2012, 09:29 AM
  2. A moodle on linux backup script
    By reggiep in forum Virtual Learning Platforms
    Replies: 12
    Last Post: 10th May 2011, 09:38 PM
  3. Fail Over Server
    By ESXi_2008 in forum Windows
    Replies: 4
    Last Post: 2nd February 2010, 03:46 PM
  4. Running moodle and mahara on same linux server - OUCH virtual hosts
    By reggiep in forum Virtual Learning Platforms
    Replies: 1
    Last Post: 1st June 2009, 01:50 PM
  5. Having problems installing moodle on linux server?
    By reggiep in forum Virtual Learning Platforms
    Replies: 9
    Last Post: 18th May 2009, 08:36 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •