+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24
*nix Thread, Endian Firewall in Technical; I cant find an error.log file, iv got an access.log which is basically the screen shot...
  1. #16

    Join Date
    Nov 2008
    Location
    Derby, UK
    Posts
    167
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    I cant find an error.log file, iv got an access.log which is basically the screen shot

  2. #17

    Join Date
    Nov 2008
    Location
    Derby, UK
    Posts
    167
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    Found a samba log and the last few lines are these.

    [2010/11/05 15:15:49, 0] rpc_client/cli_pipe.c:rpc_api_pipe(789)
    Nov 5 15:15:49 firewall winbindd[5046]: rpc_api_pipe: Remote machine FOXWOOD-SCHOOL.FOXGLOVE.LOCAL pipe \NETLOGON fnum 0x8003 returned critical error. Error was NT_STATUS_PIPE_DISCONNECTED
    Nov 5 15:20:49 firewall winbindd[5046]: [2010/11/05 15:20:49, 0] rpc_client/cli_pipe.c:rpc_api_pipe(789)
    Nov 5 15:20:49 firewall winbindd[5046]: rpc_api_pipe: Remote machine FOXWOOD-SCHOOL.FOXGLOVE.LOCAL pipe \NETLOGON fnum 0x8003 returned critical error. Error was NT_STATUS_PIPE_DISCONNECTED
    Nov 5 15:25:49 firewall winbindd[5046]: [2010/11/05 15:25:49, 0] rpc_client/cli_pipe.c:rpc_api_pipe(789)
    Nov 5 15:25:49 firewall winbindd[5046]: rpc_api_pipe: Remote machine FOXWOOD-SCHOOL.FOXGLOVE.LOCAL pipe \NETLOGON fnum 0x8003 returned critical error. Error was NT_STATUS_PIPE_DISCONNECTED
    Nov 5 15:30:49 firewall winbindd[5046]: [2010/11/05 15:30:49, 0] rpc_client/cli_pipe.c:rpc_api_pipe(789)
    Nov 5 15:30:49 firewall winbindd[5046]: rpc_api_pipe: Remote machine FOXWOOD-SCHOOL.FOXGLOVE.LOCAL pipe \NETLOGON fnum 0x8003 returned critical error. Error was NT_STATUS_PIPE_DISCONNECTED
    Nov 5 15:35:49 firewall winbindd[5046]: [2010/11/05 15:35:49, 0] rpc_client/cli_pipe.c:rpc_api_pipe(789)
    Nov 5 15:35:49 firewall winbindd[5046]: rpc_api_pipe: Remote machine FOXWOOD-SCHOOL.FOXGLOVE.LOCAL pipe \NETLOGON fnum 0x8003 returned critical error. Error was NT_STATUS_PIPE_DISCONNECTED
    Nov 5 15:40:49 firewall winbindd[5046]: [2010/11/05 15:40:49, 0] rpc_client/cli_pipe.c:rpc_api_pipe(789)
    Nov 5 15:40:49 firewall winbindd[5046]: rpc_api_pipe: Remote machine FOXWOOD-SCHOOL.FOXGLOVE.LOCAL pipe \NETLOGON fnum 0x8003 returned critical error. Error was NT_STATUS_PIPE_DISCONNECTED

  3. #18

    Join Date
    Nov 2008
    Location
    Derby, UK
    Posts
    167
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    anyone help me with this still havig problems with it

  4. #19

    Join Date
    May 2009
    Posts
    241
    Thank Post
    32
    Thanked 10 Times in 10 Posts
    Rep Power
    12
    I have found your answer after hours of searching, Hope this works (let me know)

    See Mantis Bug Page: 0002839: Proxy Auth and AD 2008R2 fail - Mantis

    Problem:
    Endian HTTP Proxy doesn't work with Windows Server 2008 R2 Active Directory
    Log errors on /var/log/samba/samba.log, like this:
    winbindd[7024]: rpc_api_pipe: Remote machine domain.local pipe \NETLOGON fnum 0x8003 returned critical error. Error was NT_STATUS_PIPE_DISCONNECTED

    What cause it:
    samba 3.2 is incompatible with ADS Windows 2008 R2

    How to fix it:
    Upgrade to samba 3.5.4.

    1- Download Samba 3.5.4 packages from: HERE (Sorry its Megaupload) tell me if you need it uploading somewhere else (Squeeky)
    2-Copy the file EFW2.4_Samba_Fix.tgz to your firewall, the easiest way is with WinSCP
    3-Unzip the file, either with WinSCP File->Custom Commands->Untar or using the command tar -xvf EFW2.4_Samba_Fix.tgz
    4-Go to the directory called samba: cd samba
    5-Run the installer: ./install.sh It should install all the packages involved correctly.
    6-Reboot

    Warning
    It works as intented in my test machine, that's all. I only tested it with Windows Server 2008 R2, I haven't tested on any other AD server.
    Use this patch at your own risk. I'm not responsible of any use or problem with these rpms (either good or bad).
    If you want to see the sources, ask for them. There are a lot, though.


    Source: ENDIAN Firewall - [EFW 2.4 Community] Active Directory 2008 R2 Bugfix
    Last edited by squeeky; 9th December 2010 at 05:03 PM.

  5. #20


    tom_newton's Avatar
    Join Date
    Sep 2006
    Location
    Leeds
    Posts
    4,473
    Thank Post
    866
    Thanked 848 Times in 670 Posts
    Rep Power
    196
    Do I win a prize for suggesting this was the case earlier?

  6. #21

    Join Date
    May 2009
    Posts
    241
    Thank Post
    32
    Thanked 10 Times in 10 Posts
    Rep Power
    12
    no, but you would have done if you had actuary found the answer as well

  7. #22

    Join Date
    Nov 2008
    Location
    Derby, UK
    Posts
    167
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    thanx guys i'll give it a go on monday when I get to work on Monday (Not there to day as couldnt get there cause of ice)

  8. #23

    Join Date
    Nov 2008
    Location
    Derby, UK
    Posts
    167
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    Hi Guys,

    worked a charm, thanx guys, specially to Squeeky as he's done all the hard graft

  9. #24

    Join Date
    Dec 2011
    Location
    Riyadh
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    AD WINDOWS

    Quote Originally Posted by Bugs View Post
    Hiya all,

    we have a Endian Firewall and i`m trying to get it to automatically pass the login credentials from the windows 7 clients to the firewall using AD.

    I have successfully joined it to the network, and I can see the computer account on my windows Server, but it refuses to pass the login info, when you try to access a site a log in box appears asking for login and password I fill this in (according to my access policy) and it just bounces back as if its the wrong password.

    I have tried various things with no luck, I even have one of the techy's from one of our partner schools looking into it, and he seems to get the same results on his test box. I`m using version 2.4.

    Cany anybody shed any light on this?
    search this command on endian community it is working fine for me
    chgrp squid /ver/cache/samba/winbindd_privileged/
    chmod 750 /ver/cache/samba/winbindd_privileged/

    USE DNS 1 WINDOWS DOMAIN CONTROLLER ip
    SYSTEM -NETWORK CONFIGURATION DOMAIN NAME -SAME AS YOUR FULL DOMAIN NAME (pdc)


    use putty from windows computer and connect through ssh

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Endian Firewall and Windows Updates
    By Craig_W in forum *nix
    Replies: 7
    Last Post: 6th December 2011, 03:05 PM
  2. firewall
    By kevin_lane in forum Windows Server 2008 R2
    Replies: 3
    Last Post: 27th October 2010, 01:49 PM
  3. Endian Firewall Problems
    By Craig_W in forum *nix
    Replies: 3
    Last Post: 31st July 2007, 02:17 PM
  4. Endian Firewall
    By Craig_W in forum *nix
    Replies: 10
    Last Post: 6th July 2007, 04:23 PM
  5. Endian firewall
    By plexer in forum *nix
    Replies: 16
    Last Post: 2nd October 2006, 10:15 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •