+ Post New Thread
Results 1 to 6 of 6
*nix Thread, squid active directory users in Technical; Hello, Have been trying to get usernames into the access.log as opposed to just ip addresses within dansguardian. I used ...
  1. #1
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0

    squid active directory users

    Hello,

    Have been trying to get usernames into the access.log as opposed to just ip addresses within dansguardian.

    I used to have a cache server that did all this, but wanted to do it on the cheap with my own linux setup.

    I think the cache had some sort of intergration with AD through squid.

    I tried some examples like: PaperCut KB | Configuring Squid on Linux to authenticate with Active Directory

    but have still not got very far. aghhh

    anyone got any help please?

    Thanks

  2. #2
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24
    Do you want DansGuardian to filter based on usernames, or squid itself? I don't think squid can do that, but if you link your linux box to your domain with Samba and Winbind you can enable NTLM authentication on Dansguardian. Then just whack the usernames and their access levels (filter1, filter2, etc) into the "View/Edit filter group assignments" file.

    Some pointers on how to bind your linux box to the domain can be found here, but be aware this guide is for debian etch, not the latest one (I'm told there are differences). I have used this guide on ubuntu karmic with little alteration.

    Feel free to pm me if you have any specific problems, I did this quite recently, so you might ring a bell!!

  3. #3
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0
    Thanks a lot.

    I will look at the link, and prob pm you.

    I have backtrack on the test server i am trying it on, and ubuntu on the production server i am going to eventually run it on.

  4. #4
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24
    Oooh, just googled backtrack (I'd never heard of it). Me likey!! I'm going to play with that

  5. Thanks to Tyiell from:

    duxbuz (28th May 2010)

  6. #5
    duxbuz's Avatar
    Join Date
    Jan 2010
    Posts
    338
    Thank Post
    14
    Thanked 1 Time in 1 Post
    Blog Entries
    1
    Rep Power
    0
    Yes!

    Thanks to your help its working

    sudo wbinfo -g

    is listing groups

    I had to restart winbind.... which i did do previously, but not after i changed the FQDN in smb.conf to the netbios shorter version.

    amongst the other things you had me try.

    Thanks very much

  7. #6
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24
    Glad I could help

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 6
    Last Post: 31st May 2011, 08:05 AM
  2. Cannot create users in Active Directory
    By WithoutMotive in forum Windows
    Replies: 17
    Last Post: 6th February 2009, 11:20 AM
  3. Replies: 1
    Last Post: 7th November 2008, 07:27 PM
  4. Importing new users into Active Directory
    By Mr_M_Cox in forum How do you do....it?
    Replies: 16
    Last Post: 4th November 2008, 11:36 AM
  5. Replies: 2
    Last Post: 28th November 2007, 04:40 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •