+ Post New Thread
Results 1 to 7 of 7
*nix Thread, phpmotion and phpshield in Technical; Hi, I'm trying to install phpmotion on the latest ubuntu release. Apache, ffmpeg etc are all installed. However, when I ...
  1. #1
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20

    phpmotion and phpshield

    Hi, I'm trying to install phpmotion on the latest ubuntu release. Apache, ffmpeg etc are all installed.

    However, when I come to run phpmotion (ie to setup it up), I am met with:

    PHP script /var/www/phpmotion/classes/config.php is protected by phpSHIELD and requires the phpSHIELD loader phpshield.5.3.lin. The phpSHIELD loader has not been installed, or is not installed correctly. Please visit the phpSHIELD php encoder site to download required loader.

    I cannot seem to find phpshield.5.3.lin, only phpshield.5.2.lin

    Is there an issue with one thing being more up to date than the other?

    I am at a loss, and have very limited unix experience. Thank you!

  2. #2
    painejake's Avatar
    Join Date
    Jan 2009
    Location
    Birmingham
    Posts
    100
    Thank Post
    38
    Thanked 8 Times in 8 Posts
    Rep Power
    14
    Not at a ubuntu box so can't test, try sudo apt-get update && apt-cache search phpshield

    Does it bring back any packages you require?

    Edit: Hmm also found http://wiki.phpmotion.com/PHPShield scroll down to PHP 5.2+ maybe that can help you. PHP was update to 5.3 in the Ubuntu repos a few days ago (Or I updated to it a few days ago anyway) I'm guessing PHPMotion\PHPShield doesn't support that yet.

    You could always run PHP 5.2 if you find no solution though.
    Last edited by painejake; 22nd May 2010 at 04:08 PM.

  3. Thanks to painejake from:

    rocknrollstar (22nd May 2010)

  4. #3
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20
    Thanks for your help. How exactly do I downgrade to php5.2? I've no idea how to do it!

    Also, apt-cache search phpshield returns nothing. Version 5.2 located at /usr/lib/php5/20090626+lfs/phpshield.5.2.lin, which is the extension_dir property showing in php.

    Thanks again.
    Last edited by rocknrollstar; 22nd May 2010 at 05:58 PM.

  5. #4
    painejake's Avatar
    Join Date
    Jan 2009
    Location
    Birmingham
    Posts
    100
    Thank Post
    38
    Thanked 8 Times in 8 Posts
    Rep Power
    14
    Try here: Ubuntu Forums - View Single Post - Reverting PHP to 5.2 in Lucid 10.04

    Hopefully this will help you out. Just make sure after reverting you PHP install you don't upgrade back up to PHP 5.3.

  6. #5
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20
    Quote Originally Posted by painejake View Post
    Try here: Ubuntu Forums - View Single Post - Reverting PHP to 5.2 in Lucid 10.04

    Hopefully this will help you out. Just make sure after reverting you PHP install you don't upgrade back up to PHP 5.3.
    Thanks painejake. Sorry- one more thing. The ubuntu page says "The big problem is that wildcards don't work, so you will need one such stanza for each PHP package you want to pull from karmic". How do I know or find out the php packages and versions that I need?

    Thank you for your continuing help!

  7. #6
    painejake's Avatar
    Join Date
    Jan 2009
    Location
    Birmingham
    Posts
    100
    Thank Post
    38
    Thanked 8 Times in 8 Posts
    Rep Power
    14
    No worries at all

    Afaik you will need to do the last step for every package you wish to pull from karmic repo. Otherwise it will just pull the packages for the lucid repo instead. So any modules for PHP will need that done too so you aren't trying to run some php 5.3 with the base php 5.2

    It could always be best to wait for php motion to update to php 5.3 though, unless it wont be for a long time or needs to be setup asap!
    Last edited by painejake; 23rd May 2010 at 12:12 PM.

  8. #7

    Join Date
    Jun 2010
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Sobre phpmotion

    para ubuntu 64 bits

    descargar (download) http: // www . phpshield . com / loaders /

    descomprimir (unzip) copy to files /usr/lib/php5/20090626/

    luego en :
    "/etc/php5/apache2/php.ini";
    y
    "/etc/php5/cli/php.ini"

    copy :

    extension = "ixed.5.3.lin"
    extension_ts = "ixed.5.3ts.lin"

    sorry not speaking english

SHARE:
+ Post New Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •