The problem I found (and sorry for the slow response- I've left schools in favour of Local Government employment) is that the 1&1 custom repositories either seem to be corrupted or altered with custom packages that simply do not work with later versions. As 1&1 don't support later versions I guess that's not a huge surprise.

The pages https://help.ubuntu.com/community/Repositories/Ubuntu and https://help.ubuntu.com/community/Re...es/CommandLine may be useful to you. It is probably easiest to use an FTP client such as Filezilla to copy and paste standard repositories from a local reference source (but these MUST match the version of the OS in use at the remote site- you need to upgrade incrementally to reach the latest version- although you can upgrade directly between LTS versions), otherwise you can try Googling for a list on the net.

If necessary a local reference copy in VMWare Server/Virtualbox will provide you with the standard list and be a useful test bed before you roll out changes to your "live" server.

As always- backup, backup, backup again and then backup the backup.........