+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 21
*nix Thread, Ubuntu 9.10 Grub Settings in Technical; Ok, this is probably a dead easy one, but it got me a bit With a fresh, default install of ...
  1. #1
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24

    Ubuntu 9.10 Grub Settings

    Ok, this is probably a dead easy one, but it got me a bit

    With a fresh, default install of Ubuntu Karmic I get a copy of Grub 1.97~beta4. It has a load of memtest and kernal choices, I don't need em, but nor do I care that they are there. The problem is, that this install unlike other installs of the same version I have done, doesnt have a countdown before using the default. It just sits there forevermore, until you pick one.

    I've worked out that the old /boot/grub/menu.lst has gone in favour of /etc/default/grub. Below is what the file contains:

    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT="0"
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX="vga=775"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entrys
    #GRUB_DISABLE_LINUX_RECOVERY="true"

    The only difference with this install to all my previous ones that have the coundown is that it is virtual (hosted with VMWare on Windows XP) - would this make any difference? I can't imagine it would but maybe I'm missing something...

    Or of course I might just be being daft with the config file above.

    Thoughts anyone?

    Cheers,

    Paul

  2. #2
    Gerry's Avatar
    Join Date
    Jun 2007
    Location
    North Wales
    Posts
    431
    Thank Post
    60
    Thanked 38 Times in 35 Posts
    Rep Power
    24
    Just checked my dual-boot laptop which works with a 10s countdown. Try changing the line:
    GRUB_TIMEOUT="0"
    to
    GRUB_TIMEOUT=10
    Note: no quotes.

  3. Thanks to Gerry from:

    Tyiell (8th February 2010)

  4. #3
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24
    Hi Gerry,

    Huh, I didn't notice the quotes - that is odd, all my other default installs are the same as yours, can't imagine why it's different...

    However I've changed it as you've suggested and it still just sits there, waiting for user entry...

    So weird...

  5. #4
    Chad's Avatar
    Join Date
    May 2007
    Location
    Elgin
    Posts
    74
    Thank Post
    5
    Thanked 20 Times in 19 Posts
    Rep Power
    18
    Don't you need to run update-grub (or similar, as root) to enforce the new settings after you've made changes?

    The same sort of thing used to catch me out in the lilo days/ you'd edit lilo.conf but then had to run lilo to apply the new settings.

    ETA:
    Ooops, just noticed the file you've pasted above says to do that, so you've likely tried that already. Not sure what the cause is, but I think I've an Ubuntu VM at home I can try and reproduce it on.
    Last edited by Chad; 8th February 2010 at 12:43 PM.

  6. Thanks to Chad from:

    Tyiell (8th February 2010)

  7. #5
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24
    Yeah I was forgetting that to begin with, but I did it these last few times. It says it works ok, but makes no difference unfortunately.

    I'm glad it's not just me that this doesn't make sense to!!!

  8. #6
    Chad's Avatar
    Join Date
    May 2007
    Location
    Elgin
    Posts
    74
    Thank Post
    5
    Thanked 20 Times in 19 Posts
    Rep Power
    18
    I've got 9.10 on my laptop at home, but it's an upgrade from 8.04 (I think) via the intermediate releases so may not be as pure as yours.

    I'll have a play tonight and see what's what. I can't remember ever changing it manually, but I think I hid some of the old kernel options from the Admin GUI - have you tried that route rather than editing the files directly?

  9. #7
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24
    Not tried that - would have to google that to work it out, I've never had to bother doing that before!!!

    I'll take a shot at it this afternoon and keep you posted

  10. #8
    Gerry's Avatar
    Join Date
    Jun 2007
    Location
    North Wales
    Posts
    431
    Thank Post
    60
    Thanked 38 Times in 35 Posts
    Rep Power
    24
    Found this: https://wiki.ubuntu.com/Grub2

    Explains what the settings do, and more.

  11. #9

    Join Date
    Jul 2009
    Posts
    539
    Thank Post
    43
    Thanked 101 Times in 86 Posts
    Rep Power
    67
    Its pretty easy to remove the old kernels from grub2.

    Just uninstall the old kernels (and kernel headers) from synaptic package manager and then run
    Code:
    sudo update-grub
    to remove them.

    You will need to search for 'linux-' in synaptic as when i typed linux-headers nothing was found on my system. Just make sure that you don't remove all the kernels at it will mess up the system (you can find the kernel you're running by typing 'uname -r' at the terminal - do not remove the kernel/kernel headers from the version displayed in the terminal)

  12. Thanks to computer_expert from:

    Tyiell (8th February 2010)

  13. #10
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24
    I've been snowed under so far this afternoon, so it might be tomorrow before I get to play with it. I'll let you know what happens when I do it - don't think I'm ignoring your help

  14. Thanks to Tyiell from:

    Chad (8th February 2010)

  15. #11
    Chad's Avatar
    Join Date
    May 2007
    Location
    Elgin
    Posts
    74
    Thank Post
    5
    Thanked 20 Times in 19 Posts
    Rep Power
    18
    Good luck! I'm interested in seeing what the fix is in case it ever happens to me :-)

  16. #12
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24
    Hi,

    Right, well I deleted the extra linux-headers as suggested by computer_expert, but I still have the recovery mode and memory test options, so I can't seem to get it down to a single choice. So unfortunately the problem remains. Looking through the link to Grub 2 posted by Gerry, I have made my /etc/default/grub file look identical to theirs and it still doesn't work!!!

    Interestingly it claims to be grub2, is configured the way grub2 is supposed to be configured (no /boot/grub/menu.lst etc) BUT the version is 1.97~beta4. Which to me implies that its a beta version of grub1??

    Waaay confused now, I'm totally out of ideas...

  17. #13
    Gerry's Avatar
    Join Date
    Jun 2007
    Location
    North Wales
    Posts
    431
    Thank Post
    60
    Thanked 38 Times in 35 Posts
    Rep Power
    24
    How about trying a GRUB GUI editor?
    ubuntu grub gui - Google Search

  18. #14

    Join Date
    Jul 2009
    Posts
    539
    Thank Post
    43
    Thanked 101 Times in 86 Posts
    Rep Power
    67
    Quote Originally Posted by Tyiell View Post
    Interestingly it claims to be grub2, is configured the way grub2 is supposed to be configured (no /boot/grub/menu.lst etc) BUT the version is 1.97~beta4. Which to me implies that its a beta version of grub1??
    That is Grub2. Grub 1 (legacy) has a version number of 0.97.

    The section here, named 'Removing Entries from Grub 2' should help you remove the memtest/recovery options from the menu. Its about halfway down the page.

  19. #15
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24
    I could cry....

    I have now removed all entries to grub except the one I want and what does it do??? It just flippin sits there waiting for me to select option 1 of 1!!!!

    Such a simple program is causing way too much trouble. And the thing is, it doesn't matter that much, it's just hugely irritating

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Ubuntu Firewall Settings
    By lt_goldman in forum Internet Related/Filtering/Firewall
    Replies: 0
    Last Post: 10th November 2009, 04:36 PM
  2. [Ubuntu] GRUB ERROR 16
    By llawwehttam in forum *nix
    Replies: 5
    Last Post: 24th February 2009, 01:02 PM
  3. grub error 16???
    By llawwehttam in forum Hardware
    Replies: 1
    Last Post: 21st February 2009, 01:29 PM
  4. Meetup / Grub
    By GrumbleDook in forum General Chat
    Replies: 2
    Last Post: 22nd July 2008, 01:10 PM
  5. Grub In Ubuntu
    By FN-GM in forum *nix
    Replies: 4
    Last Post: 14th October 2007, 05:53 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •