+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21
*nix Thread, Ubuntu 9.10 Grub Settings in Technical; Is your #GRUB_HIDDEN_TIMEOUT=0 line still commented? Removing the # should make grub boot the default without displaying the menu. You ...
  1. #16
    Chad's Avatar
    Join Date
    May 2007
    Location
    Elgin
    Posts
    74
    Thank Post
    5
    Thanked 20 Times in 19 Posts
    Rep Power
    18
    Is your

    #GRUB_HIDDEN_TIMEOUT=0

    line still commented? Removing the # should make grub boot the default without displaying the menu. You can still specify a timeout value which will enable you to press ESC to display the menu.

  2. #17
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,966
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46
    here's the header in mine (I just set the timeout to '0'):

    Code:
    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by /usr/sbin/grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #
    
    ### BEGIN /etc/grub.d/00_header ###
    if [ -s /boot/grub/grubenv ]; then
      have_grubenv=true
      load_env
    fi
    set default="0"
    if [ ${prev_saved_entry} ]; then
      saved_entry=${prev_saved_entry}
      save_env saved_entry
      prev_saved_entry=
      save_env prev_saved_entry
    fi
    insmod ext2
    set root=(hd0,5)
    search --no-floppy --fs-uuid --set c8505d7f-fbef-4ad9-b49b-1959927e9afc
    if loadfont /usr/share/grub/unicode.pf2 ; then
      set gfxmode=640x480
      insmod gfxterm
      insmod vbe
      if terminal_output gfxterm ; then true ; else
        # For backward compatibility with versions of terminal.mod that don't
        # understand terminal_output
        terminal gfxterm
      fi
    fi
    if [ ${recordfail} = 1 ]; then
      set timeout=-1
    else
      set timeout=0
    fi
    ### END /etc/grub.d/00_header ###

  3. Thanks to mark from:

    Tyiell (11th February 2010)

  4. #18
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24
    Quote Originally Posted by Chad View Post
    Is your

    #GRUB_HIDDEN_TIMEOUT=0

    line still commented? Removing the # should make grub boot the default without displaying the menu. You can still specify a timeout value which will enable you to press ESC to display the menu.
    It was indeed still commented. I uncommented as you suggested, but it hasn't made any difference...

    I run update-grub after every change and it always says it works - although since all the suggestions you have all come up with for me and all the ones I have thought up on my own have made little difference I started to wonder if it was actually updating grub.cfg at all! But I changed something, updated and checked the config file and it had made the change! It just doesn't actually make any difference!!

    I altered the file to match Mark's posting, but the same stroy applies I'm afraid - it was identical except for the timeout value - when I change it in /etc/default/grub and update, or when I changed it in the grub.cfg directley as you suggested, it does the same thing: totally ignore it!!

    I really have nothing left to give on this one, I can't think of anything that hasn't been changed, changed back, commented, and changed again!!

  5. #19
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,966
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46
    What about trying SuperGrub

  6. #20
    Tyiell's Avatar
    Join Date
    Apr 2009
    Location
    Like everyone in IT - I'm omnipresent...
    Posts
    373
    Thank Post
    147
    Thanked 67 Times in 44 Posts
    Rep Power
    24
    For those who care...

    I have fixed this problem. Well, for "fixed" read "cheated". Basically I think that the reason it wasn't booting was some sort of error wasmaking ${recordfail} true, and therefore throwing out the timeout feature as per the if statement in /boot/grub/grub.cfg shown below:

    Code:
    if [ ${recordfail} = 1 ]; then
      set timeout=-1
    else
      set timeout=4
    fi
    So by commenting out the if statement, and just leaving the timeout statement (as below) it works a treat.

    Code:
    #if [ ${recordfail} = 1 ]; then
    #  set timeout=-1
    #else
      set timeout=4
    #fi
    Of course I'm sure there's an excellent reason grub check this and now it doesn't I've no doubt its going to come round and bite me in the ass one of these days. But hey, that's a problem for another day

    Thanks to those who have helped out - and if anyone does have any ideas as to what the error that actually causes this to happen is, please shout!!!

  7. Thanks to Tyiell from:

    mark (16th February 2010)

  8. #21
    Gerry's Avatar
    Join Date
    Jun 2007
    Location
    North Wales
    Posts
    431
    Thank Post
    60
    Thanked 38 Times in 35 Posts
    Rep Power
    24
    Found this: https://bugs.launchpad.net/ubuntu/+s...b2/+bug/447725
    Near the end of the page there's a link to a possible solution:https://bugs.launchpad.net/ubuntu/+s...rt/+bug/500520

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Ubuntu Firewall Settings
    By lt_goldman in forum Internet Related/Filtering/Firewall
    Replies: 0
    Last Post: 10th November 2009, 04:36 PM
  2. [Ubuntu] GRUB ERROR 16
    By llawwehttam in forum *nix
    Replies: 5
    Last Post: 24th February 2009, 01:02 PM
  3. grub error 16???
    By llawwehttam in forum Hardware
    Replies: 1
    Last Post: 21st February 2009, 01:29 PM
  4. Meetup / Grub
    By GrumbleDook in forum General Chat
    Replies: 2
    Last Post: 22nd July 2008, 01:10 PM
  5. Grub In Ubuntu
    By FN-GM in forum *nix
    Replies: 4
    Last Post: 14th October 2007, 05:53 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •