+ Post New Thread
Results 1 to 9 of 9
*nix Thread, VBoxHeadless in Technical; Run virtual box in headless mode for a couple of vms. No issues, except I have deleted the .iso file ...
  1. #1

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,512
    Thank Post
    1,320
    Thanked 469 Times in 306 Posts
    Blog Entries
    6
    Rep Power
    199

    VBoxHeadless

    Run virtual box in headless mode for a couple of vms. No issues, except I have deleted the .iso file that one was using. Now it wont start as it cant find the .iso

    I cant figure out how to de-register the .iso from the VM at all...

    any tips ?

  2. #2


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,687
    Thank Post
    352
    Thanked 794 Times in 714 Posts
    Rep Power
    346
    Hi, I just looked at one of mine which has an iso included and it has an entry like below in its machine xml file under ~/.Virtualbox/Machines/machinename/machinename.xml

    <DVDDrive passthrough="false">
    <Image uuid="{243c8d10-f87b-4368-a26b-ad99d96b79aa}"/>
    </DVDDrive>
    Might be worth trying to remove it.

  3. Thanks to kmount from:

    RabbieBurns (15th December 2009)

  4. #3
    linescanner's Avatar
    Join Date
    Oct 2006
    Location
    East Anglia
    Posts
    297
    Thank Post
    51
    Thanked 71 Times in 48 Posts
    Rep Power
    28
    Quote Originally Posted by RabbieBurns View Post
    Run virtual box in headless mode for a couple of vms. No issues, except I have deleted the .iso file that one was using. Now it wont start as it cant find the .iso

    I cant figure out how to de-register the .iso from the VM at all...

    any tips ?
    Is there something under VBoxManage modifyvm ?


    Will look at mine in a bit

  5. Thanks to linescanner from:

    RabbieBurns (15th December 2009)

  6. #4

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,512
    Thank Post
    1,320
    Thanked 469 Times in 306 Posts
    Blog Entries
    6
    Rep Power
    199
    Ive royally messed this up now. I tried removing the enrty for the dvd in the virtualbox.xml before I saw kmounts post, which most probably is the correct solution.

    Now I get invalid machine name when trying to start the VM.

    I guess i should have taken a copy before I started messing with it ;p

    Can I create a new VM but use an existing vdi file ?

  7. #5


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,687
    Thank Post
    352
    Thanked 794 Times in 714 Posts
    Rep Power
    346
    Yup, with VBoxManage modifyvm

    VBoxManage createvm -name "Ubuntu 8.04 Server" -register
    VBoxManage modifyvm "Ubuntu 8.04 Server" -memory "256MB" -acpi on -boot1 dvd -nic1 nat
    VBoxManage createvdi -filename "Ubuntu_8_04_Server.vdi" -size 10000 -register
    VBoxManage modifyvm "Ubuntu 8.04 Server" -hda "Ubuntu_8_04_Server.vdi"
    VBoxManage registerimage dvd /home/ubuntu-8.04.1-server-i386.iso
    VBoxManage modifyvm "Ubuntu 8.04 Server" -dvd /home/ubuntu-8.04.1-server-i386.iso
    VBoxHeadless - Running Virtual Machines With VirtualBox 2.0 On A Headless Ubuntu 8.04 Server | HowtoForge - Linux Howtos and Tutorials

    Granted its for an older version and I don't have tools at hand to test atm but should point you in the right direction.

  8. Thanks to kmount from:

    RabbieBurns (15th December 2009)

  9. #6

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,512
    Thank Post
    1,320
    Thanked 469 Times in 306 Posts
    Blog Entries
    6
    Rep Power
    199
    seems theyve changed the syntax a bit for 3.1.0

    what used to be

    Code:
    VBoxManage modifyvm "2008Server" -memory "2048MB" -acpi on -boot1 dvd -nic1 hostif -hostifdev1 eth0
    is now

    Code:
    VBoxManage modifyvm "2008Server" --memory 2048 --acpi on --boot1 dvd --nic1 hostif --hostonlyadapter1 eth0
    for my settings.

    Also, you have to now spefically create a storage controller first:

    Code:
    VBoxManage storagectl "2008Server" --name 2008server --add sata --controller IntelAhci
    and then assign the file

    Code:
    VBoxManage storageattach "2008Server" --storagectl 2008server --port 0 --device 0 --type hdd --medium /root/.VirtualBox/VDI/2008Server.vdi
    Only now can I start the VM

    Code:
    oasis ~ # VBoxHeadless -startvm 2008Server
    VirtualBox Headless Interface 3.1.0
    (C) 2008-2009 Sun Microsystems, Inc.
    All rights reserved.
    
    Listening on port 3389.
    Might be worth me posting up a warning somewhere here not to upgrade to 3.1.0 blindly like I did without reading the changelog as this has changed dramatically.. and Im sure is also the reason my other VMs keep dropping out.

  10. #7

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,512
    Thank Post
    1,320
    Thanked 469 Times in 306 Posts
    Blog Entries
    6
    Rep Power
    199
    OK well that was causing the VM to bluescreen at boot

    So Im thinking that as it was a IDE drive before and now I made it a sata, Ill try setting it back to IDE

    Code:
    VBoxManage storagectl "2008Server" --name 2008server --remove
    to remove the sata drive

    to remove it and then

    Code:
    VBoxManage storagectl "2008Server" --name 2008server --add ide
    to create an IDE controller..

    and then the same previous command to attach the existing .vdi to the new controller:

    Code:
    VBoxManage storageattach "2008Server" --storagectl 2008server --port 0 --device 0 --type hdd --medium /root/.VirtualBox/VDI/2008Server.vdi
    And now it boots fine...

    Hope these ramblings might help someone else...

  11. #8


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,687
    Thank Post
    352
    Thanked 794 Times in 714 Posts
    Rep Power
    346
    All fun and games

    My gentoo is still on 3.0.12

  12. Thanks to kmount from:

    RabbieBurns (15th December 2009)

  13. #9

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,512
    Thank Post
    1,320
    Thanked 469 Times in 306 Posts
    Blog Entries
    6
    Rep Power
    199
    finally got 2008 and 2008R2 x64 up and running together for the first time.. cheers all
    Attached Images Attached Images

SHARE:
+ Post New Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •