+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 19
*nix Thread, ubunutu and pop mail in Technical; Hi folks, So im trying to setup OneorZero helpdesk to check a pop account for ticket creation. I have setup ...
  1. #1

    Join Date
    May 2007
    Location
    Hull, UK
    Posts
    256
    Thank Post
    6
    Thanked 13 Times in 13 Posts
    Rep Power
    18

    ubunutu and pop mail

    Hi folks,

    So im trying to setup OneorZero helpdesk to check a pop account for ticket creation. I have setup the system according to the documentation but when i run the mailgate.php file i get a connection timeout error.

    Problem is i dont think its a firewall issue. My XP clients can access the pop server (im behind a ISA Server by the way) i have created a rule that allows the fog server to not use authentication when accessing the internet, i have even set the ubuntu box to use the upstream proxy to be safe but it always times out.

    Am i missing anything?

    Mike
    Last edited by mcloum; 27th September 2009 at 09:23 PM. Reason: switching on email notification

  2. #2
    Arcath's Avatar
    Join Date
    Feb 2009
    Location
    Lancashire
    Posts
    973
    Thank Post
    102
    Thanked 116 Times in 101 Posts
    Rep Power
    74
    If youve set the proxy then it only sets for the current user (i think, certainly does on ubuntu 9.04 desktop) so when you load the page it runs as the http user that doesnt have the proxy set.

    What version of ubunutu are you using?

    if you create a simple PHP to get a file off the internet does it do it?

  3. #3

    Join Date
    May 2007
    Location
    Hull, UK
    Posts
    256
    Thank Post
    6
    Thanked 13 Times in 13 Posts
    Rep Power
    18
    I'm using 8.10 I believe. that makes sense, I have set a network proxy and applied it to all users via the GUI. I'm not sure how to retrieve a file via PHP, any pointers and I will test.

  4. #4
    Arcath's Avatar
    Join Date
    Feb 2009
    Location
    Lancashire
    Posts
    973
    Thank Post
    102
    Thanked 116 Times in 101 Posts
    Rep Power
    74
    by far the easiest way to test it would be:

    Code:
    <?php
    $test=file_get_contents("http://www.edugeek.net/forums/nix/42044-ubunutu-pop-mail.html");
    echo($test);
    ?>
    you should get an exact copy of this page (ish)

  5. #5

    Join Date
    May 2007
    Location
    Hull, UK
    Posts
    256
    Thank Post
    6
    Thanked 13 Times in 13 Posts
    Rep Power
    18
    Code:
    Warning: file_get_contents(http://www.edugeek.net/forums/nix/42044-ubunutu-pop-mail.html) [function.file-get-contents]: failed to open stream: Redirection limit reached, aborting in /var/www/test.php on line 2
    No go

  6. #6
    Arcath's Avatar
    Join Date
    Feb 2009
    Location
    Lancashire
    Posts
    973
    Thank Post
    102
    Thanked 116 Times in 101 Posts
    Rep Power
    74
    that sounds more like this site links all over the place, try something else like "http://google.com" instead

  7. #7

    Join Date
    May 2007
    Location
    Hull, UK
    Posts
    256
    Thank Post
    6
    Thanked 13 Times in 13 Posts
    Rep Power
    18
    changing to google.com returns the google home page but without images, which i guess is normal as they dont exist on my system

  8. #8

    Join Date
    May 2007
    Location
    Hull, UK
    Posts
    256
    Thank Post
    6
    Thanked 13 Times in 13 Posts
    Rep Power
    18
    This is the error message i get:

    The mimeDecode file was not found
    Warning: fsockopen() [function.fsockopen]: unable to connect to pop.siriusacademy.org.uk:110 (Connection timed out) in /var/www/helpdesk/mailgate/mailGate.php on line 231
    Connect Failed: Connection timed out(110)

    it says the mimeDecoee file isnt found but it exists in the folder i've specified in the OOz config. any ideas?

  9. #9


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,693
    Thank Post
    352
    Thanked 798 Times in 717 Posts
    Rep Power
    347
    Can you try the following:

    telnet pop.siriusacademy.org.uk 110

  10. #10

    Join Date
    May 2007
    Location
    Hull, UK
    Posts
    256
    Thank Post
    6
    Thanked 13 Times in 13 Posts
    Rep Power
    18
    Just sits at

    Code:
    Trying 89.207.213.43
    then...

    Code:
    telnet: Unable to connect to remote host: Connection timed out
    Last edited by mcloum; 29th September 2009 at 04:50 PM.

  11. #11
    Arcath's Avatar
    Join Date
    Feb 2009
    Location
    Lancashire
    Posts
    973
    Thank Post
    102
    Thanked 116 Times in 101 Posts
    Rep Power
    74
    ah, it looks like port 110 is blocked or atleast filtered between your ubuntu box and the outside world

  12. #12

    Join Date
    May 2007
    Location
    Hull, UK
    Posts
    256
    Thank Post
    6
    Thanked 13 Times in 13 Posts
    Rep Power
    18
    No i dont think its that, like i said Outlook on a Windows box can access the pop server no problem. The only difference is that windows has the Firewall client installed. Im going to try turning off authentication all together tomorrow and see if that helps.

  13. #13
    Arcath's Avatar
    Join Date
    Feb 2009
    Location
    Lancashire
    Posts
    973
    Thank Post
    102
    Thanked 116 Times in 101 Posts
    Rep Power
    74
    can evolution (the email client that comes with ubunutu) on the ubuntu box fetch the mail?

  14. #14

    Join Date
    May 2007
    Location
    Hull, UK
    Posts
    256
    Thank Post
    6
    Thanked 13 Times in 13 Posts
    Rep Power
    18
    nope, tried that already. Same result.

  15. #15
    Arcath's Avatar
    Join Date
    Feb 2009
    Location
    Lancashire
    Posts
    973
    Thank Post
    102
    Thanked 116 Times in 101 Posts
    Rep Power
    74
    Then its connectivity issue between the ubuntu box and the server. Have you turned off the firewall on the ubunutu bix?

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 20th May 2008, 11:09 AM
  2. Menus 'pop-under'
    By kerlj001 in forum EduGeek Joomla 1.0 Package
    Replies: 10
    Last Post: 27th February 2008, 10:51 AM
  3. The evil pop up .mbs.
    By callumtuckey in forum General Chat
    Replies: 4
    Last Post: 6th June 2007, 01:19 PM
  4. Setting up an IMAP server which collects POP mail
    By crc-ict in forum Wireless Networks
    Replies: 1
    Last Post: 17th March 2007, 05:31 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •