+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16
*nix Thread, Proxy on Ubuntu for Fog in Technical; Hi, I am complete newb with *nix. I am aiming to use FOG to help image several machines. I've installed ...
  1. #1
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20

    Proxy on Ubuntu for Fog

    Hi, I am complete newb with *nix. I am aiming to use FOG to help image several machines. I've installed Ubuntu on a 5 year old machine, and it's running fine. I've given it a static IP, and I can ping other computers on the network, and access resources on our Win2k server/XP client school network.

    However, I can't seem to access the internet at all from the Ubuntu machine. The proxy settings have been set both in Ubuntu (System Wide) and in Firefox. I've also rebooted the machine, and didn't make any difference.

    Can anyone help me out, or point me in a good direction? I've search on google and can't really find anything that's helpful to me.

    Many thanks!

  2. #2
    jmcdermott's Avatar
    Join Date
    Feb 2008
    Location
    Cornwall
    Posts
    171
    Thank Post
    16
    Thanked 42 Times in 34 Posts
    Rep Power
    21
    could you supply the results of the following
    in terminal
    sudo ifconfig
    and
    route -n

    and maybe i can help

  3. #3
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20
    Thanks jmcdermott, will do this tomorrow and post on the forum.

    Cheers.

  4. #4
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20
    Hi, the responses from the commands are as follows:

    sudo ifconfig:

    eth0 Link encap:Ethernet HWaddr 00:0c:f1:7e:8d:e9
    inet addr:10.199.224.80 Bcast:10.199.231.255 Mask:255.255.248.0
    inet6 addr: fe80::20c:f1ff:fe7e:8de9/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:17459 errors:0 dropped:0 overruns:0 frame:0
    TX packets:9807 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1827763 (1.8 MB) TX bytes:12594487 (12.5 MB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:248 errors:0 dropped:0 overruns:0 frame:0
    TX packets:248 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:19592 (19.5 KB) TX bytes:19592 (19.5 KB)


    route -n

    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    10.199.224.0 0.0.0.0 255.255.248.0 U 1 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
    0.0.0.0 10.199.224.1 0.0.0.0 UG 0 0 0 eth0

    Thanks in advance. BTW, the WIN2k server is 10.199.224.16, subnet 255.255.248.0. Static IP of the ubuntu server 10.199.224.80. proxy port 3129, cache.hants.gov.uk

  5. #5
    jmcdermott's Avatar
    Join Date
    Feb 2008
    Location
    Cornwall
    Posts
    171
    Thank Post
    16
    Thanked 42 Times in 34 Posts
    Rep Power
    21
    2 possibilties apear:

    1)
    assuming 10.199.231.255 is your router/default gateway, it is not showing up as a route.
    to test this try the following
    in terminal
    route add default gw 10.199.231.255 eth0.

    2)
    assuming 10.199.224.1 is your router/default gateway, the default gateway is not correctly configured in you network settings.

    Hope this helps

    ps. should your proxy port not be 8080?

  6. Thanks to jmcdermott from:

    rocknrollstar (20th May 2009)

  7. #6
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20
    I tried 'route add default gw 10.199.231.255 eth0'
    and got 'SIOCADDRT: Operation not permitted'. Any thoughts?

    How can I find out what the default gateway is on Win2k?

    Thanks for your help.

  8. #7
    jmcdermott's Avatar
    Join Date
    Feb 2008
    Location
    Cornwall
    Posts
    171
    Thank Post
    16
    Thanked 42 Times in 34 Posts
    Rep Power
    21
    sorry that should have been
    sudo route add

  9. Thanks to jmcdermott from:

    rocknrollstar (20th May 2009)

  10. #8
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20
    Sorry, moment of relapse. Running ipconfig on server gets:

    Physical Address. . . . . . . . . : 00-0C-F1-7E-6A-3A
    DHCP Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 10.199.224.16
    Subnet Mask . . . . . . . . . . . : 255.255.248.0
    Default Gateway . . . . . . . . . : 10.199.224.1
    DNS Servers . . . . . . . . . . . : 10.199.224.16

  11. #9
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20
    When adding sudo, I get this reply:

    SIOCADDRT: No such process

    Any thoughts?

  12. #10
    jmcdermott's Avatar
    Join Date
    Feb 2008
    Location
    Cornwall
    Posts
    171
    Thank Post
    16
    Thanked 42 Times in 34 Posts
    Rep Power
    21
    very strange how did you go about setting a static ip, does the web work if you use dhcp?

  13. Thanks to jmcdermott from:

    rocknrollstar (20th May 2009)

  14. #11
    Cools's Avatar
    Join Date
    Jan 2009
    Location
    Bedfordshire
    Posts
    498
    Thank Post
    24
    Thanked 62 Times in 57 Posts
    Rep Power
    25
    what you need to do is reinstall follow this guide up to step 11 only ..
    The Perfect Server - Ubuntu 9.04 [ISPConfig 3] | HowtoForge - Linux Howtos and Tutorials



  15. Thanks to Cools from:

    rocknrollstar (20th May 2009)

  16. #12
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20
    thanks cools and jmc. I.ll check out the link and report back.

    Jmc- i set the static ip in preferences - network- then on eth0 set the ip, subnet and gateway, and rebooted. Can ping the machine from others pcs, and ping other pcs from the machine. does this help?

    Thanks for your continuing help

  17. #13
    tmbenson's Avatar
    Join Date
    May 2009
    Location
    blacko
    Posts
    51
    Thank Post
    12
    Thanked 4 Times in 4 Posts
    Rep Power
    12
    i spent a while searching through ubuntu forums myself recently for internet problems from behind our schools proxy, i was attempting anything from updates to just a straight internet connection, and failing might i add.

    I know its basic, but have you tried to export the proxy through your .bashrc file?

    e.g - export http_proxy="http://proxyaddress : port"

    found that cured my problems!

    Tom

  18. Thanks to tmbenson from:

    rocknrollstar (20th May 2009)

  19. #14
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    20
    thanks tmbenson- can you give me a little more detailed instructions on how to do this? Still finding my way around!
    Thanks in advance.

  20. #15
    tmbenson's Avatar
    Join Date
    May 2009
    Location
    blacko
    Posts
    51
    Thank Post
    12
    Thanked 4 Times in 4 Posts
    Rep Power
    12
    depending on the proxy, you may need your credentials, but i managed it without in Ubuntu.

    Firstly you need to locate your .bashrc file,

    try this in terminal:

    gksudo gedit /etc/apt/bashrc

    If this fails first find the location of the file and then use gksudo to edit it.

    Once you have found your .bashrc file just add a proxy export at the end of it, for both Http and Ftp.

    code as follows:

    export http_proxy=http://proxy@address:myport

    export ftp_proxy=http://proxy@address:myport

    save the file and close it.

    Depending on which account you are using you MAY also have to find the .profile file in /etc/apt and add the same script to that.

    Hope this helps!

    Tom

  21. Thanks to tmbenson from:

    rocknrollstar (20th May 2009)

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. [Fog] FOG Help!
    By Dafty in forum O/S Deployment
    Replies: 2
    Last Post: 10th August 2011, 10:51 AM
  2. [Fog] FOG
    By CheeseDog in forum O/S Deployment
    Replies: 5
    Last Post: 3rd March 2009, 09:54 AM
  3. Using Netboot with FOG
    By monkeyx in forum O/S Deployment
    Replies: 11
    Last Post: 11th September 2008, 01:23 AM
  4. Replies: 9
    Last Post: 25th March 2008, 06:13 PM
  5. Fog!
    By localzuk in forum Other Stuff
    Replies: 1
    Last Post: 23rd January 2007, 11:25 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •