+ Post New Thread
Results 1 to 7 of 7
*nix Thread, disable auto clipboard mouse click feature in Technical; im using the mousepad on my laptop, and there must be some part of it that acts as a middle ...
  1. #1

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200

    disable auto clipboard mouse click feature

    im using the mousepad on my laptop, and there must be some part of it that acts as a middle click or something, because whenever im typing or using the mouse, it keeps pasting in whatever i last had in the clipboard, or whatever I might happen to have the mouse pointing over. Its really annoying. Im gonna go and buy a USB mouse at some point but till then would be great to know how to disable it.

  2. #2

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,866
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    182
    Quote Originally Posted by RabbieBurns View Post
    im using the mousepad on my laptop, and there must be some part of it that acts as a middle click or something, because whenever im typing or using the mouse, it keeps pasting in whatever i last had in the clipboard, or whatever I might happen to have the mouse pointing over. Its really annoying. Im gonna go and buy a USB mouse at some point but till then would be great to know how to disable it.
    Probably both buttons together simulates a third-button click, which pastes from the X clipboard. This might help: Sebastian’s blog HowTo: Disable “middle button” click when pressing left and right mouse button in X.Org 7.4

  3. Thanks to powdarrmonkey from:

    RabbieBurns (12th May 2009)

  4. #3

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Thanks Ill check that out. Its happening not by pressing either left or right click, but something to do with the trackpad. Maybe theres a click emulation somewhere on the trackpad, certainly i can scroll down through pages by dragging the very right of the trackpad etc.

    root@rubuntu:~# lshal | grep mouse
    info.capabilities = {'input', 'input.mouse'} (string list)
    info.product = 'Macintosh mouse button emulation' (string)
    input.product = 'Macintosh mouse button emulation' (string)
    info.product = 'IBM Enhanced (101/102-key, PS/2 mouse support)' (string)
    pnp.description = 'IBM Enhanced (101/102-key, PS/2 mouse support)' (string)
    info.linux.driver = 'psmouse' (string)
    info.callouts.add = {'hal-probe-vmmouse'} (string list)
    info.capabilities = {'input', 'input.mouse', 'input.touchpad'} (string list)
    info.callouts.add = {'hal-probe-vmmouse'} (string list)
    info.capabilities = {'input', 'input.mouse'} (string list)
    info.capabilities = {'input', 'input.mouse'} (string list)
    Im not quite sure which is what I want ?

  5. #4

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,866
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    182
    The info.product entry. Turn:

    Code:
    <device>
      <match key=”info.capabilities” contains=”input.mouse”>
        <match key=”info.product” string=”<your mouse’s info.product>”>
          <merge key=”input.x11_options.Emulate3Buttons” type=”string”>false</merge>
        </match>
      </match>
    </device>
    into:

    Code:
    <device>
      <match key=”info.capabilities” contains=”input.mouse”>
        <match key=”info.product” string=”Macintosh mouse button emulation”>
          <merge key=”input.x11_options.Emulate3Buttons” type=”string”>false</merge>
        </match>
      </match>
    </device>

  6. Thanks to powdarrmonkey from:

    RabbieBurns (12th May 2009)

  7. #5

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    thanks, added that.. will see if it works after i reboot in a while, cheers!

  8. #6

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Quote Originally Posted by RabbieBurns View Post
    thanks, added that.. will see if it works after i reboot in a while, cheers!
    been meaning to reply to myself for a while.. This is still not fixed ..

  9. #7

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Ive managed to remove this problem, by disabling the "tap mousepad for click" feature, which gets rid of my problem, but also removes the functionality a bit. But at least im not pasting random text in the middle of sentences any more which is good.

SHARE:
+ Post New Thread

Similar Threads

  1. disable right-click>set as desktop background
    By beeswax in forum Windows
    Replies: 19
    Last Post: 29th March 2012, 04:35 PM
  2. Getting someone elses clipboard?!?
    By sidewinder in forum Windows
    Replies: 6
    Last Post: 13th June 2008, 12:25 PM
  3. Replies: 10
    Last Post: 7th November 2007, 12:32 PM
  4. Clipboard Clearer
    By mattx in forum Scripts
    Replies: 0
    Last Post: 5th November 2007, 01:06 PM
  5. Replies: 3
    Last Post: 21st June 2007, 08:26 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •