+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 17
*nix Thread, V.10 - kmod-nvidia not found and installer cannot compile kernel?? in Technical; [Fedora 10} kmod-nvidia not found and manual installer cannot compile kernel?? [root@Fedora10-test hgs]# yum install kmod-nvidia Loaded plugins: refresh-packagekit Setting ...
  1. #1
    llawwehttam's Avatar
    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    223
    Thank Post
    56
    Thanked 3 Times in 3 Posts
    Blog Entries
    2
    Rep Power
    15

    V.10 - kmod-nvidia not found and installer cannot compile kernel??

    [Fedora 10} kmod-nvidia not found and manual installer cannot compile kernel??

    [root@Fedora10-test hgs]# yum install kmod-nvidia
    Loaded plugins: refresh-packagekit
    Setting up Install Process
    Parsing package install arguments
    No package kmod-nvidia available.
    Nothing to do

    plz help me
    thankyou

  2. #2

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,808
    Thank Post
    880
    Thanked 684 Times in 453 Posts
    Rep Power
    505

  3. #3


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,701
    Thank Post
    352
    Thanked 806 Times in 721 Posts
    Rep Power
    348
    Have you enabled the correct repository to provide kmod-nvidia?

  4. #4
    llawwehttam's Avatar
    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    223
    Thank Post
    56
    Thanked 3 Times in 3 Posts
    Blog Entries
    2
    Rep Power
    15
    which repo would that be???
    plz

  5. #5


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,701
    Thank Post
    352
    Thanked 806 Times in 721 Posts
    Rep Power
    348
    If you read Gatt's link it will talk you through adding the repository etc.

  6. #6
    llawwehttam's Avatar
    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    223
    Thank Post
    56
    Thanked 3 Times in 3 Posts
    Blog Entries
    2
    Rep Power
    15
    i tried that
    all i got was
    [root@Fedora10-test hgs]# su -c 'rpm -Uvh http://download1.rpmfusion.org/free/...release-stable... http://download1.rpmfusion.org/nonfr...nfree-release-... yum -y install kmod-nvidia'
    -y: unknown option

    [root@Fedora10-test hgs]# su -c 'yum -y install binutils'
    Loaded plugins: refresh-packagekit
    Setting up Install Process
    Parsing package install arguments
    Package binutils-2.18.50.0.9-8.fc10.i386 already installed and latest version
    Nothing to do

    then the driver still couldn't build the kernel

  7. #7


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,701
    Thank Post
    352
    Thanked 806 Times in 721 Posts
    Rep Power
    348
    Lets break it down:

    Run these one at a time and post back the outputs.

    rpm -Uvh http://download1.rpmfusion.org/free/...ble.noarch.rpm

    rpm -Uvh http://download1.rpmfusion.org/nonfr...ble.noarch.rpm

    yum install kmod-nvidia

  8. #8
    llawwehttam's Avatar
    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    223
    Thank Post
    56
    Thanked 3 Times in 3 Posts
    Blog Entries
    2
    Rep Power
    15
    once the driver opens in runlevel 3 it cannot download the kernel (temporary dns error) then when it attempts to build the kernel is says
    error cannol build the nvidia kernel

    funny thing is i did the exact same method on a centos machine yesterday and it was fine

  9. #9


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,701
    Thank Post
    352
    Thanked 806 Times in 721 Posts
    Rep Power
    348
    Can you as I asked confirm what happened with those commands.

  10. #10
    llawwehttam's Avatar
    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    223
    Thank Post
    56
    Thanked 3 Times in 3 Posts
    Blog Entries
    2
    Rep Power
    15
    [root@Fedora10-test hgs]# rpm -Uvh http://download1.rpmfusion.org/free/...ble.noarch.rpm
    Retrieving http://download1.rpmfusion.org/free/...ble.noarch.rpm
    curl: (7) couldn't connect to host
    error: skipping http://download1.rpmfusion.org/free/...ble.noarch.rpm - transfer failed

    [root@Fedora10-test hgs]#
    [root@Fedora10-test hgs]# rpm -Uvh http://download1.rpmfusion.org/nonfr...ble.noarch.rpm
    Retrieving http://download1.rpmfusion.org/nonfr...ble.noarch.rpm
    curl: (7) couldn't connect to host
    error: skipping http://download1.rpmfusion.org/nonfr...ble.noarch.rpm - transfer failed

  11. #11

    Gatt's Avatar
    Join Date
    Jan 2006
    Posts
    6,808
    Thank Post
    880
    Thanked 684 Times in 453 Posts
    Rep Power
    505
    whats http_proxy set to?
    # env | grep http_proxy

    if its blank - type
    # export http_proxy=<<your-proxy-iport>>

    same for ftp_proxy
    Last edited by Gatt; 20th February 2009 at 12:20 PM.

  12. #12
    llawwehttam's Avatar
    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    223
    Thank Post
    56
    Thanked 3 Times in 3 Posts
    Blog Entries
    2
    Rep Power
    15
    proxy=http://10.121.128.30:80/

    i tried down loading and installing kmod-nvidia manually but all i get is
    [root@Fedora10-test /]# rpm -ivh /home/hgs/Download/kmod-nvidia-2.6.27.12-170.2.5.fc10.i686-180.22-1.fc10.1.i686.rpm
    warning: /home/hgs/Download/kmod-nvidia-2.6.27.12-170.2.5.fc10.i686-180.22-1.fc10.1.i686.rpm: Header V3 DSA signature: NOKEY, key ID b1981b68
    error: Failed dependencies:
    nvidia-kmod-common >= 180.22 is needed by kmod-nvidia-2.6.27.12-170.2.5.fc10.i686-180.22-1.fc10.1.i686

    seems slightly more hopeful so will try installing common
    yum cannot find tho

  13. #13
    llawwehttam's Avatar
    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    223
    Thank Post
    56
    Thanked 3 Times in 3 Posts
    Blog Entries
    2
    Rep Power
    15
    tried manual install of kmod-nvidia-common but got

    livna-config-display is needed by package xorg-x11-drv-nvidia-173.14.12-1.lvn9.i386 (/home/hgs/Download/xorg-x11-drv-nvidia-173.14.12-1.lvn9.i386.rpm)
    xorg-x11-drv-nvidia-libs = 173.14.12-1.lvn9 is needed by package xorg-x11-drv-nvidia-173.14.12-1.lvn9.i386 (/home/hgs/Download/xorg-x11-drv-nvidia-173.14.12-1.lvn9.i386.rpm)
    nvidia-kmod >= 173.14.12 is needed by package xorg-x11-drv-nvidia-173.14.12-1.lvn9.i386 (/home/hgs/Download/xorg-x11-drv-nvidia-173.14.12-1.lvn9.i386.rpm)

  14. #14


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,701
    Thank Post
    352
    Thanked 806 Times in 721 Posts
    Rep Power
    348
    Can you as I asked confirm what happened with those commands.
    Seeing as I earnt myself a block of negative rep for my post above asking you to answer my previous question I didn't reply again yesterday.

    Nonetheless, I'm a nice person and want to get this going for you.

    Forgetting yum for a second, does the following work:

    wget "http://fuller.zen.co.uk/test/10MB_zero.bin"
    If this fails, we have an issue with your proxy settings within Fedora which we can resolve which may in turn fix the problems with nvidia.

  15. #15
    llawwehttam's Avatar
    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    223
    Thank Post
    56
    Thanked 3 Times in 3 Posts
    Blog Entries
    2
    Rep Power
    15
    yes it worked fine

    and negative rep??? I didn't do that



SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Using Fedora 9
    By nephilim in forum *nix
    Replies: 5
    Last Post: 17th November 2008, 01:54 PM
  2. Replies: 6
    Last Post: 9th October 2008, 01:28 PM
  3. Google SketchUp and Kernel Panics
    By ndavies in forum Educational Software
    Replies: 7
    Last Post: 19th May 2008, 03:20 PM
  4. Karoshi on Fedora Core 5
    By fooby in forum *nix
    Replies: 22
    Last Post: 16th June 2006, 01:52 PM
  5. Replies: 18
    Last Post: 7th November 2005, 05:12 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •