+ Post New Thread
Results 1 to 4 of 4
*nix Thread, Dansguardian 2.10 on Ubuntu 8.04 in Technical; Has any body got a conifigure example for ntlm auth to enable me to compile this for ubuntu. I have ...
  1. #1

    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    123
    Thank Post
    8
    Thanked 11 Times in 10 Posts
    Rep Power
    19

    Dansguardian 2.10 on Ubuntu 8.04

    Has any body got a conifigure example for ntlm auth to enable me to compile this for ubuntu.
    I have successfully got 2.8 running but want to be able to monitor the kids with dansguardian with the need for the squid-dg-squid set up I believe that dg2.10 can do this but it does not come as part of ubuntu. Also I have compiled it without but also it does not run
    It errors with
    dansguardian: error while loading shared libraries: libpcreposix.so.0:
    I know the file is there I just don't know where to tell dg.
    I am a bit of a newbie to linux
    Thanks

  2. #2


    tom_newton's Avatar
    Join Date
    Sep 2006
    Location
    Leeds
    Posts
    4,475
    Thank Post
    866
    Thanked 849 Times in 671 Posts
    Rep Power
    196
    Is that file there with the ".0" on the end?
    Perhaps you need to change --prefix when compiling.

    Think there may be a few interesting bugs in the 2.10 branch with ntlm tho (this is just based on what I hear our devs are up to - they do work on the Open Source stuff too!) so you may be best served hanging on a few weeks.

  3. #3

    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    123
    Thank Post
    8
    Thanked 11 Times in 10 Posts
    Rep Power
    19
    Yes the file is onthe systemat usr/local/lib but on closer look it is a link to libpcreposix.so.0.0.0
    It would benice to know what the configure options should beto install DG wheee the old 2.8 version was not very clued up on using compile

  4. #4

    Join Date
    Mar 2007
    Posts
    10
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    use apt-get the version in the repo is 2.9.9.7 which supports ntlm

SHARE:
+ Post New Thread

Similar Threads

  1. Dansguardian Startup
    By ahuxham in forum *nix
    Replies: 9
    Last Post: 24th June 2008, 01:48 PM
  2. Replies: 9
    Last Post: 25th March 2008, 06:13 PM
  3. Dansguardian
    By DMcCoy in forum *nix
    Replies: 10
    Last Post: 25th January 2008, 01:17 PM
  4. dansguardian
    By callumtuckey in forum How do you do....it?
    Replies: 3
    Last Post: 21st May 2007, 08:43 AM
  5. DansGuardian without local Squid
    By NetworkGeezer in forum *nix
    Replies: 2
    Last Post: 13th February 2007, 02:07 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •