+ Post New Thread
Results 1 to 11 of 11
*nix Thread, truecrypt on gentoo issue in Technical; After a fun battle to get truecrypt to install on Gentoo, Ive finally got it running, created my encrypted container ...
  1. #1

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200

    truecrypt on gentoo issue

    After a fun battle to get truecrypt to install on Gentoo, Ive finally got it running, created my encrypted container etc, all fine.

    However when trying to mount the encrypted container, I get the following error:

    Code:
    Error: device-mapper: reload ioctl failed: Invalid argument
    Command failed
    I had to add FUSE to the kernel before TC would install, which I did as a module.

    Ive not rebooted, but I dont think I need to with just a modular kernel change rather than compiling it within?

    Any suggestions?

  2. #2

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Code:
    oasis ~ # truecrypt /enc/files.enc
    Enter mount directory [default]: /home/user/secret
    Enter password for /enc/files.enc:
    Enter keyfile [none]:
    Protect hidden volume? (y=Yes/n=No) [No]: n
    Error: device-mapper: reload ioctl failed: Invalid argument
    Command failed
    I'm still no further on with this.. hope its OK to bump in case anyone's got any ideas..

  3. #3

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,812
    Thank Post
    110
    Thanked 585 Times in 506 Posts
    Blog Entries
    1
    Rep Power
    224
    Please post the more detailed error message that gets spammed to your syslog when you do that.

  4. #4

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Code:
    oasis ~ # cat /var/log/messages | grep ioctl
    Jan 19 14:51:15 oasis device-mapper: ioctl: error adding target to table
    Jan 19 14:54:12 oasis device-mapper: ioctl: error adding target to table

  5. #5

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,812
    Thank Post
    110
    Thanked 585 Times in 506 Posts
    Blog Entries
    1
    Rep Power
    224
    Install lvm2 and dmraid.

  6. #6

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Installed both. Same error. I missed a line out the logs last time.

    Code:
    Jan 19 16:00:38 oasis device-mapper: table: 254:0: crypt: unknown target type
    Jan 19 16:00:38 oasis device-mapper: ioctl: error adding target to table

  7. #7

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    been away for a couple of weeks.. still not managed to solve this problem - does anyone else have any ideas?

  8. #8

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    Geoff, if I gave you access to the machine would you be willing to have a look into this for me please?

  9. #9

    Join Date
    Apr 2009
    Posts
    2
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    since you're gentoo user i guess you have your own kernel so

    1) check whether you have appropriate modules compiled in kernel that is:

    <*>Device Drivers
    <*>Block Devices
    <*>Loopback device support
    .....
    <*>Multiple Devices driver support (LVM and RAID)
    <*>Device mapper support
    <*>Crypt target support

    if you have all of these go to truecrypt>settings>preferences>system integration

    and check "Do not use kernel cryptographic services"

    if you have the same error (or maybe other now)

    2) Check if you have all cipher and hash/digest methods used by truecrypt (and chosen by you) compiled in your kernel/as modules (then load them)

    these are:

    <*>Cryptographic API
    <*>XTS support
    <*>RIPEMD-160 digest algorithm |default for truecrypt
    <*>SHA384 and SHA512 digest algorithms |you can choose
    <*>Whirpool digest algorithm |sha512 and whirpool too

    <*>AES cipher algorithms |default truecrypt cipher
    <*>AES cipher algorithm (x86_64) -> if you are on such architecture
    or/and:
    <*>Serpent cipher algorithm
    <*>Twofish cipher algorithm
    <*>Twofish cipher algorithm(x86_64)

    it worked for me

    hope it helps

    but i'm disgusted by lack of ANY support for linux instalation (or linux support at all) on truecrypt home page... there are only methods how to use your system less useable (those hidden volumes, hidden systems etc. are overkill - if sbd would interrogate you - you would get skompolomine injection and told them not only passwords but some things you don't even know that you remember) that's why i posted this solution (usually i don't).

  10. Thanks to gentoo from:

    RabbieBurns (7th April 2009)

  11. #10

    RabbieBurns's Avatar
    Join Date
    Apr 2008
    Location
    Sydney
    Posts
    5,531
    Thank Post
    1,341
    Thanked 470 Times in 307 Posts
    Blog Entries
    6
    Rep Power
    200
    thanks for that, i will give it a try as soon as i can. I dont use X but am sure i can implement the setting you recommend from the cli.

  12. #11

    Join Date
    Apr 2009
    Posts
    2
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    i don't recomend this option cause it affects performance - i suggest enabling it for testing if the lack of crypto algorithm is the cause of your error (i had number 253 in my error but...)

    if it's the case then after enabling it everything should work (very slow though).
    if you can't mount volume despite enabling it your problem lies somewhere else (probably:P)

    i have compiled in the kernel (on my laptop), but if you can't reboot your system (without X -> i guess server) you can compile them as modules (device mapper as well)

    I came to this solution recalling old days when truecrypt was kernel module, and loading it required all other crypto modules loaded

    good luck

SHARE:
+ Post New Thread

Similar Threads

  1. Truecrypt Container Mode
    By elsiegee40 in forum How do you do....it?
    Replies: 74
    Last Post: 1st July 2011, 09:42 AM
  2. mount ext2/3 in windows with truecrypt installed
    By RabbieBurns in forum Windows
    Replies: 0
    Last Post: 16th October 2008, 11:36 AM
  3. change GMT to BST on gentoo
    By RabbieBurns in forum *nix
    Replies: 3
    Last Post: 17th June 2008, 04:13 PM
  4. Gentoo issues
    By _Bob_ in forum *nix
    Replies: 1
    Last Post: 31st October 2005, 02:29 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •