+ Post New Thread
Results 1 to 11 of 11
*nix Thread, Using a computer on and off the network in Technical; Hi. I usually post on the tes but have been advised this is a better forum for more technical questions. ...
  1. #1
    oc7
    oc7 is offline

    Join Date
    Dec 2008
    Location
    Murcia, Spain
    Posts
    8
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Using a computer on and off the network

    Hi.

    I usually post on the tes but have been advised this is a better forum for more technical questions. I have tried the search and cannot find my solution but if it has been asked before I apologise and hope you put it down to my newbie status.

    I have a laptop that is setup to log on to the network. If no network is available then as you would expect I can log on as a stand alone user. I have a work folder that allows me to pass documents from my stand alone profile to the network and back again.

    I have two problems (probably one problem with two symptoms)

    i) I cannot connect to the Internet at work when I am in stand alone mode as connecting to the network at any point causes the network home directory to mount.

    ii) When I run it off the network at home I can connect to the Internet but the machine struggles (takes quite a few minutes) when starting up appliacations. Once started they run at normal speed although seem to be slightly more prone to needing a Force Quit.

    It seems that once on a network it must be trying to sort out the filesystem but I cannot find how to stop this.

    I am running Edubuntu 7.04.

    Any thoughts? Anyone come across this before?

    Thanks in anticipation

    oc7 (kev)

  2. #2

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,859
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    182
    Sounds vaguely like you're mounting a network drive at startup. Paste the contents of /etc/fstab.

  3. #3
    oc7
    oc7 is offline

    Join Date
    Dec 2008
    Location
    Murcia, Spain
    Posts
    8
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I am mounting a network drive at start up.

    Won't be able to paste the contents of fstab until tomorrow though.

    Thanks for your quick response.

    The mount line (from memory)

    mount LINUXSERVER:/home /home ...

    also there is a shared drive

    mount SENECA00:/media/seneca /mnt/comaprtida

    the rest is as default

  4. #4

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,859
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    182
    I thought so. Add the noauto flag to stop them mounting at boot time, then mount them manually if circumstances permit by saying:
    Code:
    sudo mount 
    e.g. sudo mount /home/myuser
    You will be prompted for your password to become sudo, as usual.

    Also, it's probably not a good idea to store the whole /home directory remotely. At least, I wouldn't do it, but your mileage may vary.

  5. Thanks to powdarrmonkey from:

    oc7 (19th December 2008)

  6. #5
    oc7
    oc7 is offline

    Join Date
    Dec 2008
    Location
    Murcia, Spain
    Posts
    8
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks, I will try that.

    Won't be able to mount the network until I go back to school in a few weeks time but looks like I will be able to work at home without having to make a cup of tea everytime I want to start a new app.

    The rest of your reply throws up some more questions but I will save them for another day.

    Off for a well earned first beer of the weekend

    thanks again

    oc7 (kev)

  7. #6
    oc7
    oc7 is offline

    Join Date
    Dec 2008
    Location
    Murcia, Spain
    Posts
    8
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have added the noauto option as suggested with no effect, here is my fstab file

    Code:
    # /etc/fstab: static file system information.
    #
    #      
    proc            /proc           proc    defaults        0       0
    # /dev/sda6
    UUID=553ae6d9-42ba-439e-b0a9-7be9deba78d9 /               ext3    defaults,errors=remount-ro 0       1
    # /dev/sda7
    UUID=afec6bf4-901a-442d-801f-b970cde00293 /home           ext3    defaults        0       2
    # /dev/sda1
    UUID=D89890D09890AE8E /media/sda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    # /dev/sda5
    UUID=c77f3f84-7f07-11db-b4ae-61344fa83f19 none            swap    sw              0       0
    /dev/scd0               /media/cdrom0   udf,iso9660 user,noauto  0 0
    LINUXSERVER:/home       /home           nfs         user,noauto  0 0
    SENECA00:/media/seneca  /mnt/compartida nfs         user,noauto  0 0
    Any help gratefully received.

    P.S. I tried commenting out the last two lines and this didn't help either.

  8. #7

    Join Date
    Dec 2008
    Posts
    6
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    You could try strace'ing the apps that slow down when reading from filesystem. You can look in the strace logs to see what file they are trying to access.

    But it does not look as if the problem is FS related IMHO.

  9. #8
    oc7
    oc7 is offline

    Join Date
    Dec 2008
    Location
    Murcia, Spain
    Posts
    8
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    One of the consequences of the problem is that when I try and start a terminal session the terminal remains blank, that is, I don't get a prompt. If I try and log on as root (through ctrl f1) it times out.

    To edit fstab I have to disconnect. I would have to do the same to run the strace and so would be strac-ing when the system is running fine.

    Also, once the application is up and running there isn't really a problem.

    Currently, I am disconnecting from the network, starting up all the apps I want to use then reconnecting. When I want to start a new app I disconnect again. It is a bit mad as I have to do this for something as simple as getting the properties of a file!

    Maybe the way I am going about this is flawed, is there a better way of using my laptop at school (on the network) and at home?

  10. #9

    Join Date
    Dec 2008
    Posts
    6
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I have encountered the problem with a terminal that starts too slow myself. It is often because Ubuntu and other distros have bash-completion enabled by default. It takes some resources. If you want it to be quicker I suggest one of these methods:
    1. Changing to a simpler shell, i.e. /bin/sh. You can change the shell by editing the last field in /etc/passwd, or by executing "chsh".
    2. Uninstalling the bash-completion package, however I am not sure if this disables all the resource hungry stuff
    3. Sometimes it works if you press Control-C at bash startup. The scripts that are running will be terminated and you should get a prompt.
    4. Edit .bashrc and the other scripts to disable stuff.


    You say that applications are running at full speed when they are launched. Have you tried benchmarking your harddrive? Also, if you do a "find /" I imageine that it would halt before finding the files on the slow FS. That seems like a logical way to find out if it is a FS related problem.

  11. #10

    powdarrmonkey's Avatar
    Join Date
    Feb 2008
    Location
    Alcester, Warwickshire
    Posts
    4,859
    Thank Post
    412
    Thanked 777 Times in 650 Posts
    Rep Power
    182
    I'm still inclined to think that mounting /home off the network is not helping you. I would keep it local and mount your network stuff somewhere else, perhaps use rsync (or backintime, which is rsync + cron + diff in a nice Gnome gui) to stay in sync.

  12. #11
    oc7
    oc7 is offline

    Join Date
    Dec 2008
    Location
    Murcia, Spain
    Posts
    8
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I think it is/was a mounting problem.

    Although the noauto appeared not to work and then commenting out also appeared to fail it is now working fine. Not sure why it didn't work straight away but there you go.

    Thanks for the suggestions folks.

    I will have a look at backintime, thnaks again

    oc7 (Kev)

SHARE:
+ Post New Thread

Similar Threads

  1. DCI - Network Cabling and Computer Benching
    By chrissmall in forum Recommended Suppliers
    Replies: 2
    Last Post: 1st October 2009, 11:55 AM
  2. Replies: 13
    Last Post: 30th June 2009, 04:23 PM
  3. Computer hangs at 'Applying Computer Settings'
    By crc-ict in forum Wireless Networks
    Replies: 8
    Last Post: 25th April 2008, 10:29 PM
  4. Outside computer on our network
    By FN-GM in forum Wireless Networks
    Replies: 15
    Last Post: 19th February 2008, 09:25 PM
  5. Copy 2 files to every computer on the network
    By dezt in forum How do you do....it?
    Replies: 7
    Last Post: 5th July 2006, 11:43 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •