+ Post New Thread
Results 1 to 11 of 11
*nix Thread, clamav dependincy error in Technical; Ok I might be running befor i can walk. Have dansguardian installed fine all working but have a problem with ...
  1. #1
    alonebfg's Avatar
    Join Date
    Aug 2006
    Location
    south west some of the time
    Posts
    834
    Thank Post
    12
    Thanked 34 Times in 21 Posts
    Blog Entries
    5
    Rep Power
    24

    clamav dependincy error

    Ok I might be running befor i can walk. Have dansguardian installed fine all working but have a problem with clamav out of date ave tried to update useing package but complanes of libgmp3 not being installed. I know i have libgmp3-dev installed and a few others but this does not fix the problem
    Attached Images Attached Images

  2. #2

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,804
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: clamav dependincy error

    Use aptitude to install it rather than apt-get. It handles these sort of dependency chains better.

  3. #3
    alonebfg's Avatar
    Join Date
    Aug 2006
    Location
    south west some of the time
    Posts
    834
    Thank Post
    12
    Thanked 34 Times in 21 Posts
    Blog Entries
    5
    Rep Power
    24

    Re: clamav dependincy error

    I have tried to do that but I does not work as there is a issue with dansguardian everytime i do this its driving me nuts and i was not apt-get ing it i was doing a manual package install

  4. #4

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,804
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: clamav dependincy error

    Why are you installing the package manually?

  5. #5
    alonebfg's Avatar
    Join Date
    Aug 2006
    Location
    south west some of the time
    Posts
    834
    Thank Post
    12
    Thanked 34 Times in 21 Posts
    Blog Entries
    5
    Rep Power
    24

    Re: clamav dependincy error

    because the apt-get is out of date the engien is out of date and keeps comming up with warnings. I have downloaded the 8 clamav 0.91.2-0volatile1_i386.deb packages then try to install them via dpkg -i but keeps comming up with the above errors.

  6. #6

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,804
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: clamav dependincy error

    It's not a big deal that the engine is out of date.

    Can you run 'dpkg -l libgmp3c2' and post the output?

  7. #7
    alonebfg's Avatar
    Join Date
    Aug 2006
    Location
    south west some of the time
    Posts
    834
    Thank Post
    12
    Thanked 34 Times in 21 Posts
    Blog Entries
    5
    Rep Power
    24

    Re: clamav dependincy error

    hello i hope tis is what you are looking for ??
    Code:
    root@webserver:/home/admin# dpkg -l libgmp3c2
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name           Version        Description
    +++-==============-==============-============================================
    ii  libgmp3c2      4.1.4-11ubuntu Multiprecision arithmetic library
    root@webserver:/home/admin#
    this is way above anything i know

  8. #8
    alonebfg's Avatar
    Join Date
    Aug 2006
    Location
    south west some of the time
    Posts
    834
    Thank Post
    12
    Thanked 34 Times in 21 Posts
    Blog Entries
    5
    Rep Power
    24

    Re: clamav dependincy error

    ok i have also tried adding the
    deb http://volatile.debian.net/debian-volatile sarge/volatile main contrib
    as it said on one of the ubuntu fourms about abbing this is ok and this is the errors i get now.
    Code:
    root@webserver:/home/admin# apt-get install clamav-daemon \
    > clamav-freshclam exim4-daemon-heavy exim4 \
    > courier-base courier-authdaemon courier-imap \
    > courier-pop spamassassin wget spamc sa-exim
    Reading package lists... Done
    Building dependency tree... Done
    wget is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies.
      clamav-daemon: Depends: libclamav2 (>= 0.91.2) but it is not going to be installed
      clamav-freshclam: Depends: libclamav2 (>= 0.91.2) but it is not going to be installed
    E: Broken packages
    root@webserver:/home/admin# apt-get install clamav
    Reading package lists... Done
    Building dependency tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies.
      clamav: Depends: libclamav2 (>= 0.91.2) but it is not going to be installed
    E: Broken packages
    root@webserver:/home/admin# apt-get libclamav2
    E: Invalid operation libclamav2
    root@webserver:/home/admin# apt-get install libclamav2
    Reading package lists... Done
    Building dependency tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies.
      libclamav2: Depends: libgmp3 but it is not installable
    E: Broken packages
    root@webserver:/home/admin# apt-get install libgmp3
    Reading package lists... Done
    Building dependency tree... Done
    Package libgmp3 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
      libgmpxx3 libgmp3c2 libgmp3-doc
    E: Package libgmp3 has no installation candidate
    root@webserver:/home/admin#
    now i am still getting the same errors

    seems like it is not just me http://ubuntuforums.org/showthread.php?t=154268
    its this silly libgmp3 problem

  9. #9
    alonebfg's Avatar
    Join Date
    Aug 2006
    Location
    south west some of the time
    Posts
    834
    Thank Post
    12
    Thanked 34 Times in 21 Posts
    Blog Entries
    5
    Rep Power
    24

    Re: clamav dependincy error

    ok found this on one of the fourms and looks like it might work http://www.qustodium.net/HOWTO_Backp...u_Dapper_Drake going to try it tonight on my test platform ??

  10. #10

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,804
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: clamav dependincy error

    Those instructions look sensible. In fact, they seem familiar. I had to build a 64bit version of clamav a while back and I could swear I used the same method to get it to work.

  11. #11
    alonebfg's Avatar
    Join Date
    Aug 2006
    Location
    south west some of the time
    Posts
    834
    Thank Post
    12
    Thanked 34 Times in 21 Posts
    Blog Entries
    5
    Rep Power
    24

    Re: clamav dependincy error

    ok it dont work keep getting this error
    Code:
    root@webserver:/usr/src# dpkg -i clam*.deb libclam*.deb
    (Reading database ... 36014 files and directories currently installed.)
    Preparing to replace clamav 0.91.2-3ubuntu2 (using clamav_0.91.2-3ubuntu2_i386.deb) ...
    Unpacking replacement clamav ...
    Preparing to replace clamav-base 0.91.2-3ubuntu2 (using clamav-base_0.91.2-3ubuntu2_all.deb) ...
    Unpacking replacement clamav-base ...
    Preparing to replace clamav-docs 0.91.2-3ubuntu2 (using clamav-docs_0.91.2-3ubuntu2_all.deb) ...
    Unpacking replacement clamav-docs ...
    Preparing to replace clamav-testfiles 0.91.2-3ubuntu2 (using clamav-testfiles_0.91.2-3ubuntu2_all.deb) ...
    Unpacking replacement clamav-testfiles ...
    Preparing to replace libclamav2 0.91.2-3ubuntu2 (using libclamav2_0.91.2-3ubuntu2_i386.deb) ...
    Unpacking replacement libclamav2 ...
    dpkg: dependency problems prevent configuration of clamav:
     clamav depends on libcurl3-gnutls; however:
      Package libcurl3-gnutls is not installed.
    dpkg: error processing clamav (--install):
     dependency problems - leaving unconfigured
    Setting up clamav-base (0.91.2-3ubuntu2) ...
    
    dpkg: dependency problems prevent configuration of clamav-docs:
     clamav-docs depends on sharutils; however:
      Package sharutils is not installed.
    dpkg: error processing clamav-docs (--install):
     dependency problems - leaving unconfigured
    Setting up clamav-testfiles (0.91.2-3ubuntu2) ...
    Setting up libclamav2 (0.91.2-3ubuntu2) ...
    
    Errors were encountered while processing:
     clamav
     clamav-docs
    root@webserver:/usr/src#
    it is so frustrating

SHARE:
+ Post New Thread

Similar Threads

  1. WTF does this error mean
    By Gatt in forum Windows
    Replies: 5
    Last Post: 10th July 2007, 04:40 PM
  2. 2k3 r2 sp1 error
    By alonebfg in forum Windows
    Replies: 0
    Last Post: 10th June 2007, 10:05 AM
  3. MSI Error
    By ufuo in forum Windows
    Replies: 4
    Last Post: 30th June 2006, 01:37 PM
  4. Has anyone else seen this error?
    By beast_gts in forum ICT KS3 SATS Tests
    Replies: 6
    Last Post: 26th April 2006, 09:17 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •