+ Post New Thread
Results 1 to 2 of 2
*nix Thread, Oh, learned friends!! SSH Chroot annoyance.... in Technical; I'll skip the rant.... I'm running a secure ftp server, open ssh version 5. I'm trying to chroot the users ...
  1. #1
    DT2
    DT2 is offline
    DT2's Avatar
    Join Date
    May 2011
    Location
    Lakeville, Carleton County, New Brunswick
    Posts
    695
    Thank Post
    140
    Thanked 198 Times in 139 Posts
    Rep Power
    74

    Oh, learned friends!! SSH Chroot annoyance....

    I'll skip the rant....

    I'm running a secure ftp server, open ssh version 5.
    I'm trying to chroot the users belonging to sftpusers group (completed successfully).
    However, what is of annoyance to me is that any users connecting now cannot write to the directory in which they are jailed!!
    If i change the permissions on the directory to allow this, the server rejects the connection for security reasons.
    I need an sftp server that will chroot the users and allow them to write to their respective directories....

    In short.. HELP!!! (please )

    Anyone have any tips?

    Thanks in advance.

    DT

    EDIT:

    Scrap that, sussed it. However any files I try to upload seem to fail at exactly 56832000 bytes.... cannot find this set limit anywhere..... any ideas?
    I've set a 100Mb limit in limits.conf for the concerned usergroup, still nothing...
    Last edited by DT2; 14th November 2013 at 03:45 PM.

  2. #2
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,419
    Thank Post
    507
    Thanked 282 Times in 258 Posts
    Rep Power
    81
    so thats 6 meg then ?

    Have you tried connecting to the server and transferring over SFTP ?

    I am confused slightly, you said your running an FTP server.. if your using SSH on Linux you don't nee to run an SSH server to be able to file transfer. Just connect using Filezilla or WinSCP over port 22 and transfer files.

    As far as I can recall, ive never come across anything to do with file upload limits with SFTP on Redhat based systems. Have you tried restarting the service ?

SHARE:
+ Post New Thread

Similar Threads

  1. Tempus Learning Manager
    By Sally in forum Educational Software
    Replies: 0
    Last Post: 19th October 2005, 03:10 PM
  2. User Friendly
    By eduabncs in forum Jokes/Interweb Things
    Replies: 0
    Last Post: 14th September 2005, 02:20 PM
  3. Teaching and Learning Responsibility (tlr)
    By russdev in forum General Chat
    Replies: 16
    Last Post: 8th September 2005, 01:18 PM
  4. Oh why wont the internet work anymore :S
    By tarquel in forum Wireless Networks
    Replies: 4
    Last Post: 27th August 2005, 07:33 AM
  5. Where Can I Learn Linux?
    By StewartKnight in forum *nix
    Replies: 7
    Last Post: 22nd August 2005, 11:15 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •