+ Post New Thread
Results 1 to 1 of 1
*nix Thread, Cannot generate Sarg report from Squid3 in Technical; Ubuntu 12.10 Squid3 3.1 Dansguardian 2.10.1.1 Postfix 2.9.6 When I attempt to 'Generate Report Now' using 'Squid Report Generator' on ...
  1. #1
    Bullet333's Avatar
    Join Date
    Apr 2013
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Question Cannot generate Sarg report from Squid3

    Ubuntu 12.10
    Squid3 3.1
    Dansguardian 2.10.1.1
    Postfix
    2.9.6

    When I attempt to 'Generate Report Now' using 'Squid Report Generator' on the Webmin module I get the following error message:

    Code:
    sarg -l /var/log/squid3/access.log mail: cannot send message: Process exited with a non-zero status
    SARG: command return status 36SARG: command: sudo mail -s "SARG report, Wed May  8 12:40:11 2013" "user@domain.com" <"/tmp/sarg/2013May08-2013May08/report"


    Sending mail via the 'Mail' command works fine. I was also getting error messages via email:


    Code:
    Failed to generate Sarg report:sarg -l /var/log/squid3/access.log
    SARG: getword backtrace:
    SARG: 1:sarg() [0x4091c7]
    SARG: 2:sarg() [0x4096c1]
    SARG: 3:sarg() [0x405caa]
    SARG: 4:/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xed) [0x7ff08ed3e76d]
    SARG: 5:sarg() [0x408981]
    SARG: Maybe you have a broken time in your access.log file
    SARG: getword loop detected after 255 bytes.
    SARG: Line=""
    SARG: Record=""
    SARG: searching for 'x20'


    I've tried various Source and Destination variations as well as changing the permissions on the log files themselves. This used to work when I had Sendmail installed but I recently switched to Postfix due to how complex Sendmail was and various other issues I was having (look at my other threads).

    Please can someone tell me what's going on?
    Thanks
    Last edited by Bullet333; 8th May 2013 at 07:33 PM.

SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS] XML to DOC/PDF (Indidual Reports from ASM)
    By tben2505 in forum MIS Systems
    Replies: 24
    Last Post: 14th March 2012, 12:05 PM
  2. Linux Guest cannot mount CD-ROM from host or client device
    By ranj in forum Thin Client and Virtual Machines
    Replies: 0
    Last Post: 5th January 2012, 11:54 AM
  3. Replies: 2
    Last Post: 4th October 2011, 05:50 PM
  4. Users cannot change AD passwords from Macs
    By sidewinder in forum Mac
    Replies: 7
    Last Post: 3rd October 2011, 05:33 PM
  5. [SIMS] Issue with reporting from Nova-T4 for new teachers
    By localzuk in forum MIS Systems
    Replies: 10
    Last Post: 20th June 2011, 07:42 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •