+ Post New Thread
Results 1 to 3 of 3
*nix Thread, Linux (freeBSD) filesystem problem from a noob in Technical; I have been experimenting with freenas (which runs on a version of freebsd) Trying some python things I noticed that ...
  1. #1

    Join Date
    Jan 2009
    Location
    Burton On Trent
    Posts
    143
    Thank Post
    24
    Thanked 30 Times in 22 Posts
    Rep Power
    17

    Question Linux (freeBSD) filesystem problem from a noob

    I have been experimenting with freenas (which runs on a version of freebsd)
    Trying some python things I noticed that the serial package isnt included in python on it.

    So I downloaded it, and followed the install instructions (python setup.py install)
    however it gives an error saying
    /usr/local/lib is mounted on a read only filesystem.

    How do I change this so that I can install this package?
    Anyone able to help or give pointers?

    Cheers
    Pete.

  2. #2

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,842
    Thank Post
    110
    Thanked 592 Times in 513 Posts
    Blog Entries
    1
    Rep Power
    226
    post the output from 'mount' and list the contents of '/etc/fstab'

  3. #3

    Join Date
    Jan 2009
    Location
    Burton On Trent
    Posts
    143
    Thank Post
    24
    Thanked 30 Times in 22 Posts
    Rep Power
    17
    mount
    /dev/ufs/FreeNASs1a on / (ufs, local, read-only)
    devfs on /dev (devfs, local, multilabel)
    /dev/md0 on /etc (ufs, local)
    /dev/md1 on /mnt (ufs, local)
    /dev/md2 on /var (ufs, local)
    /dev/ufs/FreeNASs4 on /data (ufs, local, noatime, soft-updates)
    Store1 on /mnt/Store1 (zfs, local, nfsv4acls)
    /etc/fstab
    /dev/ufs/FreeNASs1a / ufs ro 1 1
    /dev/ufs/FreeNASs3 /cfg ufs rw,noauto 2 2
    /dev/ufs/FreeNASs4 /data ufs rw,noatime 2 2
    /dev/ada1p1 none swap sw 0
    0
    /dev/ada2p1 none swap sw 0
    0
    /dev/ada3p1 none swap sw 0
    0
    I'm guessing it's the 'ro' part. But if I change it to rw, and then reboot, it changes back to ro
    :-(

    Hope you can help. Cheers
    Pete.



SHARE:
+ Post New Thread

Similar Threads

  1. FTP Client problems from 2008 r2 box
    By fox1977 in forum Windows Server 2008 R2
    Replies: 6
    Last Post: 23rd May 2011, 12:21 PM
  2. Linux - Best distro for a relative noob?
    By LosOjos in forum *nix
    Replies: 33
    Last Post: 12th October 2010, 12:47 PM
  3. Problem from the start with the computer
    By aliv25 in forum Links
    Replies: 15
    Last Post: 1st October 2007, 09:13 AM
  4. Replies: 2
    Last Post: 20th September 2006, 10:31 AM
  5. RIS problems from start to finish!!!
    By HodgeHi in forum Wireless Networks
    Replies: 12
    Last Post: 29th June 2006, 11:17 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •