+ Post New Thread
Results 1 to 12 of 12
*nix Thread, Webmin, Cannot get it to work.! in Technical; I wanted to try 'CentOS' for my home NAS & Backup-server, So I downloaded the net install iso and finally ...
  1. #1
    tickmike's Avatar
    Join Date
    Jul 2006
    Location
    South Derbyshire. U.K.
    Posts
    367
    Thank Post
    5
    Thanked 3 Times in 3 Posts
    Rep Power
    17

    Webmin, Cannot get it to work.!

    I wanted to try 'CentOS' for my home NAS & Backup-server, So I downloaded the net install iso and finally installed CentOS 6.3 with minimum server install.
    I then installed 'X Window System' And 'Gnome Desktop', That all went well, I then created a 'User' account, logged out of root and into user, then updated it.
    I have used 'Webmin' before on 'PCLinuxOS' so I wanted to try it on this distro and followed this to install it ...
    Install Webmin on CentOS 6.3 | Zwiegnet Blog 2012

    But I cannot get it to run in firefox !. http://file-server.localdomain:10000 ............ I just get 'Server not found'

    # service webmin status
    Webmin (pid 1724) is running

    # uname -a
    Linux file-server.localdomain 2.6.32-279.9.1.el6.i686


    There is no firewall on this test machine.

    Any idea's what I can try please.
    Last edited by tickmike; 11th October 2012 at 01:06 AM.

  2. #2

    Join Date
    Sep 2010
    Posts
    548
    Thank Post
    26
    Thanked 62 Times in 58 Posts
    Rep Power
    19
    when i tried this i just used the http://linuxmachinenameort.
    is the server set to allow incoming connections, it was either centos/ubuntu which needed the IPTABLES tweaking to allowing incoming traffic

  3. #3

    Join Date
    Nov 2011
    Location
    Somerset
    Posts
    66
    Thank Post
    2
    Thanked 5 Times in 5 Posts
    Rep Power
    6
    Have you tried using the urls : "http://localhost:10000" or "https://localhost:10000"

  4. #4

    twin--turbo's Avatar
    Join Date
    Jun 2012
    Location
    Carlisle
    Posts
    2,334
    Thank Post
    1
    Thanked 381 Times in 340 Posts
    Rep Power
    150
    it will be https

    do https://ipofserver:10000

    Rob

  5. #5
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,421
    Thank Post
    508
    Thanked 282 Times in 258 Posts
    Rep Power
    81
    OR it could be the firewall is blocking http or https.

    run this command:

    system-config-firewall-tui

    BEAWARE though system-config may not be install so you may need to run 'yum install system-config-firewall-tui'

    Once into system-config edit the firewall - scroll down the list and enable http and https and then go forward until you go to the end and apply it.

    This is done through CLI - I've never done it through Gnome Desktop - Ive never installed CentOS with a Desktop.

  6. #6
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,421
    Thank Post
    508
    Thanked 282 Times in 258 Posts
    Rep Power
    81
    anyway after you've done the firewall restart webmin with 'service httpd restart' and service webmin restart'.

  7. #7

    Join Date
    Sep 2010
    Posts
    548
    Thank Post
    26
    Thanked 62 Times in 58 Posts
    Rep Power
    19
    pulled from the webmin support pages: Webmin

  8. #8
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,421
    Thank Post
    508
    Thanked 282 Times in 258 Posts
    Rep Power
    81
    thats another way of doing it

  9. #9
    tickmike's Avatar
    Join Date
    Jul 2006
    Location
    South Derbyshire. U.K.
    Posts
    367
    Thank Post
    5
    Thanked 3 Times in 3 Posts
    Rep Power
    17
    Thanks all I will have another look tonight.

  10. #10
    tickmike's Avatar
    Join Date
    Jul 2006
    Location
    South Derbyshire. U.K.
    Posts
    367
    Thank Post
    5
    Thanked 3 Times in 3 Posts
    Rep Power
    17
    The one that worked was "http://localhost:10000" by ragbuster Thanks, I did not have to do anything else because I do not think that I installed / set up 'iptables'
    # service iptables status
    Table: filter
    Chain INPUT (policy ACCEPT)
    num target prot opt source destination
    1 ACCEPT all -- 0.0.0.0/0 0.0.0.0/0 state RELATED,ESTABLISHED
    2 ACCEPT icmp -- 0.0.0.0/0 0.0.0.0/0
    3 ACCEPT all -- 0.0.0.0/0 0.0.0.0/0
    4 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:22
    5 REJECT all -- 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited

    Chain FORWARD (policy ACCEPT)
    num target prot opt source destination
    1 REJECT all -- 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited

    Chain OUTPUT (policy ACCEPT)
    num target prot opt source destination




    Does that mean it's not running ?.
    The ' cli ' takes some getting used too !.

  11. #11

    Join Date
    Nov 2011
    Location
    Somerset
    Posts
    66
    Thank Post
    2
    Thanked 5 Times in 5 Posts
    Rep Power
    6
    If iptables is running it will be listed as running under the services application.
    Your rules from above show rejecting all forwarding and for your incoming you reject all initially and then allow all via all those rules.
    Well thats how it would be interpreted in webmin but not sure if cli mode shows it reversed, if so you are enabling all ports and then finally rejecting everything.

  12. #12
    tickmike's Avatar
    Join Date
    Jul 2006
    Location
    South Derbyshire. U.K.
    Posts
    367
    Thank Post
    5
    Thanked 3 Times in 3 Posts
    Rep Power
    17
    @ ragbuster
    In webmin it says

    -----------------------------------------------------------------------------------------------------------------------------------------
    Linux Firewall
    Rules file /etc/sysconfig/iptables Search Docs..


    Incoming packets (INPUT) - Only applies to packets addressed to this host
    Select all. | Invert selection.
    Action Condition Move Add
    Accept If state of connection is ESTABLISHED,RELATED
    Accept If protocol is ICMP
    Accept If input interface is lo
    Accept If protocol is TCP and destination port is 22 and state of connection is NEW
    Reject Always
    Select all. | Invert selection.

    Forwarded packets (FORWARD) - Only applies to packets passed through this host
    Select all. | Invert selection.
    Action Condition Move Add
    Reject Always
    Select all. | Invert selection.

    Outgoing packets (OUTPUT) - Only applies to packets originated by this host
    There are no rules defined for this chain.

    Click this button to make the firewall configuration listed above active. Any firewall rules currently in effect will be flushed and replaced
    Click this button to reset the configuration listed above to the one that is currently active.
    Yes No Change this option to control whether your firewall is activated at boot time or not.
    Click this button to clear all existing firewall rules and set up new rules for a basic initial configuration.


    ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    This is from 'Boot up and shutdown'
    iptables Starts, stops and saves iptables firewall Yes (start at boot) Unknown status


    ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    I will just use port 22xx for ssh to the server and block the rest if I dicide to use Centos for my NAS.
    once I have found my way around I will install raid 1 on it and do more tests.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 0
    Last Post: 29th October 2010, 09:29 AM
  2. Creating Home Folder.. and getting it to map for users
    By dgrams in forum How do you do....it?
    Replies: 16
    Last Post: 26th February 2010, 05:15 PM
  3. Replies: 7
    Last Post: 21st April 2008, 10:24 AM
  4. Problems getting joomla to work
    By krisd32 in forum Windows
    Replies: 21
    Last Post: 28th March 2006, 09:08 AM
  5. getting moodle to work on ubuntu
    By pcprofessor in forum *nix
    Replies: 6
    Last Post: 23rd February 2006, 09:07 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •