+ Post New Thread
Results 1 to 5 of 5
*nix Thread, OTRS LDAP/AD Authentication in Technical; is there any silly trick to get LDAP authentication working between AD & OTRS? I have this set $Self->{'AuthModule::LDAP::SearchUserDN'} = ...
  1. #1
    oxide54's Avatar
    Join Date
    Mar 2009
    Posts
    798
    Thank Post
    51
    Thanked 55 Times in 54 Posts
    Rep Power
    22

    OTRS LDAP/AD Authentication

    is there any silly trick to get LDAP authentication working between AD & OTRS?

    I have this set

    $Self->{'AuthModule::LDAP::SearchUserDN'} = 'otrs_ldap';
    $Self->{'AuthModule::LDAP::SearchUserPw'} = 'PASSWORD';

    but wireshark tells me

    bindrequest / simple / missing?

  2. #2

    Join Date
    Jan 2008
    Location
    Cheshire, UK
    Posts
    335
    Thank Post
    66
    Thanked 60 Times in 42 Posts
    Rep Power
    48
    Quote Originally Posted by oxide54 View Post
    is there any silly trick to get LDAP authentication working between AD & OTRS?
    Glad to see someone else is using OTRS. I haven't started using AD authentication yet, but it is on the 'I should look at that'. Anyway, have you looked at the documentation on the OTRS site.

    Customer user backend

    This also looked interesting Configuring OTRS to make Customers / Users authenticate via LDAP (MS Windows Active Directory)

  3. #3
    oxide54's Avatar
    Join Date
    Mar 2009
    Posts
    798
    Thank Post
    51
    Thanked 55 Times in 54 Posts
    Rep Power
    22
    found what the problem was, (normally do 3 seconds after posting )

    be careful most of the documentation on tinternet is for old versions and the config files have changed somewhat. so best to use the official documentation

    that link you linked to doesn't work with the new version, thats what i was using. the sync part where after it logs you in creates an entry in the database for the ldaP user is wrong, and you should check the official documentation
    Last edited by oxide54; 30th September 2012 at 11:28 PM.

  4. Thanks to oxide54 from:

    sjatkn (30th September 2012)

  5. #4
    oxide54's Avatar
    Join Date
    Mar 2009
    Posts
    798
    Thank Post
    51
    Thanked 55 Times in 54 Posts
    Rep Power
    22
    are you using IMAP with exchange?

  6. #5
    oxide54's Avatar
    Join Date
    Mar 2009
    Posts
    798
    Thank Post
    51
    Thanked 55 Times in 54 Posts
    Rep Power
    22
    No idea what i did, nut IMAP works with exchange now.

    Might blog my config when finished for other people.

    Thing is can i get two different ad domains working as customers!??

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 2
    Last Post: 6th January 2012, 06:20 PM
  2. Replies: 17
    Last Post: 18th August 2008, 02:03 PM
  3. MediaWiki LDAP AD authentication
    By plexer in forum How do you do....it?
    Replies: 7
    Last Post: 22nd February 2007, 08:54 AM
  4. CachePilot & LDAP/AD
    By beast_gts in forum Wireless Networks
    Replies: 6
    Last Post: 30th June 2006, 08:28 AM
  5. Replies: 5
    Last Post: 28th June 2006, 06:15 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •