Hi, I am baffeled I am trying to run VOIP traffic from an elastix server over a Cisco 870 router. Call quality is fine untill more then a few people start surfing the internet. I have tried to enable some QOS on the router but with it I can make one call and the rest just drops. I spend nearly a day surfing Cisco website and managed to come up with this config:



ip access-list extended DATA_TRAFFIC

permit tcp any any eq www

permit tcp any any eq 443

ip access-list extended VOIP_TRAFFIC

permit udp any any

permit tcp any any eq 5060

permit tcp any any eq 5061

permit tcp any any eq 10000

permit udp any any range 16348 32768

permit tcp any any eq 5060

permit ip 10.6.49.66 255.255.255.255 any



class-map VOIP_TRAFFIC

match access-name VOIP_TRAFFIC

class-map DATA_TRAFFIC

match DATA_TRAFFIC



policy-map VOICE_QOS

class VOIP_TRAFFIC

priority percent 30

policy-map DATA_TRAFFIC

class DATA_TRAFFIC

bandwith percent 50

policy-map class-default

fairqeue



I have tried applying it to the Dialer and ATM interface. The show policy map command shows hits on every class, but call quality still drops and line availaibility drops to one line availaible. Does any know what I am doing wrong or of a better config?