+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 24
Network and Classroom Management Thread, ClassRoomBookings! Images won't display!? in Technical; Hi guys, I've managed to install ClassRoomBookings with WAMPP but the images wont display? I'm guessing it's something to do ...
  1. #1

    Join Date
    Jun 2009
    Posts
    57
    Thank Post
    22
    Thanked 1 Time in 1 Post
    Rep Power
    0

    ClassRoomBookings! Images won't display!?

    Hi guys,

    I've managed to install ClassRoomBookings with WAMPP but the images wont display? I'm guessing it's something to do with permissions and CHMOD as all the image directory's are 100% correct. I've tried adding permission for IIS_IUSRS with full control but still no luck.

    Any ideas?

    Thanks

  2. #2

    john's Avatar
    Join Date
    Sep 2005
    Location
    London
    Posts
    10,422
    Thank Post
    1,531
    Thanked 1,066 Times in 931 Posts
    Rep Power
    305
    Do you mean CRBS as in written by our amazing @webman ?

  3. #3

    webman's Avatar
    Join Date
    Nov 2005
    Location
    North East England
    Posts
    8,417
    Thank Post
    644
    Thanked 965 Times in 665 Posts
    Blog Entries
    2
    Rep Power
    328
    Which images - icons within CRBS, or just room photos that you've uploaded?
    What are the URLs to the missing images? Do they exist on the filesystem at the location that the URL is pointing to?


  4. #4

    Join Date
    Jun 2009
    Posts
    57
    Thank Post
    22
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Yes CRBS,

    It look's as if it can't find any images or css e.t.c. I'll attach a screenshot.

    All the image directories point to the right place & the images are there in the folder.

    noimages.jpg

  5. #5

    webman's Avatar
    Join Date
    Nov 2005
    Location
    North East England
    Posts
    8,417
    Thank Post
    644
    Thanked 965 Times in 665 Posts
    Blog Entries
    2
    Rep Power
    328
    It looks like it's not loading the CSS files. Could you view-source of the page and paste the contents over at Pastebin.com - #1 paste tool since 2002!

    The <base> tag in the first few lines should look like this:

    Code:
    <base href="http://localhost/crbs/" />

  6. #6

    Join Date
    Jun 2009
    Posts
    57
    Thank Post
    22
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Quote Originally Posted by webman View Post
    It looks like it's not loading the CSS files. Could you view-source of the page and paste the contents over at Pastebin.com - #1 paste tool since 2002!

    The <base> tag in the first few lines should look like this:

    Code:
    <base href="http://localhost/crbs/" />
    No problem mate - CRBS - Pastebin.com

  7. #7

    webman's Avatar
    Join Date
    Nov 2005
    Location
    North East England
    Posts
    8,417
    Thank Post
    644
    Thanked 965 Times in 665 Posts
    Blog Entries
    2
    Rep Power
    328
    OK, open up the system/application/config/config.php file, and make sure that the first entry for base_url has a trailing forward slash at the end. E.g.:

    Code:
    $config['base_url'] = "http://localhost/crbs/";

  8. #8

    Join Date
    Jun 2009
    Posts
    57
    Thank Post
    22
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Amazing how something so small can fix it! It worked Should there be 2 images that wont display? One next to "My Profile" and one next to "Users"?

  9. #9

    webman's Avatar
    Join Date
    Nov 2005
    Location
    North East England
    Posts
    8,417
    Thank Post
    644
    Thanked 965 Times in 665 Posts
    Blog Entries
    2
    Rep Power
    328
    Yes I think that is just an incorrect file extension - check in webroot/images/ui for the correct naming, and just change it to what the URL of the image points to

  10. #10

    Join Date
    Jun 2009
    Posts
    57
    Thank Post
    22
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Brilliant mate, finally - When I add a room the field section comes up with the below error :/

    PHP.jpg

    Thanks for all ur help mate!

  11. #11

    webman's Avatar
    Join Date
    Nov 2005
    Location
    North East England
    Posts
    8,417
    Thank Post
    644
    Thanked 965 Times in 665 Posts
    Blog Entries
    2
    Rep Power
    328
    The warning appeared because there was no additional information entered into the room fields (if any have been defined). It can be ignored, but to turn those off:

    Open up the /crbs/index.php file and change the error_reporting line to 0:

    Code:
    error_reporting(E_ERROR);

  12. #12

    Join Date
    Jun 2009
    Posts
    57
    Thank Post
    22
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Brilliant mate, worked! Thanks

  13. #13

    Join Date
    Jun 2009
    Posts
    57
    Thank Post
    22
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I'm not sure if this is supported as it's in windows but I'm using WAMPP to host it. I've edited apache to allow people on my network to access http://<PC NAME> but the second they go to http://<PC NAME>/crbs it say's page cannot be found? Any ideas??

  14. #14

    webman's Avatar
    Join Date
    Nov 2005
    Location
    North East England
    Posts
    8,417
    Thank Post
    644
    Thanked 965 Times in 665 Posts
    Blog Entries
    2
    Rep Power
    328
    1) Check the Apache security settings so that it allows access from other machines on the network.
    2) Change the base_url (in the config.php file) from localhost to the hostname of the computer.

    At 1), test with IP address first, and then test by hostname. The WAMP menu should have an option to edit the Apache config file. There might already be a line that says "Allow from 127.0.0.0". Change this to "Allow from all".

  15. #15

    Join Date
    Jun 2009
    Posts
    57
    Thank Post
    22
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Quote Originally Posted by webman View Post
    1) Check the Apache security settings so that it allows access from other machines on the network.
    2) Change the base_url (in the config.php file) from localhost to the hostname of the computer.

    At 1), test with IP address first, and then test by hostname. The WAMP menu should have an option to edit the Apache config file. There might already be a line that says "Allow from 127.0.0.0". Change this to "Allow from all".
    2) did the trick! Thanks



SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Classroombookings
    By kestrel1 in forum Network and Classroom Management
    Replies: 17
    Last Post: 22nd November 2013, 05:03 PM
  2. Replies: 1
    Last Post: 26th January 2011, 03:46 PM
  3. Classroombookings - Hosted?
    By webman in forum Network and Classroom Management
    Replies: 16
    Last Post: 22nd January 2009, 10:38 AM
  4. Replies: 0
    Last Post: 19th March 2007, 03:58 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •