+ Post New Thread
Results 1 to 4 of 4
Network and Classroom Management Thread, LanView 4 and VLANs in Technical; Does anyone know how to get LanView4 to talk over different VLANs? I am able to get the server and ...
  1. #1
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,051
    Thank Post
    308
    Thanked 293 Times in 203 Posts
    Rep Power
    120

    LanView 4 and VLANs

    Does anyone know how to get LanView4 to talk over different VLANs?

    I am able to get the server and client talking in the same VLAN but as soon as the server is is a different VLAN on the same switch, it doesnt work.

    Thanks

  2. #2
    adhutton's Avatar
    Join Date
    Dec 2008
    Location
    Northeast England
    Posts
    404
    Thank Post
    164
    Thanked 86 Times in 64 Posts
    Rep Power
    54
    I have been trying to get this to work, but with not a lot of success...

    However, what I have been able to get working is to have two network cards in my PC. One card is on the main LAN and the other card is plugged in to our VLAN.

    That allows me to toggle between network connections and to view the two sets of machines (separately) via Lanview4.

    This, of course, is only any good if you only have a single VLAN, as multiple VLANS would require multiple additional network cards and connections to your PC.

    Not ideal, but it is working ok for me at the moment. Just thought I would share...

    Have you been able to find any other solutions to the VLAN issue?

    Andrew

  3. #3
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,051
    Thank Post
    308
    Thanked 293 Times in 203 Posts
    Rep Power
    120
    I found the way during the easter break..

    We have HP switches and i had to add IP FORWARD-PROTOCOL UDP {BROADCAST ADDRESS OF THE VLAN} {PORT}. Here is the config from one of our switches which was acting as the core switch in the test VLAN.

    Port 2104 is the sending port to the clients and port 2607 returns the status of the client. My admin machine was in VLAN1, client machines were in VLAN2 & 3 and it worked without any problems..

    Code:
    vlan 1
       name "DEFAULT_VLAN"
       untagged 14-21,23-24
       ip address 10.0.0.2 255.255.255.0
       ip helper-address 10.0.0.254
       ip forward-protocol udp 10.0.3.255 2104
       ip forward-protocol udp 10.0.2.255 2104
       ip forward-protocol udp 10.0.4.255 2104
       ip forward-protocol udp 10.0.5.255 2104
       ip forward-protocol udp 10.0.6.255 2104
       ip forward-protocol udp 10.0.7.255 2104
       ip forward-protocol udp 10.0.8.255 2104
       ip forward-protocol udp 10.0.9.255 2104
       ip forward-protocol udp 10.0.10.255 2104
       ip forward-protocol udp 10.0.11.255 2104
       ip forward-protocol udp 10.0.12.255 2104
       ip forward-protocol udp 10.0.13.255 2104
       ip forward-protocol udp 10.0.14.255 2104
       ip forward-protocol udp 10.0.15.255 2104
       ip forward-protocol udp 10.0.16.255 2104
       tagged 22
       no untagged 1-13
       exit
    vlan 2
       name "VLAN2"
       ip address 10.0.2.1 255.255.255.0
       ip helper-address 10.0.0.254
       ip forward-protocol udp 10.0.0.255 2607
       tagged 21-22
       exit
    vlan 3
       name "VLAN3"
       untagged 9-12
       ip address 10.0.3.1 255.255.255.0
       ip helper-address 10.0.0.254
       ip forward-protocol udp 10.0.0.255 2607
       tagged 21-22
       exit
    Since the HP Switches we have got only allow 16 entries and we wanted to have about 26 VLANS then we decided to go against it, to this day im looking for a switch which will flood VLANs with the IP FORWARD setting.

  4. #4
    adhutton's Avatar
    Join Date
    Dec 2008
    Location
    Northeast England
    Posts
    404
    Thank Post
    164
    Thanked 86 Times in 64 Posts
    Rep Power
    54
    I found this on the MST Software site, which may help anyone with CISCO switches:

    "It is possible by setting up on a cisco device:

    ON THE SENDING SUBNET

    ip helper-address SUBNET-BROADCAST-ADDRESS ie 192.168.1.255

    // This turns the 255.255.255.255 lanview broadcasts to a directed broadcast

    IN GLOBAL CONFIG

    ip forward-protocol udp 2607
    ip forward-protocol udp 2104

    // This allows the IP helper address to forward broadcast UDP packets on those ports

    create an ACL for filtering so only wanted directed broadcasts are forwarded:

    access-list 110 permit udp host LANVIEWSERVERIP any eq 2607
    access-list 110 permit udp host LANVIEWSERVERIP any eq 2104

    on the recieving subnet

    ip directed-broadcast 110

    On a layer 3 switch these are applied to the VLAN interfaces.

    And DONE!

    PS Dont blame me if you break stuff!
    "


    Please let me know if anyone has any other info. for CISCO switches.

    Andrew

SHARE:
+ Post New Thread

Similar Threads

  1. Lanview 4 help
    By jamin100 in forum Network and Classroom Management
    Replies: 33
    Last Post: 28th October 2011, 03:05 PM
  2. MST Lanview 3
    By adder1230 in forum Network and Classroom Management
    Replies: 41
    Last Post: 11th June 2010, 06:38 PM
  3. Lanview 4
    By Don__1 in forum Network and Classroom Management
    Replies: 14
    Last Post: 15th October 2009, 08:10 PM
  4. Lanview 3
    By dezt in forum Network and Classroom Management
    Replies: 1
    Last Post: 29th May 2009, 01:13 PM
  5. Lanview
    By mrtechsystems in forum Thin Client and Virtual Machines
    Replies: 3
    Last Post: 22nd March 2007, 10:25 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •